Dismiss Notice

to Ford Explorer and Ranger owner generated reviews, discussion, tech tips, how to articles, off-road modifications, events, and more! Since 1996 we have been the #1 Ford Explorer resource on the Internet. We also cover the Explorer Sport Trac, Mercury Mountaineer, Lincoln Navigator, Mazda Navajo, Mazda Pickups, and the Aerostar.

Register Today It's free! This box will disappear once registered!

  • Searches ExplorerForum.com
    JDraper
    Last Activity:
    January 28, 2017
    Joined:
    January 11, 2001
    Messages:
    15,330
    Trophy Points:
    58
    Positive ratings received:
    3

    Post Ratings

    Received: Given:
    Like 1 0
    Thanks 0 0
    Useful 2 0
    Disagree 0 0
    Home Page:
    Occupation:
    Sr. Development Engineer/Engineering & Application

    JDraper

    Somewhat Functional

    Moderator Emeritus
    JDraper was last seen:
    January 28, 2017
      1. davidk
        davidk
        RE: my Explorer 911 post: my problem has resolved - [oil change shows overfilled]. I tried to delete the post (don't think it would help anyone else) but I can't.

        It was a bizarre situation, for some reason the oil wouldn't drain, but now it does, and everything seems OK (cross my fingers).

        I figure as Moderator you can delete it.

        Take care,

        David
      2. dco43054
        dco43054
        Howdy!

        Might be time to unstick the sticky of my thread How to Fix Sirius / My Ford Touch Voice Commands in the MFT forum. It's not really that relevant with all the upgrades out there, and the big upgrade to v3.

        Thanks,

        Dave
      3. peterk9
        peterk9
        I sent a message this morning using the 'Contact Us' method about a problem I'm having posting photos. Have not received any response yet.
        I attempted to post a photo, 800x600, 140KB in jpg format but received the following when I attempted to upload it; This is not a valid image file.
        I even tried uploading a picture that I successfully uploaded within the past week and get the same error msg. Savving it as a bmp or gif also produced the same result.
        Any idea what the problem may be? I know the site was down for a while the other day. Could something have happened to cause this situation?

        Peter (peterk9)
    • Loading...
    • Loading...
    • About

      Home Page:
      http://users.nmax.net/users/jsrdraper/
      Occupation:
      Sr. Development Engineer/Engineering & Application
      City, State:
      McVeytown, PA
      Year, Model & Trim Level:
      '11 XLT
      Country - Optional:
      USA
      Vehicle Specs:
      YES
      Engine:
      3.5 DOHC
      Year:
      2011
      Transmission:
      6 Speed Auto
      Transfer Case:
      None
      Front Axle:
      Yes
      Rear Axle:
      Yes
      Lighting:
      Clear fogs
      Tires:
      Michelin's
      Wheels:
      Factory
      Audio/Video and Navigation:
      Factory
      Communications:
      MFT/Sync
      Sliders / Bumpers:
      None
      Accessories:
      Radar Detector, Crazy Driver
      Penn State Grad (Aerospace Engineering & Physics)...and just slightly more than mildly touched in the head... :)

      Mustangs, 4x4's

      Interact

      Signature

      Moderator..Home Improvement/Explorer 911/2011 Explorer Forum
      You took my breath away....and now I want it back....
      '66 Mustang Coupe, '04 Mustang Mach 1, '08 Focus, '11 Explorer XLT
      "Ex"plorer's: '92 Sport, '94 Sport, '01 XLS
      Our Crappy Website








    We Support Our Troops!