1. for access to reviews and discussion of the 2016 and 2017 Ford Explorer, Tech Tips, How to Articles, Off-Road Modification, Events, and more!

    Register Today It's free! This box will disappear once registered!

2000 ranger lean bank 1

Discussion in 'Stock 1995 - 2001 Explorers' started by stren_g, November 10, 2012.

  • Searches ExplorerForum.com
    1. stren_g

      stren_g New Member

      Joined:
      January 10, 2010
      Messages:
      12
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      ne
      Year and Model:
      2003, 2000
      I've done many searches previously for a lean bank 2 problem. I found a vacuum leak at the upper intake manifold, so I replaced the gaskets. Cool, cel went off for a while and then came back on with p0171 code. I read that this is lean bank 1, I couldn't find any vacuum leaks this time so I cleaned the maf and iacv, no dice. What could be causing this? Could it be o2 sensors, should I check fuel pressure, or...? Is there a way to check the o2 sensors?
       
    2. Support EF


      Join the Elite Explorers for $20 a year

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, add your own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



      to hide adverts.

    Share This Page








    We Support Our Troops!