and gain access to Reviews and Discussion of the 2016 and 2017 Ford Explorer Tech Tips, How to Articles, Off-Road Modifications and Events, Street Truck Mods and Events, and much more! Since 1996 our community has covered every aspect of the Ford Explorer, Ford Ranger and all vehicles based on this platform.

Register Today It's free! This box will disappear once registered!

2003 Ford Explorer with a check engine light.

Discussion in 'Stock 2002 - 2005 Explorers' started by babygurl04tn, March 28, 2010.

  • Searches ExplorerForum.com
    1. babygurl04tn

      babygurl04tn New Member

      Joined:
      March 28, 2010
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Greeneville,TN
      Year and Model:
      2003 XLT
      Hey everyone. I am new to this site. I stumbled upon it while trying to get some ideas as to what could be wrong with my Explorer. One thing it was doing, although it ran fine, was when we went to put gas in. The pump would shut off like the gas tank was full, even if it was nowhere near full. This is not a primary concern of mine at the moment because it still ran with this problem. When it first started messing up we were just driving down the rd and the overdrive light started flashing and the rpms went to like 4000. The temp gauge also sunk all the way to cold. That problem went away somehow on its on. It just happened that one time. The next time it messed up I had turned it off to get gas. When I went to crank it, it would not start. I noticed that the oil gauge was all the way to empty and the gas gauge said I had a full tank, when I know that I should have only had around 1/2 tank. I pumped the gas pedal a cpl of times while trying to start it and it started right up. The 4x4 high and low light started flashing at that time. That method of starting it worked for a few days. The last time it ran we kept it running when we stopped for something to eat so we wouldnt have to fight with it to start. It died. It hasnt ran since. Please help me out!! I would appreciate it so much.
       
    2. Support EF


      Join the Elite Explorers for $20 a year

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, add your own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



      to hide adverts.
    3. BrooklynBay

      BrooklynBay Staff Member Moderator Elite Explorer

      Joined:
      November 11, 2005
      Messages:
      50,753
      Likes Received:
      12
      Trophy Points:
      58
      City, State:
      Brooklyn, NY
      Year and Model:
      88 89 93 95 96 Aerostars
    4. jrford

      jrford Well-Known Member

      Joined:
      March 1, 2005
      Messages:
      2,537
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Birmingham, MI
      Year and Model:
      '10 Sport Trac
      with all those lights, it should or hopefully posted a CEL. Gas gage can be slow to react it the nature of the thing, pumping the pedal really doesn't do anything with fuel injection by the way.


      starting sounds like - maybe a fuel problem, might be overflow EVAP, fuel filter, fuel pump???? should have a CEL if so. I look for a fuel pressure test.

      O/D light 4x4, slipping gear, maybe a transmission issue it should have a CEL.

      good luck, i never really ever suggest it, but this one sounds like a stealership fix. . .or a good mechanic. Post back what they find. ..
       

    Share This Page


    Click Here

    We Support Our Troops!