1. for access to Ford Explorer and Ranger owner generated reviews and discussion, tech tips, how to articles, off-road modifications, events, and more! Since 1996 we have been the #1 Ford Explorer resource on the Internet. We also cover the Explorer Sport Trac, Mercury Mountaineer, Lincoln Navigator, Mazda Navajo, Mazda Pickups, and the Aerostar.

    Register Today It's free! This box will disappear once registered!

2004 explorer service engine soon light on

Discussion in 'Stock 2002 - 2005 Explorers' started by mamd1996, September 1, 2007.

  • Searches ExplorerForum.com
    1. mamd1996

      mamd1996 New Member

      Joined:
      September 1, 2007
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Jersey Girl
      Year and Model:
      2004 Explorer XLT
      I took my 2004 explorer xlt (56,000 miles, no other problems)
      The "service engine soon" light came on
      The idiots at the ford dealership said they don't know whats wrong with my suv!
      Possible things: my computer chip is not working right or my fuel pump is going?

      Don't they just hook up the suv to a diagnostics thingy?

      I'm a girl so I have no clue about this stuff!

      I have only done oil changes every 3 months, and changed the air filter.
      Otherwise, the suv has had no other service.

      Does anyone have any suggestions as what should be done or what the problem could be?

      Thanks!
       
    2. Support EF


      Join the Elite Explorers for $20 a year

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, add your own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



      to hide adverts.
    3. jrford

      jrford Well-Known Member

      Joined:
      March 1, 2005
      Messages:
      2,538
      Likes Received:
      0
      Trophy Points:
      46
      City, State:
      Birmingham, MI
      Year and Model:
      '10 Sport Trac
      I would suggest trying another dealer. As yes you are correct there is a diagnostic thingy that can be hooked up - sometimes its called a diagnostic scanner. Asked them 'what codes did you pull?'. Then post your codes here, maybe someone can confirm what they are. At this point it could be anything. Maybe your gas cap is lose . . . oil fill cap . . . they should be able to tell you something and if not leave. Note there may be a charge to hook up the tool or as they call diagnostic service - $45 - and yes it’s a rip off.
       
    4. BrooklynBay

      BrooklynBay Staff Member Moderator Elite Explorer

      Joined:
      November 11, 2005
      Messages:
      50,953
      Likes Received:
      23
      Trophy Points:
      58
      City, State:
      Brooklyn, NY
      Year and Model:
      88 89 93 95 96 Aerostars
    5. dford

      dford New Member

      Joined:
      December 4, 2006
      Messages:
      49
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Bethesda, Md.
      Year and Model:
      2003 XLT
      My 03 with 93K recently had the "check gas cap" light come on and then as the owner's manual stated, the "service engine soon" light soon came on. The gas cap seems ok to me---do they fail? Does anyone know what this might be? The truck runs great despite the warning lights. There is no AutoZone near me and I'd hate to buy a scanner if I don't need to.
       
    6. BrooklynBay

      BrooklynBay Staff Member Moderator Elite Explorer

      Joined:
      November 11, 2005
      Messages:
      50,953
      Likes Received:
      23
      Trophy Points:
      58
      City, State:
      Brooklyn, NY
      Year and Model:
      88 89 93 95 96 Aerostars
    7. dford

      dford New Member

      Joined:
      December 4, 2006
      Messages:
      49
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Bethesda, Md.
      Year and Model:
      2003 XLT
      I had refueled after the warning lights had come on. It has been about a week now and they still haven't reset themselves yet.
       
    8. BrooklynBay

      BrooklynBay Staff Member Moderator Elite Explorer

      Joined:
      November 11, 2005
      Messages:
      50,953
      Likes Received:
      23
      Trophy Points:
      58
      City, State:
      Brooklyn, NY
      Year and Model:
      88 89 93 95 96 Aerostars
    9. JCUZ

      JCUZ Well-Known Member

      Joined:
      September 4, 2007
      Messages:
      1,253
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Canberra, Australia
      Year and Model:
      2004 Explorer Limited V8
      My 2004 XLT has just done the same thing (lit up the Service check light) - this was after I fitted a monster 9" K&N filter to it and took it for a run, so maybe I kinked a hose running under the intake tubing or something. The truck still goes great though - in fact the K&N is a massive improvement over the stock filter - especially as mine looked like it had been dipped in mud. Anyway, I digress....

      Is there any way (other than a scantool) to clear the code. If not, anyone know where I can get a cheap scantool that works? I'm in Australia so can't go to your local auto store, but am happy to order on-line etc.
       
    10. Maniak

      Maniak Moderator-Stock 91-94 Staff Member Moderator Elite Explorer

      Joined:
      February 9, 1999
      Messages:
      11,999
      Likes Received:
      7
      Trophy Points:
      58
      City, State:
      Vail, Arizona
      Year and Model:
      1992 XLT 4x4
      This code scanner is on sale @ harborfreight for $64

      [​IMG]

      If you have a local harbor freight just print out the web page with the price an they will honor it.

      If you don't have a local HFT you can mail order it...

      I personally have this scanner and have used it on our 2006 mustang.. It works great. It will give you the current and pending codes and support the new CAN protocol.

      http://www.harborfreight.com/cpi/ctaf/displayitem.taf?Itemnumber=94217

      ~Mark
       
    11. JCUZ

      JCUZ Well-Known Member

      Joined:
      September 4, 2007
      Messages:
      1,253
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Canberra, Australia
      Year and Model:
      2004 Explorer Limited V8
      Thanks for the tip - I couldn't see international postage at Harbour Tools, but used the product description to find the same thing on ebay for under $40 USD (plus postage, of course):

      http://cgi.ebay.com/ebaymotors/Auto...014QQitemZ330162725220QQrdZ1QQsspagenameZWDVW

      [​IMG]
      I have mine ordered and it will arrive next week. Again, thanks for the tip/link - much appreciated.
       
    12. ViperGTS

      ViperGTS New Member

      Joined:
      July 26, 2007
      Messages:
      4
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      South Jersey
      Year and Model:
      '02 Mountaineer v8
      The code reader will find the problem. My experience with check engine lights on other cars has been the oxygen sensors going bad. Usually easy to replace and not too expensive if you buy them online.
       
    13. gpaps

      gpaps New Member

      Joined:
      June 13, 2000
      Messages:
      26
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Philadelphia, PA
      Year and Model:
      2002 XLT 4.6L V8
      I have the same problem with the "service engine soon light". Went to Autozone and they scanned that is was the EGR valve. He scanned 3 x's to make sure and the computer gave him the same reading. I changed the EGR valve with factory EGR valve and had the computer reset. I drove the car to work the next day and on the way home the light came back on. I had it scanned again and the computer said the same thing the EGR valve needs to be replaced. What else could it be that is setting off this light since the EGR valve is brand new? Anyone know or had the same problem. Thanks.
       
    14. BrooklynBay

      BrooklynBay Staff Member Moderator Elite Explorer

      Joined:
      November 11, 2005
      Messages:
      50,953
      Likes Received:
      23
      Trophy Points:
      58
      City, State:
      Brooklyn, NY
      Year and Model:
      88 89 93 95 96 Aerostars
    15. 1962dude

      1962dude New Member

      Joined:
      October 1, 2008
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Deer Park, Texas
      Year and Model:
      2004 XLS
      Hi there -- long time listener but first time....poster?

      My 2004 XLS had its "Service Engine Soon" light come on roughly a month ago. I tried to hedge my bets first by getting the oil changed and then buying a new gas cap but the light never went off. The gas cap bit fixed my wife's Dodge Stratus "Check Engine" light woes, thought it was worth($16) a try.

      My fuel filter is original(78,000 miles) and was about to change that next but had yet to find the jiffy Lube open after hurricane Ike left us a bit scattered a couple of weeks ago.

      I finally dropped in at a AutoZone store where they read the codes for me and it was the EGR valve and here is all that it stated.

      "The ECM has detected too little flow on the EGR system"

      Probable causes:
      1 -- Blocked passage on the EGR system
      2 -- Failed EGR valve
      3 -- EGR solenoid faulty
      4 -- Failed EGR pressure sensor where applicable
      5 -- Failed EGR position sensor where applicable

      The guy at AutoZone said I might just need to remove the valve and blow it clean/clean it off(out?) to get the light to go out. I haven't done anything yet since this is merely the "Exhaust Gas Recirculation" valve and find it unlikely that the truck will just suddenly stop in its tracks until I haul it in to the dealership to fix the problem.

      Also, if you change it yourself just unhook the positive battery lead for a few minutes and then hook it back up. That will reset the system for you. Works on most other vehicles anyway.

      Any suggestions?
       
    16. easy2no

      easy2no New Member

      Joined:
      September 29, 2008
      Messages:
      26
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Kemah, TX
      Year and Model:
      05 Limited
      My 05 had a check engine light with a code P0401... EGR same as yours... However on the 05 the EGR & DPFE sensor are one unit, not seperate like earlier ones... Big $$$ locally but found a new motorcraft on line for half price... Will arive 10/2 and hopefully will fix the problem...
       
    17. rednekborn1989

      rednekborn1989 New Member

      Joined:
      September 30, 2008
      Messages:
      10
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      leesburg,FL
      Year and Model:
      2001 Ford Ranger Edge
      just take the truck to a part store like autozone and they can hook up the scanner and tell you what the problem for free as long as the light is still on if it isnt than there is no point. hope this helps
       
    18. tv4fish

      tv4fish Member

      Joined:
      October 16, 2007
      Messages:
      97
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Minnesota
      Year and Model:
      2007 EB V8 & 2002 EB V6
      I had it scanned again and the computer said the same thing the EGR valve needs to be replaced. What else could it be that is setting off this light since the EGR valve is brand new? Anyone know or had the same problem. Thanks.

      You betcha' -- EXACT same problem - I have replaced the EGR valve and ONE of the oxygen sensors - STILL have the same code come up "EGR valve" (2002 Eddie Bauer w/4.0 L engine)
       
    19. easy2no

      easy2no New Member

      Joined:
      September 29, 2008
      Messages:
      26
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Kemah, TX
      Year and Model:
      05 Limited
      You may want to check the tube leading into the EGR valve... If you have been using fuel additives or premium could be some gunk build up in it... Also check to make sure the gasket was installed the correct way...
       
    20. tv4fish

      tv4fish Member

      Joined:
      October 16, 2007
      Messages:
      97
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Minnesota
      Year and Model:
      2007 EB V8 & 2002 EB V6
      Gasket was installed correctly - tube looked fine - no additives used - Upon checking further - now I will just need to spend ANOTHER $35 +/- for a "DPFE sensor" - as that apparently could be the culprit:mad::mad:
       
    21. GTXALEX

      GTXALEX New Member

      Joined:
      May 19, 2014
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      NY
      Year and Model:
      1995 EXPLORER
      Egr problems

      Hello all, had the same problem on my Interceptor Crown Vic, I replaced the EGR and still same code. I removed the tubes to the other flow sensor, clean as could be. Swapped out the other flow sensor, same code!
      I removed the throttle body and the EGR passage was CLOGGED!!!.
      A little cleaning and no codes!
      Hope this helps someone!
       
    22. 01fordexploder

      01fordexploder New Member

      Joined:
      January 17, 2007
      Messages:
      8
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Baltimore MD
      Year and Model:
      01 Exp Spt, 01 XLT, 04 EB
      seems to be confusion on model years...
      the 2004 and up utilizes a ECM combination DPFE/EGR unit
      03 and below had separate EGR valve and DPFE sensor...
      usually problems stem from gunk accumulation in the DPFE holes throwing up a code for an EGR code or there could be hose cracks..in 03 and below check the hoses first then DPFE sensor before replacing an EGR..04 and above check hoses first and then replace the whole assembly (ECM) refer to search part CX2102 on 2004 (&05?)
       

    Share This Page








    We Support Our Troops!