for access to Reviews and Discussion of the 2016 and 2017 Ford Explorer Tech Tips, How to Articles, Off-Road Modification, Events, and more!

Register Today It's free! This box will disappear once registered!

2004 V8 Explorer check charging system problem.

Discussion in 'Stock 2002 - 2005 Explorers' started by kent tango, November 28, 2008.

  • Searches ExplorerForum.com
    1. kent tango

      kent tango New Member

      Joined:
      November 28, 2008
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      2004 Explorer Eddie Bauer
      I am a new forum member and found a similar problem to the one I have where a 05 explorer V6 owner had a "check charging system" problem but never posted a solution?? I have had a similar problem with my 04 Explorer V8 (w/ tow package), but many trips to Ford dealers and private mechanics have not solved the problem. I have added a new battery and alternator, and during the latest dealer siege of three weeks, they tried (2) new PCM's, did a grid (wiring harhas) overlay test and they still have not solved the problem?? The "check charging system and battery light" still come on regularly. The system is charging OK but misses occasionally under light load?? Dealer now says I need a new $1,400 (primary) wiring harnas. The dealer says he "believes" that is the solution (even though he could not find it), but also says it might need one or two other harnaces if that doesn't work. The Explorer only has 37K and is well maintained (Mobile 1 etc.) This is getting out of hand and driving me nuts!! I need a reliable tow vehicle soon!! to make a trec south with my trailer in January and February. Any help would be appreciated!!! -Kent-
       
    2. Support EF


      Join the Elite Explorers for $20 a year

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, add your own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



      to hide adverts.
    3. Sams01XplrSprt

      Sams01XplrSprt Southern Cali Explorer

      Joined:
      November 14, 2004
      Messages:
      15,667
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Newport Beach California & Bay Area California
      Year and Model:
      2001 Sport (sold)
      welcome kent
       
    4. BrooklynBay

      BrooklynBay Staff Member Moderator Elite Explorer

      Joined:
      November 11, 2005
      Messages:
      50,869
      Likes Received:
      18
      Trophy Points:
      58
      City, State:
      Brooklyn, NY
      Year and Model:
      88 89 93 95 96 Aerostars
      Welcome to this forum! Your charging system doesn't have that many separate harnesses that it should cost that much. Check Autozone's website for a schematic diagram. You could check each wire from point to point with a continuity tester.
       
    5. fkatende

      fkatende New Member

      Joined:
      February 9, 2014
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      2004 ford explorer
      i just acquired a 2004 ford explorer XLT and has the similar problem 'check charging system'. i have looked at various problem and seems like its a common problem and there is no lasting solution to it.......has some one out there managed to have it fixed for good..help..!
       
    6. mikebusc

      mikebusc New Member

      Joined:
      February 15, 2014
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      2004 Mercury Mountaineer
      Looks Like you responded to an old post (2009). I have the same problem. Going to try tomorrow changing battery and checking belt and alternator. Let me know if you find anything too.
       
    7. westernMdlife

      westernMdlife New Member

      Joined:
      October 23, 2013
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      2004 Explorer XLT
      I've been having this problem for the last week. It will start up but the alternator doesn't charge the battery back up. I started it and kinda "jump started"/excite the I term on the alternator and it began to charge properly, until I turn the engine off. Replaced the alternator (new), battery is 2yrs old but still good. Have the constant hot to the alternator, continuity on stator wire is good. Only thing I'm left with is something with the ignition switch? ..IDK..
       
    8. name420420

      name420420 New Member

      Joined:
      May 6, 2014
      Messages:
      30
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Fairmont,West Virginia
      Year and Model:
      2002 ford explorer 4.6L
      mine had this issue. was a broken wire in the harness by the battery. I also am told their is a fuse by the alternator itself. but not sure about that
       
    9. phouse

      phouse Member

      Joined:
      March 8, 2001
      Messages:
      76
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Phila PA
      Year and Model:
      1991 Explorer
      Have you tried a alternator from the Ford Dealership?
       

    Share This Page









    We Support Our Troops!