Dismiss Notice



Register Today It's free! This box will disappear once registered!

2005 Explorer XLT - No lower heat

Discussion in 'A/C & Heater systems - HVAC' started by Bruce F, January 17, 2018.

  • Searches ExplorerForum.com
    1. Bruce F

      Bruce F New Member

      Joined:
      January 17, 2018
      Messages:
      2
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Newtown, CT
      Year, Model & Trim Level:
      2005 Explorer XLT
      I have heat in both the upper vents and defroster but there is no heat coming from the lower (foot) vents no matter what position the vent dial is in. Also, there is no clicking noise I've read about it other posts. Greatly appreciate any ideas. Thanks guys and gals!
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. Bruce F

      Bruce F New Member

      Joined:
      January 17, 2018
      Messages:
      2
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Newtown, CT
      Year, Model & Trim Level:
      2005 Explorer XLT
      Nothing? Really!
       

    Share This Page







    We Support Our Troops!