Dismiss Notice



Register Today It's free! This box will disappear once registered!

2016 explorer XLT AWD terrain management system fault

Discussion in 'Stock 2011 - 2019 Ford Explorer Discussion' started by Ayman20, January 13, 2018 at 2:30 PM.

  • Searches ExplorerForum.com
    1. Ayman20

      Ayman20 New Member

      Joined:
      Saturday
      Messages:
      3
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Montreal
      Year, Model & Trim Level:
      2016 explorer XLT AWD
      A day with heavy snow. Using the snow mode then
      I got the message of terrain management system fault + service advance Trac


      Now unable to select the snow mode !!

      What is the problem ?

      20180113_135842.jpg
       
    2. Support EF

      Join the Elite Explorers for $20 for 2 years!

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. Woah322

      Woah322 New Member

      Joined:
      November 3, 2017
      Messages:
      11
      Likes Received:
      0
      Trophy Points:
      3
      City, State:
      SI,NY
      Year, Model & Trim Level:
      17 Explorer Sport
      I’ve had the same error message after extended use, I just shut the car off let it cool and restart it and solved the issue
       
    4. NunavutExplorer

      NunavutExplorer New Member

      Joined:
      August 27, 2017
      Messages:
      23
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Nunavut
      Year, Model & Trim Level:
      '17 XLT 3.5 App/Tech pkg
      Is it just the 2 faults? If there is ABS/Hillstart assist/Hill descent/etc then it is an ABS sensor. Just went through this recently on my 17 received last August and local shop scanned codes and came up with the rear abs sensor. So he took a look at all 4. 2 rear ones were the same bad and worn out. There is a small magentic strip with the abs sensor that goes bad. The other side was similar and he figured only had a couple weeks left til it goes too. So he recommended to purchased dealer that both rears be replaced. Fronts were good yet as the rears see most of dust/dirt/snow when driving. Mind you all our roads are gravel roads so that didn't help longevity, but Ford shouldn't have only assumed these vehicles will only drive on pavement as dirt roads are all over the continent.

      My problem also started on a heavy snow day and blowing snow situations and guess they got iced up and faulted the already worn sensors.
       
    5. KayGee

      KayGee Active Member

      Joined:
      March 27, 2017
      Messages:
      177
      Likes Received:
      21
      Trophy Points:
      28
      City, State:
      Farmington, MI
      Year, Model & Trim Level:
      '16 & '17 PIU
      Have you had it scanned for codes? If so, what were they?
       

    Share This Page







    We Support Our Troops!