and gain access to Reviews and Discussion of the 2016 and 2017 Ford Explorer Tech Tips, How to Articles, Off-Road Modifications and Events, Street Truck Mods and Events, and much more! Since 1996 our community has covered every aspect of the Ford Explorer, Ford Ranger and all vehicles based on this platform.

Register Today It's free! This box will disappear once registered!

91 XLT Fuel Gauge question

Discussion in 'Stock 1991 - 1994 Explorers' started by mthomas4147, August 17, 2012.

  • Searches ExplorerForum.com
    1. mthomas4147

      mthomas4147 New Member

      Joined:
      April 21, 2012
      Messages:
      8
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      1991 Explorer XLT
      Hello Again, this forum has been most helpful in bringing my old '91 back to daily driver status - approaching 300K miles with one rebuild on the engine and transmission. Latest maintenance issue was resolved by replacing fan, fan clutch, water pump, and serpentine belt. All went smoothly, after reading a variety of posts on what to look out for... so thanks for that. The last thing I did was to wash off the corrosion on the battery cable clamp and flush the battery tray with clean water. I buttoned up the project, checked the coolant levels etc and called it a day.
      In the morning I started the engine, and noticed that the fuel gauge was reading 3/4 full, but I really didn't pay attention as to what the needle did on startup - and this is the crux of my question to the group -

      I simply can't remember if the fuel gauge needle just stays at the current fuel level when the engine is shut off, or does it do a reset from E and then travel to the current fuel level ? I ask this because I know that the fuel tank is full, to the filler neck. And now it's showing only 3/4 full.

      If I turn off the engine, and then restart - the fuel gauge needle backs up to 1/2 full and then travels to the 3/4 position - AND a bit more. So if I do this process 3-4 times I can get the gauge needle to move a bit more after each attempt and now it's reading Full. I'm not sure if it's going to stay there, or drift backwards or report correctly from here on forward.

      Summary of questions >>
      1) what is a correctly functioning fuel gauge supposed to do on engine shutdown / and then startup. ie stay at current level or do some sort of reset?

      2) Any ideas as to what has caused/ or is causing this issue? And could it be related to any of the service items I covered when I changed out the waterpump , battery cleanup etc?

      3) And lastly Is there any way to force a reset to the fuel gauge to "zero" it out, so at least I know it "knows" where the starting point is for fuel level..?

      Thanks again for all the assistance.
      Mike
       
    2. Support EF


      Join the Elite Explorers for $20 a year

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, add your own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



      to hide adverts.
    3. Anime

      Anime EF YEAH!! Elite Explorer

      Joined:
      November 6, 2000
      Messages:
      5,427
      Likes Received:
      0
      Trophy Points:
      46
      Year and Model:
      2016 EX Sport Concept
      The fuel gauge isn't supposed to do anything on shutdown. It's not receiving any electrical signal with the engine off, so the needle may or may not go down. Often it just goes down some, then goes back to reading the actual fuel level on startup. It will not do any sort of reset, since the level is read by a float, not an electrical sensor like some newer vehicles. Those higher-tech gauges will do like you're thinking, and "reset" each time the vehicle is started.

      It could be anything to do with the electrical connections from the fuel pump float, the fuel pump itself, or the wiring from the pump to the gauge. Most common is the fuel pump itself, especially if it's the original pump at 300,000 miles. It could also be the float as well, they can get rusted and develop a leak, allowing some fuel in, which of course compromises the ability to float on the surface.

      The fuel gauge doesn't work like you're thinking, it doesn't have an absoloute "zero" for empty and 100% for full. It's just an analog gauge designed to indicate an approximate level of fuel in the tank.


      My suggestion would be to take a flashlight and pull back the fabric flaps above the fuel tank and take a look at the top of the pump. If it looks rusted solid and/or is falling apart then that's a good sign you might want to think about investing in a new pump assembly. You should also inspect the wiring running from the pump, along the left side frame rail, and into the engine compartment.

      It is possible the gauge itself has gone wonky, but my guess would be the pump itself. A whole new assembly fixes a lot of things, and also provides a bump in performance, as old pumps wear out. I recommend the full stainless assembly from NAPA, I think it's a Carter brand pump sold as NAPA. Costs about $100 but is well worth it. You'll also need a fuel pump lock ring and gasket, the old one will turn into scrap the instant you remove it.
       
    4. mthomas4147

      mthomas4147 New Member

      Joined:
      April 21, 2012
      Messages:
      8
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      1991 Explorer XLT
      Thanks for the quick reply, and a clear explanation as to how the gauge really works.

      - some additional details that might round out the discussion. The fuel pump was replaced by the dealer around 85K miles ago. It was really "buzzing" at startup, no real performance issues but really annoying.
      So I'll give it a look to see if there is anything going with it.

      I guess my question revolves around the timing of the whole issue - as I've never had a problem with the gauge function in the past.

      The fan / waterpump issue problem happened a couple of months ago, with it really making a rattle - so the car was parked for the entire time until I had the opportunity to change out all the parts...so the car just sat there. The first time that I started it was just to check out the function of the cooling system - and then noticed the issue with the gauge.

      So I suspected that I must have bumped a wire under the hood, or got water on something when I washed off the battery etc. ?

      As a side question, I read through a variety of posts on the forum speaking to other fuel gauge issues folks have had on their vehicles. Apparently there are multiple "modes" of operation - anti slosh etc, and associated times related to gauge resetting. Do you know offhand if these functions were also part of the 91 instrument design? The fact that multiple starting attempts affects the position of the needle as it relates to fuel level seems to point out something in that direction?

      I'm going to poke around tomorrow to see if I can narrow down the symptoms etc, but my overall concern is whether or not I can trust this gauge from here on out.
      Thanks again.
      Mike
       
    5. Corik

      Corik Member

      Joined:
      July 15, 2011
      Messages:
      86
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      CA
      Year and Model:
      Explorer '91 XLT 4x4 A4LD
      My fuel gauge does the exact same thing, its annoying when I fill up on gas. but only seems to happen if I fill the tank completely.

      When I first noticed it, I thought the gas station was ripping me off, but as you said when I turned the key on and off it moved up and as I drove away it finally read full.
      I may need an assembly too.
       
    6. mthomas4147

      mthomas4147 New Member

      Joined:
      April 21, 2012
      Messages:
      8
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      1991 Explorer XLT
      Fuel Gauge Update

      I drove enough to empty the tank, refilled it completely to the filler neck. The gauge updated correctly after about 20 minutes of driving. I suspect this has something to do with the anti-slosh, and the different modes this fuel system has for updating itself...the fact that the float was exercised from completely full > empty > full ...might have reset something that was hanging up?

      Upon shutting down the engine, the gauge backs up approximately about 1/8 of a tank's worth of needle movement. Restarting the engine the needle makes it's way back to the original level prior to shut down. Pretty flaky operation, but it seems to be as smart as a door bell...

      I'll track this for awhile, and if anything changes I'll update the post. Now on to converting the fuel pressure regulator over to a '92 version, so I can finally get the fuel feed-line leak fixed once and for all..

      Thanks again for the replies...
       
    7. rodb

      rodb Active Member

      Joined:
      July 24, 2012
      Messages:
      120
      Likes Received:
      0
      Trophy Points:
      16
      City, State:
      SoCal
      Year and Model:
      1991 Eddie Bauer 4x4
      My '91 does almost same thing except even if I run it down to empty on the gauge, put in 18 gallons and it only reads 3/4 full, have tried several times but gauge won't go any higher.
       
    8. knb416

      knb416 New Member

      Joined:
      November 5, 2008
      Messages:
      21
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Calhoun, KY
      Year and Model:
      1994 XLT
      It could be that your anti-slosh module is on the verge of failing. My fuel gauge acted all wonky for over a year and when I put another module in it worked perfectly.

      As for actually installing the module, all I had to do was remove the trim and a few bolts/screws. I have seen where some have said that the speedometer cable had to be disconnected from the back of the instrument cluster in order to access the module. Luckily I didn't have to. On my 94' I was able to pull it out just enough that I could remove the old module and slide the replacement back in. It was on the left side side of my instrument cluster, and about the size of a credit card cut in half.

      I hope this helps. Good luck!
       
      Last edited: August 23, 2012
    9. mthomas4147

      mthomas4147 New Member

      Joined:
      April 21, 2012
      Messages:
      8
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      1991 Explorer XLT
      The only other suggestion I have to try - and I can't vouch for any "engineering" reason for the gauge behaving this way - is to see if the needle will reset it's resting position by turning the ignition switch to the ON ( don't have to start the engine) position and let the needle travel to where it thinks it needs to go. Then turn the switch to the OFF position. Repeat this action and see if the needle gains any movement towards the "F" position. I did this and I could get the needle to eventually hit the full extent of travel in the gauge.

      Failing this, I guess the anti-slosh module is the next thing to check out. I have the advantage that the fuel pump / float assembly was changed out on my vehicle and I hope that buys me at least one thing I don't have to consider. Good luck.
       
    10. Turdle

      Turdle Check it out Staff Member Moderator Elite Explorer

      Joined:
      June 16, 2003
      Messages:
      26,876
      Likes Received:
      32
      Trophy Points:
      68
      City, State:
      Humboldt, KS
      Year and Model:
      2000 Mounty
      When I installed a new motorcraft pump in our 93, the float lever was "misadjusted" ( bent) . This made the gauge read 3/4 full when full. I pulled the pump assembly, gave a slight downward bend to the float lever --set the assembly in the tank and checked the gauge reading. I knew the tank was full, but now the gauge read overfull. I then fine tuned my bend back upwards, set the assembly back into the tank and it read right on the full line.
       
    11. rodb

      rodb Active Member

      Joined:
      July 24, 2012
      Messages:
      120
      Likes Received:
      0
      Trophy Points:
      16
      City, State:
      SoCal
      Year and Model:
      1991 Eddie Bauer 4x4
      Anyone have a picture of this anti-slosh module mounted in dash?
       

    Share This Page






    We Support Our Troops!