Dismiss Notice



Register Today It's free! This box will disappear once registered!

99 explorer v6 5.0 leak

Discussion in 'Transmissions & Transfer Cases' started by Mike Blotzer, February 4, 2018.

  • Searches ExplorerForum.com
    1. Mike Blotzer

      Mike Blotzer New Member

      Joined:
      February 4, 2018
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      AZ
      Year, Model & Trim Level:
      99 Exp Sport
      Got an oil/transmission fluid from radiator I'n assuming, although it appears to be spraying all over left side (u joints, stabilizer, wheel well etc.) and all through the front of drive train (oil pan etc) My initial look leads me to a hose issue (they looked old), oil cooler line (per TSB 00-9-1), but seeing the amount of sludge everywhere, would see if anyone has been down this road before.

      Oh yeah, cig lighters dont work, radio/display flickers randomly, power windows lock without engaging, oh display dark...think I have an electrical issue?! lol

      Thanks in advance
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.

    Share This Page







    We Support Our Troops!