and gain access to Reviews and Discussion of the 2016 and 2017 Ford Explorer Tech Tips, How to Articles, Off-Road Modifications and Events, Street Truck Mods and Events, and much more! Since 1996 our community has covered every aspect of the Ford Explorer, Ford Ranger and all vehicles based on this platform.

Register Today It's free! This box will disappear once registered!

AC Compressor Problem

Discussion in 'Stock 1995 - 2001 Explorers' started by Explorer98Sport, July 17, 2013.

  • Searches ExplorerForum.com
    1. Explorer98Sport

      Explorer98Sport New Member

      Joined:
      July 17, 2013
      Messages:
      2
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      1998 Ford Explorer Sport
      When i have my AC off my car runs fine, but as soon as my AC is turned the AC compressor will engage then all of the sudden my idle will go down the AC compressor will stop engaging for about 3 seconds then the idle will recover, and then it will repeat again as the idle goes down the AC compressor stops for seconds then recovers. this only happens when my car is at a complete stop. When I go to give it power from a stand still, its like it doesn't have enough power to go. all this happens when my AC is on. When my AC is off my car runs like a champ no problems at all. I just added freon thinking that the Freon about 8 hours ago, but still runs horrible when the AC is on. This is a 1998 Ford Explorer Sport
       
    2. Support EF


      Join the Elite Explorers for $20 a year

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, add your own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



      to hide adverts.
    3. koda2000

      koda2000 Explorer Addict

      Joined:
      September 2, 2011
      Messages:
      7,721
      Likes Received:
      64
      Trophy Points:
      68
      City, State:
      Georgia
      Year and Model:
      2001 Explorer EB 5.0L
      the idle will vary slightly when the compressor engages (a few hundred RPM) that's normal, however it should not effect the way the engine runs. it is possible that you have a compressor problem, but it could also be that you have too much refrigerant in the system. have you put a set of gauges on the system, or did you just add refrigerant blindly?
       
    4. Explorer98Sport

      Explorer98Sport New Member

      Joined:
      July 17, 2013
      Messages:
      2
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      1998 Ford Explorer Sport
      I've had the car for 4 years, and I never had this problem so I just thought the entire refrigerant system was out, so I just put a whole can in without a gage. It isnt that theres too much, I honestly think that there is something wrong with the compressor.
       

    Share This Page






    We Support Our Troops!