Dismiss Notice



Register Today It's free! This box will disappear once registered!

Another Explorer Navigation Error

Discussion in '2011-2016 My Ford Touch / In Vehicle Technology' started by KW Carlson, December 13, 2017.

  • Searches ExplorerForum.com
    1. KW Carlson

      KW Carlson New Member

      Joined:
      December 13, 2017
      Messages:
      4
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Oxford, CT
      Year, Model & Trim Level:
      2014 explorer Limited
      I purchased a used Explorer Limited this past summer and rarely experienced nav errors so ignored them. Ironically, the error came back to bite me this past week as I was in Old Forge NY for the opening of snowmobile season. Temperatures were in the teens and 20s. Out of the blue I received a series of navigation faults and the loss of my USB inputs (on again - off again). Most folks in the forum seem to believe the problem is with the software V2.11. The car is at the dealer right now for repair but I'm not optimistic. Does anyone know what really causes the problem?

      Thanks

      KW
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. Rick

      Rick Pumpkin Pilot Staff Member Admin Elite Explorer

      Joined:
      February 8, 1999
      Messages:
      30,647
      Media:
      40
      Albums:
      4
      Likes Received:
      426
      Trophy Points:
      113
      City, State:
      Wayoutin, Aridzona
      Year, Model & Trim Level:
      '93 XL Pumpkin Edition
      Callsign:
      AB7FH
    4. jmr061

      jmr061 Well-Known Member

      Joined:
      August 24, 2014
      Messages:
      1,595
      Likes Received:
      59
      Trophy Points:
      68
      City, State:
      Wisconsin
      Year, Model & Trim Level:
      16 Edge
      Pr-16 Exp Sport
      That is super old software (V2.11 for MFT). In fact a 14 should have come with at least 3.X on it (thinking 3.6 or so). It also sounds like a connection issue with the USB ports. If you really are running V2.11 software for MFT there is something fishy in and of itself right there.
       
    5. KW Carlson

      KW Carlson New Member

      Joined:
      December 13, 2017
      Messages:
      4
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Oxford, CT
      Year, Model & Trim Level:
      2014 explorer Limited
      Looks like I have Sync2 V3.6. So the problem still exists with this software version. Is it a software or hardware issue? Does it ever really go away? Any thoughts appreciated.

      Thanks

      KW
       
    6. peterk9

      peterk9 Staff Member Moderator Elite Explorer

      Joined:
      December 28, 2010
      Messages:
      20,232
      Likes Received:
      556
      Trophy Points:
      143
      City, State:
      Ottawa, Ontario area
      Year, Model & Trim Level:
      2017 Explorer Platinum
      Callsign:
      VE3
      Welcome to the Forum.:wave:
      It won't go away if it is a connection issue with the port as Jason suggested as a cause. The latest Sync 2 version is V3.10.

      Peter
       
    7. KW Carlson

      KW Carlson New Member

      Joined:
      December 13, 2017
      Messages:
      4
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Oxford, CT
      Year, Model & Trim Level:
      2014 explorer Limited
      Dealer called and advised that the USB/SD card panel is being replaced but more parts are needed so vehicle is to be held overnight. Hoping for good news in the morning. Will pass along the solution if indeed the problem is solved.

      Thanks for your input

      KW
       
    8. Halford1

      Halford1 Active Member

      Joined:
      June 1, 2015
      Messages:
      106
      Likes Received:
      7
      Trophy Points:
      18
      Location:
      Santa Clarita, California
      City, State:
      California
      Year, Model & Trim Level:
      2014 Ford Explorer XLT
      I am getting MyFord Touch checked on 12/27 due to it black out and the USB would not work. The Ford Dealer thinks its wiring came loose. Fingers crossed.
       
    9. KW Carlson

      KW Carlson New Member

      Joined:
      December 13, 2017
      Messages:
      4
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Oxford, CT
      Year, Model & Trim Level:
      2014 explorer Limited
      The Explorer is now back in my hands and everything is working. I received new software, a new SD card, and a new media panel. I do love this machine when all is working.

      Thanks all for your interest and good luck to the Hartford XLT owner.

      KW
       
    10. peterk9

      peterk9 Staff Member Moderator Elite Explorer

      Joined:
      December 28, 2010
      Messages:
      20,232
      Likes Received:
      556
      Trophy Points:
      143
      City, State:
      Ottawa, Ontario area
      Year, Model & Trim Level:
      2017 Explorer Platinum
      Callsign:
      VE3
      If your MFT screen goes blank there is a good chance that you will need a new APIM.

      Peter
       
    11. Halford1

      Halford1 Active Member

      Joined:
      June 1, 2015
      Messages:
      106
      Likes Received:
      7
      Trophy Points:
      18
      Location:
      Santa Clarita, California
      City, State:
      California
      Year, Model & Trim Level:
      2014 Ford Explorer XLT
      hope so.
       

    Share This Page







    We Support Our Troops!