Dismiss Notice



Register Today It's free! This box will disappear once registered!

Brand New Ford Explorer 2013 XLT Brake Problem

Discussion in 'New Member Introductions' started by zeeshanali38, September 5, 2013.


  • Searches ExplorerForum.com
    1. zeeshanali38

      zeeshanali38 New Member

      Joined:
      September 4, 2013
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      Year, Model & Trim Level:
      Ford Explorer 2013
      Hi,
      I just bought a brand new Ford Explorer 2013 (XLT) and after driving for a week it is giving some vibration noise when applying brakes at high speed of 70 mph. This is not emergency brakes but normal brakes applied to reduce the vehicle speed. I have booked an appointment with the agent which is in two days. I was just curious to know what would be the problem with this brand new vehicle. Appreciate some feedback.
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.

    Share This Page








    We Support Our Troops!