Dismiss Notice



Register Today It's free! This box will disappear once registered!

Cat problem?

Discussion in 'Stock 1995 - 2001 Explorers' started by panteramatt, June 29, 2009.

  • Searches ExplorerForum.com
    1. panteramatt

      panteramatt Active Member

      Joined:
      February 28, 2003
      Messages:
      114
      Likes Received:
      0
      Trophy Points:
      16
      City, State:
      south jersey
      Year, Model & Trim Level:
      07 Mountaineer V8
      Had my wifes 97 explorers computer ran since its had a check engine light and it came back as p0420, catalyst efficiency below threshold bank 1. Does this mean the cats are bad or the o2 sensor? Which ones are they? Any fixes?
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. marragtop

      marragtop Well-Known Member

      Joined:
      April 14, 2001
      Messages:
      2,075
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      balt, md
      Year, Model & Trim Level:
      91, 92, 95, and 2000 xlts
      If the truck is running ok, I'd reset the codes and see if the CEL comes back on. Could be a false reading.
       

    Share This Page







    We Support Our Troops!