and gain access to Reviews and Discussion of the 2016 and 2017 Ford Explorer Tech Tips, How to Articles, Off-Road Modifications and Events, Street Truck Mods and Events, and much more! Since 1996 our community has covered every aspect of the Ford Explorer, Ford Ranger and all vehicles based on this platform.

Register Today It's free! This box will disappear once registered!

EATC wiring

Discussion in 'Stock 1995 - 2001 Explorers' started by Ryon40, July 20, 2010.

  • Searches ExplorerForum.com
    1. Ryon40

      Ryon40 Active Member

      Joined:
      March 30, 2009
      Messages:
      156
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Cincinnati, OH
      Year and Model:
      1998 Explorer Sport 4x4
      I'm about to go to the junkyard before they decide to close to get a wiring harness for an EATC out of a 1997 Limited or EB. Anyone know what tools will be needed its a you pull you pay place and I am putting in the unit so I don't know what I need to remove it. I'm also going to be removing the sensors and everything too. Any help is greatly appreciated!

      Thanks alot!
       
    2. Support EF


      Join the Elite Explorers for $20 a year

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, add your own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



      to hide adverts.
    3. Ryon40

      Ryon40 Active Member

      Joined:
      March 30, 2009
      Messages:
      156
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Cincinnati, OH
      Year and Model:
      1998 Explorer Sport 4x4
      Nobody?
       

    Share This Page


    Click Here

    We Support Our Troops!