for access to Reviews and Discussion of the 2016 and 2017 Ford Explorer Tech Tips, How to Articles, Off-Road Modification, Events, and more!

Register Today It's free! This box will disappear once registered!

Engine stalls for no reason...HELP!!!

Discussion in 'Under the Hood' started by dbdb, July 7, 2002.

  • Searches ExplorerForum.com
    1. dbdb

      dbdb New Member

      Joined:
      July 7, 2002
      Messages:
      10
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Westminster, MD
      Year and Model:
      93 Sport
      Ok I have a 93 Sport Explorer.
      The enigine stalls on me every so often for now reason. Yes the CEL light comes on, but goes away when I try to restart the engine. It wants to turn over, but nothing. 2 things I noticed:
      1) There seems to be too much oil according to the dipstick, might have the wrong dip stick for that model don't know.
      2) If I let the car sit for a while, and it varies how long, sometimes 2 hours, sometimes 24 hours, it will usually start right back up.
      But eventually it will stall out again. I thought maybe the fuel filter, but no one can get a code to show them what the issue is. HELP please anyone! Thanx.
      BTW, recent work done to my baby was having the Valve Modulator replaced because of a slipping tranny.
      Thanks in advance.
       
    2. Support EF


      Join the Elite Explorers for $20 a year

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, add your own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



      to hide adverts.
    3. mrboyle

      mrboyle I Drive By Brail Moderator Emeritus

      Joined:
      February 18, 1999
      Messages:
      4,142
      Likes Received:
      0
      Trophy Points:
      48
      City, State:
      Montrose, CO
      Year and Model:
      '95 Bronco '80 Toy
      It sounds like your fuel pump is going out. Next time this happens, check for fuel pressure at the injector rail. No pressure = replace pump.
       
    4. Ksharpe

      Ksharpe New Member

      Joined:
      July 11, 2002
      Messages:
      2
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Eureka, Missouri
      Year and Model:
      2000 XLT
      Check your idle selonoid.
      Mine is stalling out, with a 4.0 SOHC, and a mechanic friend told me that this was also occurring on alot of the fords they work on. If you can find the selonoid, called the I.A.C. in Haynes, tap it lightly with a screwdriver to see if it loosens frees up the idle.
       
    5. jeremism30

      jeremism30 Member

      Joined:
      July 11, 2002
      Messages:
      67
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Oxnard,ca
      Year and Model:
      1995 Sport
      Idle speed controll motor.
      The symtoms are:

      1. The engine starts, but only with yyour foot on the gas. If you take your foot off it stops.

      2. A bad idol speed control motor can also cause a waveyness in the engine.

      3. The hotter the weather is the worse it is.

      It's your Idal Speed Controll Motor. First call a dealership with your ven#, due to many models on all Fords have recalls. If there isn't a recall on it, first remove it and clean it inside and out. See if that works. If it doesn't then replace it. It's about 80-100 bucks i think for the part. I had the same problem, I first cleaned mine and it worked fine for a while, but now I think that I will end up replacing it. I think early 90's are the years that where recalled.
       

    Share This Page









    We Support Our Troops!