for access to Reviews and Discussion of the 2016 and 2017 Ford Explorer Tech Tips, How to Articles, Off-Road Modification, Events, and more!

Register Today It's free! This box will disappear once registered!

Help please - Horn doesn't work

Discussion in 'Stock 1991 - 1994 Explorers' started by jrhartman, July 8, 2005.

  • Searches ExplorerForum.com
    1. jrhartman

      jrhartman Member

      Joined:
      May 18, 2005
      Messages:
      57
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      canton, mi
      Year and Model:
      '94 XLT 4x4, '93 XLT 4x2
      My horn doesn't work, everytime I push the wheel all I hear is just a click, almost sounds like a blinker. Judging by that sound I am guessing that my problem might be with the horns themselves. Someone had installed an aftermarket alarm and then cut the siren/speaker on that so I am wondering if they cut the factory horns too. My problem is that I don't know where the factory horn(s) are located. If someone can help me with location of these horn(s) I would sincerely appreciate it. Pics would be even better.

      Thanks in advance
       
    2. Support EF


      Join the Elite Explorers for $20 a year

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, add your own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



      to hide adverts.
    3. jrhartman

      jrhartman Member

      Joined:
      May 18, 2005
      Messages:
      57
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      canton, mi
      Year and Model:
      '94 XLT 4x4, '93 XLT 4x2
      no one knows???? c'mon guys...
       
    4. 91EX4x4

      91EX4x4 Active Member

      Joined:
      January 18, 2003
      Messages:
      177
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Lebanon,Ohio
      Year and Model:
      '91 EB & '96 xlt
      Same thing happened to mine, the wires came loose on the horn so i just pushed them back on and now it works. The horn is on the drivers side below the headlight. I can get a pic for you later if you would like?
       
      Last edited: July 10, 2005
    5. jrhartman

      jrhartman Member

      Joined:
      May 18, 2005
      Messages:
      57
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      canton, mi
      Year and Model:
      '94 XLT 4x4, '93 XLT 4x2
      thanks...I will try to take look at her right now...
       
    6. jrhartman

      jrhartman Member

      Joined:
      May 18, 2005
      Messages:
      57
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      canton, mi
      Year and Model:
      '94 XLT 4x4, '93 XLT 4x2
      found it, both wires were plugged in, but I pulled them off and put them back on again....and now I have a horn again...thanks a million
       
    7. Glacier991

      Glacier991 EF Tranny Guru Moderator Emeritus

      Joined:
      February 8, 2003
      Messages:
      9,830
      Likes Received:
      4
      Trophy Points:
      38
      City, State:
      Sacramento, CA 95827
      Year and Model:
      1992 XLT
      I'm reminded of the bumpersticker... "Ignore Horn, Watch for finger"
       
    8. derrek

      derrek New Member

      Joined:
      March 2, 2008
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Manchester, NH
      Year and Model:
      94 4x4 eddie bower
      I have a horn that doesn't work and the fuse is blowing out.
      My horn has a single circut. It is not a double, according to the eletrical book I should have a relay with it but I have not been able to find the relay to see if the short is in the relay.

      Do you know where the relay is at if there is a relay or if I am barking up the wrong tree?

      94 eddie bower 4x4 explorer

      Thanks!
       
    9. LXNavajo_94

      LXNavajo_94 Active Member

      Joined:
      July 25, 2006
      Messages:
      167
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Hendersonville,NC
      Year and Model:
      1994 navajo lx
      the horn relay should be on the passenger side fenderwell that little black plastic bnox thing and yes the relays do go bad
       

    Share This Page









    We Support Our Troops!