and gain access to Reviews and Discussion of the 2016 and 2017 Ford Explorer Tech Tips, How to Articles, Off-Road Modifications and Events, Street Truck Mods and Events, and much more! Since 1996 our community has covered every aspect of the Ford Explorer, Ford Ranger and all vehicles based on this platform.

Register Today It's free! This box will disappear once registered!

Help

Discussion in 'New Member Introductions' started by Firtree, April 30, 2012.

  • Searches ExplorerForum.com
    1. Firtree

      Firtree New Member

      Joined:
      April 29, 2012
      Messages:
      2
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Qualicum Beach BC
      Year and Model:
      1994 ford Explorer
      I,m researching mass air sensor info. Just sort of inherited a nice 1994 Explorer XLT thats been pretty well looked after, but was running horrible rich & a lousy idle. Check Eng. light proved to be MAS. Changed it with one from wreckers. Idle now perfect & motor running cleaner. Oddly though Eng.check light is off when motor started and stays off untill revs increase to about 1600rpm when it then comes on & stays lit untill motor's stopped.

      Anyone had same problem or have a comment? Oh! should add, the check eng.lght coming on seems to have no effect on engine power when travelling and idle is still A1.
       
    2. Support EF


      Join the Elite Explorers for $20 a year

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, add your own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



      to hide adverts.
    3. rickybobby

      rickybobby Well-Known Member

      Joined:
      June 26, 2010
      Messages:
      1,276
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Battle Creek, mi
      Year and Model:
      '97 XLT
      You need to have the codes read, without the codes we cant tell you anything
       
    4. Firtree

      Firtree New Member

      Joined:
      April 29, 2012
      Messages:
      2
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Qualicum Beach BC
      Year and Model:
      1994 ford Explorer
      I should have been more specific. Initial code reader check showed only MAS the problem. Had codes read again after MAS replaced and the light coming on problem I described. Result of the second scan showed all sensors A1
       

    Share This Page




    Click Here

    We Support Our Troops!