1. for access to reviews and discussion of the 2016 and 2017 Ford Explorer, Tech Tips, How to Articles, Off-Road Modification, Events, and more!

    Register Today It's free! This box will disappear once registered!

Horn and cruise won't work!

Discussion in 'General Explorations!!' started by d3cker, February 17, 2004.

  • Searches ExplorerForum.com
    1. d3cker

      d3cker New Member

      Joined:
      September 7, 2003
      Messages:
      4
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Albany, New York
      Year and Model:
      1998 Eddie Bauer
      My horn and cruise on my 1998 Ford Explorer Eddie Bauer V8 AWD won't work! I'm pretty sure it's the fuse but I don't have an owners manual and I can't figure out which fuse it is. I have searched everywhere but have found nothing. It would be great it someone could help me out with what fuse is for the horn and cruise control.

      THANKS!!!!
       
    2. Support EF


      Join the Elite Explorers for $20 a year

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, add your own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



      to hide adverts.
    3. double_take

      double_take Active Member

      Joined:
      January 14, 2004
      Messages:
      146
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Chicago, IL
      Year and Model:
      '98 Sport & '00 E.B.
    4. jimbo74

      jimbo74 Elite Ranger

      Joined:
      December 27, 2000
      Messages:
      18,444
      Likes Received:
      1
      Trophy Points:
      58
      City, State:
      Nor*Cal
      Year and Model:
      98 XLT Supercab 4x2
      when my horn and fuse didnt work also, it was a fuse, dont remeber which fuse it was though... it was in the interior fuse box.... you can buy a fuse tester at an auto parts store and just test all of them for a couple of bucks....
       
    5. Billy177

      Billy177 Well-Known Member

      Joined:
      July 10, 2003
      Messages:
      1,899
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Redding CT
      Year and Model:
      99 Explorer XLT SOHC 4x4
      replace your clock spring i bet the airbag light is on too
       
    6. d3cker

      d3cker New Member

      Joined:
      September 7, 2003
      Messages:
      4
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Albany, New York
      Year and Model:
      1998 Eddie Bauer
      Thanks for the help! With the online owners manual I was finally able to find the right fuse. It was the #10 fuse under the hood. I have my horn and cruise back now!

      Thanks again!
       

    Share This Page








    We Support Our Troops!