1. Tip... Did you know that if you hold most smartphones sideways you can bring up a more full featured version of the forum?
    Dismiss Notice

for access to reviews and discussion of the 2016 and 2017 Ford Explorer, Tech Tips, How to Articles, Off-Road Modification, Events, and more!

Register Today It's free! This box will disappear once registered!

How I solved the stuck fuel gauge on my 05 Explorer

Discussion in 'Stock 2002 - 2005 Explorers' started by High_Order1, July 15, 2011.

  • Searches ExplorerForum.com
    1. High_Order1

      High_Order1 Active Member

      Joined:
      January 31, 2007
      Messages:
      497
      Likes Received:
      0
      Trophy Points:
      16
      City, State:
      near Oak Ridge, TN
      Year and Model:
      2005 Jack Bauer Edition
      How I solved the gas gauge problem on my 2005 Flex Fuel Ford Explorer





      Difficulty: Above Average, for two reasons; 1) you wind up cutting a permanent, gaping hole into your car, and 2) you're dealing with gasoline and critical systems. If you have access to the tools, the time, and can follow this, you can do this.

      Tools: saber saw with metal blade, screwdrivers, socket set (I forget which specifically, sry) with extensions, volt-ohm meter



      Next, a word about gasoline

      Too many people have gotten weird ideas about how gasoline behaves. Mostly from 'friend-of-a-friend' stories, and a LOT from Hollywood. See, real life is too boring for movie crews, so, they have to spice things up often. This is why every car, even with minor damage, makes the huge BOOM, and the cool fireball (except the hero car, which can be shot completely up, rammed, and jump through the air, but not even shift funny, but I digress).

      The primary danger with gas is what nerds call the vapor phase. The liquid is surprisingly stable. I have seen many, many times where stuff shoulda caused the BOOM, not cause it. On the other hand, when the vapor comes out, that’s when Mister Gas Quits Being Reasonable and starts being the animal it really is.

      What does this mean to you? Many people don't mess with certain repairs, because They Fear The BOOM. As long as you follow a few rules, you'll be fine. First, if you get a puddle or a spill, stop what you're doing and clean it up. Second, have lots of fresh ventilation. Third, avoid working on the car when the exhaust is hot. And, if you pull the pump, put something over the hole while its' gone. Past that, as long as you aren't carrying static, or making sparks, you should be fine.

      And, if you don't believe me, then why are most fuel tanks made out of plastic now, instead of metal? And, why aren't there more explosions at filling stations?


      BEFORE YOU BEGIN!

      Listen to me. Seriously. This isn't the normal car you're used to. It is a rolling computer, and it is so, so, SO sensitive to battery shape. BEFORE you waste days going through all this other crap, go check yer battery. If it is a few volts shy at rest, try charging it with a real charger (your alternator won’t suffice), or replace it. If it drops below 10v while cranking, replace it. Period. If the terminals are a little crapped up, FIX THEM. No green, no dirt, clean and tight. Don't hesitate to whack a terminal connector off and replace them. SERIOUSLY.

      There are a TON of gremlins and transient issues that can only be solved with a good battery. I don't care if its' 6 months or 6 years old. Don't assume your battery is good. I promise.


      OK - a backgrounder on this retarded/genius gas system

      In my first car, here is how it worked-


      [​IMG]


      In the fuel tank is a float. This float is connected by an arm to for all intents and purposes, a volume knob. As the level of fuel rises, the float also rises, and turns the knob one way. As it drops, the knob turns the other way. The knob is actually a variable resistor, and turning it changes the value of resistance.

      You put electricity through it, and attach a voltmeter to the other side, and voila! Gas Gauge!

      Well, in the flex fuel Ford, there are a number of complications.

      First, for some reason unknown to me, Ford thinks sending direct current through the fuel sensor in a tank full of ethanol is a bad idea. (I even researched it, and couldn't come up with anything. I am guessing the alcohol has some kind of electroplating effect on the resistor part over time. Just a guess).


      So, in between the wire and the fuel sensor / volume knob, there is a DC to AC converter.


      On the other end, we no longer have a simple, analog car. What we have basically is a computer with wheels that can’t understand the volume knob (analog) input.


      So, now, at the used-to-be-dashboard-now-we-call-it-an-instrument-cluster, there is an analog-to-digital converter. Continuously variable voltage goes in one side, a digital signal that is a binary number proportionate to the amount of fuel in the tank comes out the other side.




      But wait, there's more!

      See, the master computer what runs everything in the car doesn't like the fact that as the car moves, the float is continuously in motion and therefore continuously sending varying data to the computer and the cluster. Nope. So, it has a computer program that interprets the data it is seeing, and compares it with information from other sensors and timers, and THEN, sends a signal to the little needle telling you its' time to feed the hog again.


      So, if you’re keeping count, it goes sender > harness with connectors > digital to analog converter > computer > fuel gauge



      Seriously! There are 3-4 fuel gauge programs or 'strategies' that the car is continuously running.

      The first one, is called 'Anti-Slosh Mode'. You are normally in this mode. Basically, the system averages the readings it sees over time then adjusts the needle to match. Unless you're standing still, and not sloshing, you really aren't seeing the true tank level.

      The second and third (and maybe fourth, I forget now) strategies kick in when there's been a gap in the continuous data, or there's been a large change in the data.

      IF THE KEY WAS OFF, and there has been a large change in the current data (in other words, you put at least 15% more gas in it than it had) from the stored value, there is a small delay where the needle does nothing while the computer averages things. Then, it reverts back to antislosh.

      IF THE KEY WAS ON, oh boy. You just invoked a series of timers, that unless defeated by turning the car off for a period of time, can wait up to 55 MINUTES to watch the system settle before adjusting the needle. This isn't an error, it is a factory programmed strategy.

      The last strategy is similar to key on / data change, and it gets invoked if there was a gap in data, like an intermittent short, or bus error or something.

      In simpler words, refuel with the car off; your gauge will be pretty accurate (everything else notwithstanding). Refuel with the car on, and it will take foooorever to reflect the new level.

      Why does it need all this? Friend, I honestly don't know. But it must be important, or Ford wouldn't have wasted money and engineering effort putting it in, and no, you can't just hack it all out and throw in a reg'lar gauge. (The computer needs this data to compute a lot of things. If you deny it, it will get pissy with you).


      Why did I need to hear all that?


      Because. The intuitive shadetree will realize that there are a lot of places for a problem to pop up, and you just can't go at it with a voltmeter and a cheat wire anymore to diagnose it.




      How do we diagnose a gauge issue?


      Well, if a gauge sticks at one end or another, that's one set of issues. If it swings, seemingly random, that's a much tougher fish to fry.

      In my case, suddenly, one day, it just picked a level, and stayed there. I KNEW I wasn’t getting that good of a gas mileage.

      The service DVD says the first test is to plug your worldwide data system up, and command the dash to display full, 3/4, 1/2. 1/4, and empty. Don't have one? Not a problem. Starting at KOEO (key off, engine off), hold your setup and reset buttons, and turn the ignition key to RUN (where it lands after you start the car.)

      You should see test in the message display. Hit setup once, and you should get GAGE SWEEP. If the gas needle sweeps, it is likely that the instrument cluster is ok.

      The next test Ford recommends requires a special Rotunda tool. You can fake it with a couple of resistors, though. All you are doing is substituting a known resistance further and further downstream from the cluster to verify that its' not a bad wire or connector, or, that the cluster is messed up.


      I didn't do any of that. I unplugged a connector (C4037) while the car was on RUN, but not started, because I am fearless.This connector is located under a dust cover on the passenger side, and is trivial to locate:


      [​IMG]



      When I unplugged it, the needle dropped to zero. Plugging it back in, I got the previous readings. If my needle had stayed put through all of that, I would bet that it was somewhere between that connector and the needle, and NOT in the tank.

      In my case, it pointed to the 3/4 mark. Now, I never fill this thing all the way up, so I knew it was wrong. Watching the trip meter, either I was getting the best mileage of my life, or the float was stuck. So, I ran it off road, to shake it loose. No dice. I got up under there, and hit the tank (dang, that is a BIG tank) with a mallet.

      To spite me, now the gauge pointed straight up like I fed it viagra.




      Oh crap, I gotta drop the tank!


      Now, if you've never had the pleasure of dropping a fuel tank, let me hip you: it suxxors. You really need to be on concrete or asphalt. Flat. You knock ten years of dirt off everything, reach waaaaay up and over the top of the tank where you can't see, and undo the fuel filler hose, and usually a couple of emissions hoses. Not trivial. Then, using a board perched precariously on a rollaround jack, while the car sits on jackstands so you can actually get up under there, you bust loose some straps. Then, as you lower it, using your knees to steady the tank, you pop loose a couple more hoses, and some electrical connectors.

      THEN, you put it on the ground, gently. You did drain the tank first, right? Because most of us can time repairs to the same time we run out of gas, right? You can't just put a hose in an explorer tank, there's a basket screen in the filler pipe.

      Then, there's putting it back. Did you know that a pinhole about .020 in diameter can set a trouble code on an explorer? Yeah.

      I had no interest in any of that. $90/hr at the local dealership; I didn't have any help, my driveway is a gravel incline, and I just didn't feel like bear wrestling a fuel tank almost as long as I am. So, I cut a frigging hole in my floorboard. Yes, I did. The sensitive are kindly requested to look away now.


      Here's how:

      I recommend usually a few things here. I am going to assume that you have some basic knowledge in a few skillsets; this isn't for a beginner. One thing I usually recommend is to go wash the undercarriage. Especially in the conventional method, knocking road grime off is a HUGE help.


      First, yank the passenger seats.

      It only takes about ten minutes. Front passenger seat is four bolts. The little covers, if you still have them, just pop off. DON'T forget to unplug the two little electrical connectors (more if you have the special front seat). Back passenger seat is a combination of bolts and nuts. You don't have to take the small seat out or the seat belt latches, just the 60 bench (60/40 split). The fourth bolt is tricky to get to. Use two extensions, slide it towards the rear, then down on top of the bolt, like so:

      [​IMG]


      Next, pop the doorsill cover off. It is stiff, but simply pops loose. Resist the urge to rent a carpet cleaner, pick it up and roll it back and over the center console. You should be here:


      [​IMG]



      Now, whack a hole. I used a saber saw with a homebrew depth guard. (A depth guard is just something you stand the saw on so that you limit how deep the blade travels. You only need about a 1/4 inch. Any deeper and you run the risk of accidentally whacking a cable or hose. )

      [​IMG]

      [​IMG]


      This is how much room you got to work with under there:


      [​IMG]

      White is the floor pan, the other is the top of the tank unit.







      I just SLOWLY drilled a start hole, cut three corners and bent it back.





      [​IMG]





      I took time, and cleaned the top. No sense in having something fall into the tank.
      [​IMG]

      [​IMG]



      Now, here is where you can benefit from my next 90 tortured minutes.

      First, there are four connectors that bother you. First, pull the vent. This is a bitch. Use a couple of screwdrivers. There are red tabs, one on each side. They press inward, then up. Then grab the top red bar with a pair of pliers and yank up. This will release it from the tank vent tit. Now, trace that hose to the tee, then to the right. You'll see a grey electrical connector. push down on the top, and pull the plug. NOW, move that stupid pipe. It is in the way of the gas line.

      The gas line is removed by a similar clip. Unlike the vent, that is removed by pulling up, this clip goes to the left, after you unclip the piece on the right. You may need to twist the connector a bit to let the red piece pull out far enough to disengage the clip. (If you don't, it ain't comin' off. I promise).





      Once all the hoselry has been moved, now it’s time to remove the assembly. The assembly is held in place by a metal ring, which in turn is secured by several teeth. These teeth do a good job by themselves, but to add insult to injury they are bent over to lock the ring in place.

      [​IMG]

      I tried to be dainty about it, but as the hammer and big screwdriver in the pictures show, eventually, after you skin the knuckles, and the sun is dimming, you do what you need to do. Bend those tabs, then knock the shit out of that lock ring. It will go.

      [​IMG]


      FINALLY

      At this point, the fuel unit will come out by pulling straight up, but take care; the fuel float will need a little contorting to get it out of the hole. Also, uh, hey – that’s gas in your crew compartment. Try not to spill any; its’ gonna stink everything up.

      Once the unit is out, plug the hole with a towel. Also, if you’ll look straight down, you’ll see what almost looks like a deepwell in the base of the tank. If there is any crap down there, figure out a way to scoop it out. That’s junk waiting to clog your filter up.

      This is the fuel assembly in all its’ glory:

      [​IMG]

      The green arrow points to the pump. The yellow arrow points to part of the sock, a filter that protects the pump. It pops off, and a cleaning in fresh gas isn’t a bad idea at all. The red arrow points to the connector that makes up the fuel level sender circuit; the alligator clips are tying the meter into the circuit. The white arrow points to the float. Following the coat hanger / float wire up, you’ll find the sending unit. It’s basically held in place with a screw and some clips. Clips are FRAGILE, so don’t force things.


      [​IMG]

      Before I cracked it open, I wiggled the arm. It was sloppy, and the meter showed that there was a couple of places that the sender didn’t send a value at all.

      This is the sender unit. See the black arc? That’s a resistor, like in our volume knob. In my case, it’s dirty as hell, and begged for a light scrubbing with a brass brush and some contact cleaner.

      Here’s a closeup:

      [​IMG]

      I then cleaned the wiper (the piece that attaches to the float arm, and varies the resistance) and bent it a little more so make sure it would make great contact.


      [​IMG]

      Once I cleaned it (because they won’t sell you just that part – I checked), I reassembled it and tested it by slowly moving the arm. The meter dutifully displayed that I fixed it. No flat spots!

      I’d like to share some detail on reassembly, but there’s nothing Earth shattering here. I bent the metal back down, used some high dollar aluminum tape to tape it in place, shoved the carpet back, the seats back, and its’ been months now, and I don’t smell gas or exhaust, and the gauge works like a champ!!

      [​IMG]


      Shawn
       
    2. Support EF


      Join the Elite Explorers for $20 a year

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, add your own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



      to hide adverts.
    3. esclamada

      esclamada Active Member

      Joined:
      October 25, 2010
      Messages:
      502
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      KCMO
      Year and Model:
      '02 Mountaineer AWD V8
      excellent post! most landrovers have this issue and they do fix/replace the pump this way.
       
    4. Javadog123

      Javadog123 Member

      Joined:
      July 18, 2011
      Messages:
      81
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Hilo ,Hawaii
      Year and Model:
      2004 XLS AWD
      Great write-up on the repair. I had to laugh though, I thought I was the only one who cut up cars to get to the fuel pump. I had to do that on my 1990 Trooper. It really beats the heck out of dropping a 10-20 year old gas tank. I do the same thing sometimes on those really hard to get engine to tranny bolts. Helps not only on removal but also on re-assembly. I use my high speed cutter with 3" cutting wheels. Fits those hard to reach spaces.
       
      Last edited: August 3, 2011
    5. rocco123

      rocco123 Active Member

      Joined:
      February 24, 2002
      Messages:
      770
      Likes Received:
      2
      Trophy Points:
      28
      City, State:
      Endicott, NY
      Year and Model:
      1994 XLT & 2002 Limited
    6. High_Order1

      High_Order1 Active Member

      Joined:
      January 31, 2007
      Messages:
      497
      Likes Received:
      0
      Trophy Points:
      16
      City, State:
      near Oak Ridge, TN
      Year and Model:
      2005 Jack Bauer Edition
      Rereading,

      I thought I'd also add that in a flex fuel vehicle, there's also a sensor that determines how much alcohol is in the gas. Have no idea where it is, or how it affects how long the needle takes to settle, but I thought I'd share.

      Shawn
       
    7. Eknodel

      Eknodel New Member

      Joined:
      June 6, 2008
      Messages:
      2
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Vallejo, CA
      Year and Model:
      '02 XLT
      This is one of the best how-to postings I've seen. My 2003 Explorer has a problem where the gas guage suddenly drops to E. My research leads me to believe that years of cheap Costco gas has left sulfur deposits on the resister in the sender unit. Your pics help lead me to that conclusion. Now I finally know how to tackle this repair without dropping the tank and without paying a dealer $800 to replace the sender. Thanks.

      One question - your photo of the floor board appears to show a dark "patch" panel around the area where you made the cut. Is this a panel or just material adhered to the floor panel?
       
    8. m00nJump3r

      m00nJump3r New Member

      Joined:
      February 1, 2012
      Messages:
      18
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      2004 Explorer
      Excellent write up.....I have been getting this problem as well, it takes about an hour worth of driving and a few shut off to get up to the proper mark.

      I am not mechanically inclined to perform such and knowing myself, I would probably get myself into a situation that will end up costing me more :confused::scratch::D

      anyone know how much it would cost to fix this? I think I have an esp hopefully it haven't ran out.....

      TY
       
    9. m00nJump3r

      m00nJump3r New Member

      Joined:
      February 1, 2012
      Messages:
      18
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      2004 Explorer
      Could someone please help me, I am having this problem, unforuntantely I am not that inclined nor do I have the space to do this?

      Anyone know how much it cost, I don't think my esp cover this problem and I would like to get this fix?

      TY in advance.
       
    10. High_Order1

      High_Order1 Active Member

      Joined:
      January 31, 2007
      Messages:
      497
      Likes Received:
      0
      Trophy Points:
      16
      City, State:
      near Oak Ridge, TN
      Year and Model:
      2005 Jack Bauer Edition
      Eknodel = Thanks for your kind words! I think SOMEBODY should profit off my mistakes, anyways!

      To answer your question, that's some kind of funky patch that was there. No klew what it does or why it's there. I just whacked through it, too.

      Moonjumper, I am very sorry you're having problems, and what you say makes sense. Reread the thread a couple of times. Do you have a buddy you could bribe? Relative that owes you a favor??

      Or... my favorite = announce you're throwing a party. Then, when they get there, put them to work!! LOL

      I am betting that one of the lounge forums on here would get you more attention. Or maybe a Craigslist ad? Sorry I can't help.

      Shawn
       
    11. danwheler660

      danwheler660 New Member

      Joined:
      April 17, 2012
      Messages:
      41
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      fenton michigan
      Year and Model:
      2002 mercury mountaineer
      My gauge on my 2002 reads empty all the time.Once in awaile it will move but 99.9% it stays on empty.Would thid maybe fix mine or do i hav a differt problem Thanks Dan
       
    12. peter @exp

      peter @exp New Member

      Joined:
      September 7, 2012
      Messages:
      10
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      FLORIDA
      Year and Model:
      2004 EXPLORER SPORT TRAC
      Sea foam or gum out in tank may help. Worked for me clean out the crap in tank
       
    13. wangbungal

      wangbungal New Member

      Joined:
      January 27, 2011
      Messages:
      39
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      miami fl
      Year and Model:
      ford ranger xl 97
      at shawn, i just want to ask where did you start the pilot hole for your jigsaw?
       
    14. jkflanny

      jkflanny New Member

      Joined:
      March 3, 2014
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      NC
      Year and Model:
      2005 Ford Explorer
      Replace Fuel Pump and Sending Unit?

      My Explorer is definitely having sending unit issues. I did the Seafoam additive and it worked for a while, but no longer. Time to replace. Local Mechanic suggested replacing fuel pump also since he would already be in there to save on coming back for labor costs. Do you think this is necessary?
       
    15. D Hook

      D Hook Elite Explorer

      Joined:
      October 10, 2010
      Messages:
      843
      Likes Received:
      3
      Trophy Points:
      18
      City, State:
      Omaha, NE
      Year and Model:
      06 Explorer Limited V-8
      Most definitely.
       
    16. FordFool2

      FordFool2 Active Member

      Joined:
      December 11, 2010
      Messages:
      401
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Cedar Rapids, IA
      Year and Model:
      04 Eddie Bauer & 13 Ltd
      This was a very helpful thread when my fuel pump went bad in my 2004 EB. I chickened out on the floor cutting and went ahead dropped the tank.

      One tip: I was able to rotate the locking ring collar without bending up the tabs as shown with the claw hammer. I just used a drift and was able to drive/rotate the collar to release it.
       
    17. High_Order1

      High_Order1 Active Member

      Joined:
      January 31, 2007
      Messages:
      497
      Likes Received:
      0
      Trophy Points:
      16
      City, State:
      near Oak Ridge, TN
      Year and Model:
      2005 Jack Bauer Edition
      wangbungal - If I remember correctly, somehow I think I made a small pilot hole with a drill, and looked for light by crawling up under the car to see how close I had gotten. I think

      danwheler660 - It might. You basically are trouble shooting the system, so at some point, you should find your problem assuming its' not your computer.

      jkflanny - nah. If its' not broke, I wouldn't mess with it. On the other hand, if they will toss in a NEW (not reman) pump cheap, and you've gotten significant miles, (shrugs). Pumps are stupid expensive. It takes the mech an extra five minutes, and then can double or triple the book hours.

      FordFool2 - Thanks! Yeah, a punch is a great idea. Had I had one... LOL! I didn't really know what I was doing, even with the service manual, so, my threads aren't gospel, they just save y'all some time avoiding my silly mistakes.
       
    18. Tankentaisha

      Tankentaisha Elite Explorer

      Joined:
      June 25, 2015
      Messages:
      64
      Likes Received:
      0
      Trophy Points:
      6
      City, State:
      Alaska
      Year and Model:
      2002 Explorer XLT
      Great thread and the pics are a big help!
       
    19. ANTHONY-GATLIN

      ANTHONY-GATLIN Elite Explorer

      Joined:
      August 3, 2012
      Messages:
      73
      Likes Received:
      0
      Trophy Points:
      16
      City, State:
      TOKYO
      Year and Model:
      2004 FORD-EXPLORER SPORTS
      I am going to upgrade my fuel pump to a { HFP-342 255LPH Fuel Pump }
      for my supercharger setup this weekend
      this will help me a lot
      hey THANK YOU
       
    20. ANTHONY-GATLIN

      ANTHONY-GATLIN Elite Explorer

      Joined:
      August 3, 2012
      Messages:
      73
      Likes Received:
      0
      Trophy Points:
      16
      City, State:
      TOKYO
      Year and Model:
      2004 FORD-EXPLORER SPORTS
      hey did my cutting today
      is was very easy
      I just use a metal sheet cutter scissors
       
    21. Nomechexp

      Nomechexp New Member

      Joined:
      March 1, 2016
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      02 mercury mountaineer
      Question

      Hi does this work for a mercury mountaineer and it has flex fuel so I wld use the 2nd option correct?
       
    22. Number Twelve

      Number Twelve Active Member

      Joined:
      August 31, 2015
      Messages:
      229
      Likes Received:
      18
      Trophy Points:
      18
      City, State:
      15 miles west of Tampa Florida
      Year and Model:
      2005 Ford Explorer XLT
      OMG! I think I'm in love.
      This is better than my, "Kill the Dinger" Thread.
      And yes, I would put hole in the floor to check the tranny fluid if I wasn't sure that would end up with Mercon V in the carpeting.
      Highest praise. Deepest respect.
      And $800 I'm not going to pay somebody else to replace the sending unit!

      Edit, 30 days later: My gauge was sticking on Empty at start-up about 40% of the time. I added a can of Seafoam and it has registered correctly during my last 15 trips. I consider that to be lucky!
      One out of 15 failures in this Ex that I didn't have to take it apart and replace something.:mad:
       
      Last edited: May 28, 2016
    23. High_Order1

      High_Order1 Active Member

      Joined:
      January 31, 2007
      Messages:
      497
      Likes Received:
      0
      Trophy Points:
      16
      City, State:
      near Oak Ridge, TN
      Year and Model:
      2005 Jack Bauer Edition
      Thank you number 12!
      People like you are why I post how-to's here.

      Now, if we could only get them stickied, so other people can find them more easily!!

      Shawn
       

    Share This Page









    We Support Our Troops!