1. for access to reviews and discussion of the 2016 and 2017 Ford Explorer, Tech Tips, How to Articles, Off-Road Modification, Events, and more!

    Register Today It's free! This box will disappear once registered!

I really need some input on limp home mode.

Discussion in 'Stock 2002 - 2005 Explorers' started by tyger0ne9, September 14, 2009.

  • Searches ExplorerForum.com
    1. tyger0ne9

      tyger0ne9 New Member

      Joined:
      September 14, 2009
      Messages:
      3
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      new orleans, la.
      Year and Model:
      '04
      i have a 2004 explorer very dependable til now i hope you all can help. here is my story i helped a friend jump start his vehicle and inadvertently my posi cable came while the motor was running. that was ok i put the cable back on and tightened it and i forgot to mention i needed a jump the same morning and my starter was dragging. anyway i took it to our shop(carpentry) and did the bearing on the drivers side all done and put together i went to start it and it started in limp home mode i tried to reset the computer for ten minutes and reconnected it and nothing not even a turn over nothing. all the lights work and the battery is not dead any help will be appreciated.
       
    2. Support EF


      Join the Elite Explorers for $20 a year

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, add your own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



      to hide adverts.
    3. BrooklynBay

      BrooklynBay Staff Member Moderator Elite Explorer

      Joined:
      November 11, 2005
      Messages:
      50,929
      Likes Received:
      21
      Trophy Points:
      58
      City, State:
      Brooklyn, NY
      Year and Model:
      88 89 93 95 96 Aerostars
    4. Gus Gorilla

      Gus Gorilla Active Member

      Joined:
      May 12, 2008
      Messages:
      373
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      The Cradle of Naval Aviation
      Year and Model:
      2001 Sport Trac 4X4
      If you needed a jump that morning, then just driving to work would not charge your battery. You would have to drive for hours on end for the alternator to completely charge a fully discharged battery. The good ol' test light might light. But it needs a charger and some time to recouperate.
       
    5. tyger0ne9

      tyger0ne9 New Member

      Joined:
      September 14, 2009
      Messages:
      3
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      new orleans, la.
      Year and Model:
      '04
      limp home mode

      no on my model it is a amber open end wrench im thinking it needs a reset of somesort i have to get it diagnosed but the dealer wants 280.00 just for diagnostics anyway thank you for your response any other advice will greatly be appreciated
       
    6. tyger0ne9

      tyger0ne9 New Member

      Joined:
      September 14, 2009
      Messages:
      3
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      new orleans, la.
      Year and Model:
      '04
      limp mode home


      i tried my battery in another vehicle and it started it right up then i put it back in my 04 explorer and nothing not even the tell tale tick tick tick. anyway thank you for your response if you have any more suggestions it will be greatly appreciated
       
    7. jrford

      jrford Well-Known Member

      Joined:
      March 1, 2005
      Messages:
      2,538
      Likes Received:
      0
      Trophy Points:
      46
      City, State:
      Birmingham, MI
      Year and Model:
      '10 Sport Trac
      Newer Battery it started right?
      Is it orginal? My guess it needs a battery, might also need a Alternator too (some times they go hand in hand).

      Check the Voltage, with key off it should read about ~12.8volts, running 13.3V.
      There is a lot of electronics and these trucks will do strange things if the battery is even close to going bad -imo.

      When i swapped mine out, the store checked it as good but the Eye was black, and if you played the radio for an hour or so the battery was near dead. So i just put a new one in and all was fine.
       

    Share This Page








    We Support Our Troops!