Dismiss Notice



Register Today It's free! This box will disappear once registered!

Instrument Cluster Shorts Out

Discussion in '2001-2005 Explorer Sport Trac' started by 3Square, May 17, 2011.

  • Searches ExplorerForum.com
    1. 3Square

      3Square New Member

      Joined:
      May 16, 2011
      Messages:
      3
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Coyote Flats, Texas
      Year, Model & Trim Level:
      2004 Sport Trac
      I am hoping somebody can help me with this question.
      I have a 2004 Model Sport Trac and about a year ago my dash started shorting out, my speedometer would quit working and i would have to slap my Cluster panel for it to start working again.
      Well after about a year of not being able to find out what exactly is wrong with it. it has started to where it very seldom comes back on, but not only does my speedometer not work it also cuts my Radio out and my Electric Windows won't work.
      It now on occasion will come on and i will listen to the Radio while can, but if i don;t turn my Radio off before it shorts out again that after i get out of my truck i can go out to my truck a few hour's later and my Radio will be playing and my Dome lights are coming off and and, now it has also started runing my battery down when i go out in the morning to start it i have to put a Charger on my Battery. I have to carry a Battery Charger and Extension Cord with me where ever i go.


      Can somebody please help.


      thanks
      3Square
       
      • Thanks Thanks x 1
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. ncranchero

      ncranchero Co-moderator Staff Member Moderator Elite Explorer

      Joined:
      August 14, 2004
      Messages:
      3,736
      Likes Received:
      3
      Trophy Points:
      48
      City, State:
      Denver,NC
      Year, Model & Trim Level:
      '94 F150 4x4 SWB 4.9L
      Holy cow!

      Have you had the battery tested These trucks go berserk over a weak/defective battery.

      I'd test/replace the ignition switch (SW5011 Motorcraft) FIRST since it affects all of the systems you comment on. If not that you may have a PCM issue. Does it still crank and run with no problems .......... other than the dead battery?
       
    4. 3Square

      3Square New Member

      Joined:
      May 16, 2011
      Messages:
      3
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Coyote Flats, Texas
      Year, Model & Trim Level:
      2004 Sport Trac
      Yes it still cranks and, i put a new battery on it about 6 months ago.
      i had a friend scan it and it said that it could be a problem with the keyless entry remote. i also thought that maybe i had a bad ground.
      he also mentioned th pcm same as you did.
      the ignition switch sounds like it would be the least expensive to try.
      i will have to check this out.

      thank you
       
    5. Kelvarr

      Kelvarr New Member

      Joined:
      November 4, 2009
      Messages:
      15
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Novi, MI
      Year, Model & Trim Level:
      05 SportTrac XLT 2WD
      Sorry for the necro, but I am having the same issue with my 2005 sport trac. Did you ever find out what it was? I don't want to just start replacing parts I don't need to.

      The truck runs perfectly fine, but the symptoms are all the same (shorting out, speedometer/tachometer zero out and actually ping against bottom peg, odometer doesn't increase, trip meter resets, stereo cuts in/out). Not sure about the windows, as I haven't tried them during this.
       
    6. 3Square

      3Square New Member

      Joined:
      May 16, 2011
      Messages:
      3
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Coyote Flats, Texas
      Year, Model & Trim Level:
      2004 Sport Trac
      Answer to kellvarr

      I have found out that it can be 2 things. either a short or a bad instrument cluster.
      if your lights and radio come on when the vehicle has been parked for a while with the key off.then you need to have the cluster replaced.
      need to have a mechanic do it because the new cluster has to be programed to your key. (key has a chip in it).
       
    7. Kelvarr

      Kelvarr New Member

      Joined:
      November 4, 2009
      Messages:
      15
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Novi, MI
      Year, Model & Trim Level:
      05 SportTrac XLT 2WD
      I've never noticed the lights and/or radio coming on with the key off, but now that you say that, for the first time last night, when I shut the truck off and took the key out, the needles continued to bounce and click.

      I was thinking it was a short, but it is sounding like a cluster.
       
    8. Clusterpup

      Clusterpup Well-Known Member

      Joined:
      April 6, 2009
      Messages:
      1,200
      Likes Received:
      0
      Trophy Points:
      46
      City, State:
      Miami, FL
      Year, Model & Trim Level:
      02 Sport Trac 4x4
      I had nothing to do with it.

      "Sorry for the necro", that's funny right there.
       
    9. crewguy

      crewguy New Member

      Joined:
      December 10, 2011
      Messages:
      5
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      CT
      Year, Model & Trim Level:
      04 Sporttrack
      Instrument cluster repair

      I was having the same issues. Speedo and tach not working some times and no odometer . I had it fixed at R.T. Grimm electronics in Camp Hill PA. The cost was $ 185.00. This includes shipping both ways.I shipped on Thursday and br noon on Friday I got a call back saying that repair was complete and cluster would be shipped in the afternoon. Awesome service and a great price I thought. If I had shipped earlier in the week it would have been 48 hour turn around from Connecticut. Here is a link to there web site.:):eek:

      http://www.rtgrim.com/instrument_cluster_repair
       
    10. Gambino

      Gambino New Member

      Joined:
      March 19, 2017
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Medford mass
      Year, Model & Trim Level:
      2004 ford sport trac xlt
      My 2004 sport trac is having issues cluster off and on windows work off and on and radio also says test . is this the cluster issue?
       
    11. crewguy

      crewguy New Member

      Joined:
      December 10, 2011
      Messages:
      5
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      CT
      Year, Model & Trim Level:
      04 Sporttrack
      I would most likely say it is the cluster. You can use the link from my earlier post. RT Grimm in PA. If they can't fix it the only cost will be shipping. It is a pain to get out but if you watch some YouTube videos it helps a lot. Mine has been fine since I sent it to them. Good luck.
       
    12. Vikki snow

      Vikki snow New Member

      Joined:
      January 20, 2018
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Cheyenne wyo
      Year, Model & Trim Level:
      2005 ford sport trac
      We changed the battery and now rthe cluster wont work and the radios off. No intermittent just off. Truck starts and runs exterior lights all work blinkers and heater work, no tach speedo or guages, also no rear window and no Window controls on the door. Already pulled cluster no burning or scorch checked all fuses and relays. At a loss. We've unhooked the battety before and this hasn't happened so where do i go now?
       
    13. swshawaii

      swshawaii Explorer Addict

      Joined:
      April 3, 2009
      Messages:
      8,936
      Likes Received:
      218
      Trophy Points:
      73
      City, State:
      Kailua-Oahu, Hawaii
      Year, Model & Trim Level:
      '05 Sport Trac XLS (RWD)
    14. crewguy

      crewguy New Member

      Joined:
      December 10, 2011
      Messages:
      5
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      CT
      Year, Model & Trim Level:
      04 Sporttrack
      Well after 2 1/2 years my t2004 sport trac started showing issues again. No door chime when opened with key in ignition. Gas gage not working , headlights coming on after locking truck and a host of other strange things. I sent it back to RT Grimm on Tuesday and on Wednesday it was on the way back to me. All issues were solved. I found out the hard way that the alternator does NOT charge the battery when the cluster is out. Stuck on side of the highway at 1 am on my way home from work. Live and learn.
       
    15. koda2000

      koda2000 Explorer Addict

      Joined:
      September 2, 2011
      Messages:
      11,056
      Likes Received:
      508
      Trophy Points:
      143
      Year, Model & Trim Level:
      x
      I'm guessing the alternator didn't charge because with the cluster out the CHG/BATT light isn't there to turn on the alternator (via the voltage regulator) once the engine is started. Did they give you an explanation?
       
      Last edited: February 2, 2018
    16. crewguy

      crewguy New Member

      Joined:
      December 10, 2011
      Messages:
      5
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      CT
      Year, Model & Trim Level:
      04 Sporttrack
      That is correct koda2000. I did not ask anyone about it. I searched charging issues and read somewhere, maybe on this forum Without the light the charging circuit is not complete and therefor the alternator never gets told to charge. As you said.
       
    17. Donald Dentremont

      Donald Dentremont New Member

      Joined:
      February 2, 2018
      Messages:
      2
      Likes Received:
      0
      Trophy Points:
      11
      City, State:
      willow spring, NC
      Year, Model & Trim Level:
      2001, Ford, Ranger Edge
      Found out what most of the causes of these issues is, your GEM Module controls most of your electric and electronic functions, like power windows, power locks, radio, windshield wipers and sprayer pump, it also controls most of the right side functions of you instrument cluster, like bulbs and so on. If you have a GEM module getting ready to go out you will have a lot of these issues especially your tachometer, to replace one you would have to go to your nearest junk yard and obtain one for about $50-$100 and pray that it works(ensure the part numbers match up on the GEM module) a new one from ford will cost anywhere from $200-$400 and then you still have to pay some one from ford to reprogram the New GEM Module for a modest $180-$200. See if this helps!
       
    18. Donald Dentremont

      Donald Dentremont New Member

      Joined:
      February 2, 2018
      Messages:
      2
      Likes Received:
      0
      Trophy Points:
      11
      City, State:
      willow spring, NC
      Year, Model & Trim Level:
      2001, Ford, Ranger Edge
      Also your speed sensor (which in most cases is located on top of the transmission) will cause the speedometer to malfunction as well
       

    Share This Page







    We Support Our Troops!