for access to reviews and discussion of the 2016 and 2017 Ford Explorer, Tech Tips, How to Articles, Off-Road Modification, Events, and more!

Register Today It's free! This box will disappear once registered!

Loud humming noise coming from the air filter

Discussion in 'Under the Hood' started by scubaman, June 23, 1999.

  • Searches ExplorerForum.com
    1. scubaman

      scubaman Guest

      I have a 95 Explorer and I'm getting a loud humming noise coming (it seems) from air filter compartment. I took it in for repair but they could not figure out what was causing the sound. Any ideas? I'm trying to avoid taking it to the dealer!! ($$$). It does do it all the time and it doesn't affect my engine, steering or braking. Please help me solve this problem because it's getting on my nerves.
       
    2. Support EF


      Join the Elite Explorers for $20 a year

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, add your own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



      to hide adverts.
    3. KyleC

      KyleC Member

      Joined:
      September 17, 1999
      Messages:
      90
      Likes Received:
      0
      Trophy Points:
      0
      I dont know if this helps but a friend of mine has a F-150 that was doing this because he drilled holes in the airbox and weakened the plastic just enough to make it resonate as the air goes throught it. It actually sounds like a cow mooing at certain RPMs.
       
    4. Chris Suerig

      Chris Suerig New Member

      Joined:
      October 6, 1999
      Messages:
      2
      Likes Received:
      0
      Trophy Points:
      0
      I have the same problem with my 97. Did you ever find the problem? my e - mail is Csuerig@aol.com. Thank you.
       
    5. rwp99exp

      rwp99exp New Member

      Joined:
      August 8, 2004
      Messages:
      10
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      el cajon, ca.
      Year and Model:
      1999 explorer sport
      mine does the same thing and i have the gen 1 K&N. they say it normal.....its just sucking a lot of air
       
    6. Alec

      Alec Elite Moderator Moderator Emeritus

      Joined:
      April 25, 2000
      Messages:
      15,997
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Houston, Texas
      Year and Model:
      2008 JK
      Very loud humming noise at idle (or low load) = IAC, Idle Air Control valve. A zillion posts on here about it, good luck!
       
    7. unclemeat

      unclemeat Well-Known Member

      Joined:
      October 20, 2002
      Messages:
      3,081
      Likes Received:
      2
      Trophy Points:
      48
      City, State:
      Richmond, VA
      Year and Model:
      91 sport
      It is also cheap and simple to fix.
       
    8. My98xplorer

      My98xplorer Active Member

      Joined:
      July 28, 2004
      Messages:
      108
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      lakeland fl
      Year and Model:
      1998 Sport
      I had the same problem with my Explorer. It was indeed the IAC, i took it off and cleaned it out and instantly no more humming!
       
    9. fordfordboy

      fordfordboy New Member

      Joined:
      March 30, 2008
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      texas
      Year and Model:
      95 explorer
      humming noise!

      The humming noise on my 95 explorer started after I instaled a K&N filter. It only does it at idle, not when i hit the gas. And it starts right about when it hits around 90 degrees outside. I will look at the control valve.
       
    10. SuperSix1

      SuperSix1 New Member

      Joined:
      April 20, 2009
      Messages:
      10
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      1997 XLT
      I just got my car back had the serp belts replaced some other things + a long overdue air filter/ oil change and my cars been humming in the low rpms at stop lights but never while on the highway/ constant moving ... I figure its just sucking alot of air in...
       
    11. ugoguyo

      ugoguyo New Member

      Joined:
      December 25, 2013
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      west covina , california
      Year and Model:
      1998 ford explorer
      Ive had that same humming from my air filter box for about 5 years ....Its annoying!! ...its time to fix it
       

    Share This Page









    We Support Our Troops!