1. It's time for our yearly 2 for 1 Elite Explorer sale! Last day is November 30!

    Right now you can purchase an Elite Explorer membership for $20 and receive a full two year membership!

    Click Here to start your membership!

    If you would like to extend an existing membership for two more years please contact "Rick" through a conversation/private message as I will have to set up existing memberships manually. Thank you and happy holidays!!!
    Dismiss Notice



Register Today It's free! This box will disappear once registered!

navigation SD card

Discussion in '2011-2016 My Ford Touch / In Vehicle Technology' started by cowboyearl, November 28, 2011.

  • Searches ExplorerForum.com
    1. cowboyearl

      cowboyearl New Member

      Joined:
      October 30, 2011
      Messages:
      44
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      columbia kentucky
      Year, Model & Trim Level:
      2015 exployer limited
      New exployer limited. Nav doesn't show exit off parkway. (its been there 5 years). Doesn't show bypass in our town, (its been there 3 years). Contacted ford. Response: contact telenav.
      Contacted telenav: response: contact ford.
      The nav system is a joke.
      Wife has a 2012 kia sporatge.
      Nav system is updated by satalite. Hers evens show a burger king thats been inour town less than a year.
      Never by a vehicle with an SD nav card.
       
    2. Support EF

      Holiday Special through Nov 30! Join the Elite Explorers for $20 for 2 years!

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. w1kedz

      w1kedz Guest

      Ford is switching from Telenav maps to Navteq maps in the 2012 "Performance Upgrade"... this should solve a lot of your problems. Navteq supplies the maps for most large gps firms (I believe Garmin even uses them)
       
    4. NCSWolfpak

      NCSWolfpak New Member

      Joined:
      March 25, 2011
      Messages:
      28
      Likes Received:
      1
      Trophy Points:
      0
      City, State:
      NC
      Year, Model & Trim Level:
      '11 Ltd.
      If you go to telenav.com and see your missing bypass and exit, then it's a Ford issue (they need an update). If you DON'T see it, however, don't take telenav's excuse that it's Ford's fault, because it's not up to Ford to update Telenav's maps. Ford's only problem here is using a sub-par vendor (IMO).
       
    5. cowboyearl

      cowboyearl New Member

      Joined:
      October 30, 2011
      Messages:
      44
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      columbia kentucky
      Year, Model & Trim Level:
      2015 exployer limited
      I did

      I went on televavs site. The exit was there, the the new subway was there. The new bypass was there. At the bottom it says updated 2008. Its been updated since 2008, but doesn't show on my nav system.
       
      Last edited: November 29, 2011
    6. calb

      calb Active Member

      Joined:
      July 10, 2011
      Messages:
      576
      Likes Received:
      0
      Trophy Points:
      0
      Year, Model & Trim Level:
      2012 AWD Explorer Limited
      We've been through this before. As I recall the Telnav maps on their site do not match up with the ones they are using in vehicles.

      New SD card and performance enhancements should fix things, but yeah - we have to wait.
       
    7. pacman9270

      pacman9270 Elite Explorer

      Joined:
      January 10, 2017
      Messages:
      82
      Media:
      10
      Likes Received:
      30
      Trophy Points:
      18
      City, State:
      Dallas, TX
      Year, Model & Trim Level:
      2016 Ford Explorer Sport
      There needs to be an update to the Navigation system. It seems outdated with some routes in Dallas, TX.
       
    8. 1995E

      1995E Elite Explorer

      Joined:
      July 16, 2010
      Messages:
      1,777
      Likes Received:
      37
      Trophy Points:
      58
      City, State:
      Maryland
      Year, Model & Trim Level:
      95 + 11 Ex both XLT
      You update it by buying new Navigation SD cards. I think the current maps are A7.
       
    9. pacman9270

      pacman9270 Elite Explorer

      Joined:
      January 10, 2017
      Messages:
      82
      Media:
      10
      Likes Received:
      30
      Trophy Points:
      18
      City, State:
      Dallas, TX
      Year, Model & Trim Level:
      2016 Ford Explorer Sport
      That's what I have and it still needs updating. End up relying on my phone for GPS.
       
    10. 207

      207 New Member

      Joined:
      March 21, 2017
      Messages:
      27
      Likes Received:
      4
      Trophy Points:
      3
      Year, Model & Trim Level:
      2016 Explorer Sport
      I bought an Explorer a little over a week ago and it has the A7 SD card in it. The navigation in this vehicle is nearly useless. For instance:

      We went to Newport, Rhode Island via I-95 N. (I know the quickest way is 102 to 4 to 138) This Nav wanted me to drive up to Providence, down to Fall River, MA to Rt 24 southwest back to Newport. Adding about another hour and a half to the trip!!!... Needless to say I ignored the Nav and took the 102 / 4 / 138 route.

      Then yesterday I had to take my wife to a Dr in Hawthorne, NY. It's right next door to the Westchester Medical Center, I know how to get there, I-684 south, Saw Mill Pkwy, onto the Sprain Brook Pkwy and get off at Bradhurst Ave.. Simple,no problem.
      Except I used the Nav... bad mistake. This dumb device had me exit at Chappaqua, NY, run Rt 117 south to Broadway and Commerce St to Bradhurst. Right through busy towns and loads of traffic lights.
      Actually, I should have shut it off when I was at the traffic light about a mile from home (Rt-37 & Jeanette Rd) and the stupid Nav told me to turn right and head north towards New Fairfield,CT instead of left, over Golden Hill and onto I-84 west to I-684 south.

      On the return trip.. Yeah, I jumped right onto the Sprain Brook and went up the Saw Mill... the Nav alerted me that there was construction at exit 43 and do I want to detour. Seeing that the Nav has been inaccurate so far I kept going. Was there construction?? Yup, in the low 30's exits. And what was at exit 43?.. Nothing, nada, zip, no delay or construction at all.

      It appears I have to use one of my Garmin's, with lifetime map updates, from now on..

      Sorry for the long & boring post..
      Rant over...
       
    11. peterk9

      peterk9 Staff Member Moderator Elite Explorer

      Joined:
      December 28, 2010
      Messages:
      18,091
      Likes Received:
      379
      Trophy Points:
      113
      City, State:
      Ottawa, Ontario area
      Year, Model & Trim Level:
      2017 Explorer Platinum
      Callsign:
      VE3
      Welcome to the Forum :wave:
      I believe there is an option for "quickest route" or something similar. Did you use that? I seldom use navigation but so far haven't any issues during the times I have.
      Several members have posted that they prefer to use Garmin or a similar cell based navigation option.

      Peter
       
    12. 207

      207 New Member

      Joined:
      March 21, 2017
      Messages:
      27
      Likes Received:
      4
      Trophy Points:
      3
      Year, Model & Trim Level:
      2016 Explorer Sport
      Yes, Peter I've tried the different settings it doesn't help. The above are just two examples. I've been using it around town experimenting and using "home" as a destination. Many times it had me in "WTF?" mode because it wanted me to go in directions that just don't make sense. Maybe they produced a bunch of messed up / error infected A-7 SD cards.
      Apparently this was a new card because the salesman showed it to me as he walked out of the parts dept with the NAV package.. so, I doubt it was somebody's "left over".
      Hopefully there's a fix for this when it goes in for service...
       
      • Like Like x 1

    Share This Page







    We Support Our Troops!