1. It's time for our yearly 2 for 1 Elite Explorer sale! Last day is November 30!

    Right now you can purchase an Elite Explorer membership for $20 and receive a full two year membership!

    Click Here to start your membership!

    If you would like to extend an existing membership for two more years please contact "Rick" through a conversation/private message as I will have to set up existing memberships manually. Thank you and happy holidays!!!
    Dismiss Notice



Register Today It's free! This box will disappear once registered!

New to the site..and new to the Explorer world (problem inside)

Discussion in 'Stock 2006 -2010 Explorers' started by Richard Means, November 9, 2017.

  • Searches ExplorerForum.com
    1. Richard Means

      Richard Means New Member

      Joined:
      November 9, 2017
      Messages:
      8
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Mooresville
      Year, Model & Trim Level:
      2006 Explorer Limited
      Hey there, I'm new to the Explorer game here. Just picked up a 2006 Explorer Limited and have picked up an issue. I let the truck sit for a couple weeks at home, came out today to start it and noticed the "door open" light is on and the parking brake light is on the dash and won't go off. I did some searching and seem some threads on here about using WD-40 on the latches, so I tried that (all 4 doors, rear gate and the rear glass) with no success.

      I also noticed that none of my dash lights are working (the ones behind the tach, Speedo, turn signals, brights etc) all of the lights themselves function as they should on the exterior of the vehicle. When I turn the headlight switch it turns the appropriate lights on on the outside of the truck as well and all the HVAC and steering wheel lights work as they should, but again nothing on the dash besides the info center, parking brake and "open door" light.

      Hopefully someone has had a similar experience and figured it out.

      Thanks in Advance,
      Ricky:help:
       
    2. Support EF

      Holiday Special through Nov 30! Join the Elite Explorers for $20 for 2 years!

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. 07EddyB

      07EddyB Active Member

      Joined:
      November 18, 2011
      Messages:
      262
      Likes Received:
      17
      Trophy Points:
      28
      City, State:
      Bowling Green, KY
      Year, Model & Trim Level:
      2007 Ford Explorer 4.6 V8
      Was it sitting outside or inside a garage? How long ago did you you buy it that everything was OK?
       
    4. Richard Means

      Richard Means New Member

      Joined:
      November 9, 2017
      Messages:
      8
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Mooresville
      Year, Model & Trim Level:
      2006 Explorer Limited
      was a couple weeks outside, got it about a month ago and everything worked fine. Only thing I can recall is one time I rolled the dimmer and it took a minute for the lights to come back bright
       
    5. 07EddyB

      07EddyB Active Member

      Joined:
      November 18, 2011
      Messages:
      262
      Likes Received:
      17
      Trophy Points:
      28
      City, State:
      Bowling Green, KY
      Year, Model & Trim Level:
      2007 Ford Explorer 4.6 V8
      Then I would guess one of two things - water intrusion or a weak battery. I would drive it and see if it clears up.
      I haven't seen it before but that's what makes sense. If you want to expedite the process then charge your battery while you check the fuse panel under the hood for moisture.
       
    6. Richard Means

      Richard Means New Member

      Joined:
      November 9, 2017
      Messages:
      8
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Mooresville
      Year, Model & Trim Level:
      2006 Explorer Limited
      I drove it for a few minutes and all seemed fine, it cranked right over just like normal. I checked the fuse under the dash on the drivers side. Is there anything in the box under the hood that it could be?
       
    7. Zorin

      Zorin New Member

      Joined:
      October 31, 2017
      Messages:
      17
      Likes Received:
      1
      Trophy Points:
      3
      City, State:
      Milton, KS
      Year, Model & Trim Level:
      2006 Explorer Eddie Bauer
      One quick thing I would scope out is the condition and cleanliness of the battery connections. Cars typically have a lot of the electrical items switched on the ground, and if you have a flaky ground connection due to filth, well, that can cause the entire issue. It doesn't even have to look like a science project....just a regular coating of filth will do the job. Fords do have issues with that, however, Chryslers are the world's worst.....they will not start with a marginal connection.

      Pull them battery connections, shine everything up nice, and make sure they are clean and tight.

      Tim
       
    8. Explorer_PL

      Explorer_PL Elite Explorer

      Joined:
      November 16, 2007
      Messages:
      1,975
      Likes Received:
      43
      Trophy Points:
      68
      City, State:
      Rockland County, NY
      Year, Model & Trim Level:
      06EB V8 & 07EB V6
      Do you have an aftermarket alarm or remote starter ? I do and when they tapped to the factory harness, they screwed it up and after few years the wires they tapped into corroded and all kind of things started happening: no interior lights, car unlocking itself every 30 seconds, dimmer not working,......
       
    9. Richard Means

      Richard Means New Member

      Joined:
      November 9, 2017
      Messages:
      8
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Mooresville
      Year, Model & Trim Level:
      2006 Explorer Limited
      nothing aftermarket on it at all, completely stock. On the dimmer dial if I roll it all the way to the right and click it the dome lights come on. It is wierd that the open door light stays on as well. This pic is with the truck running and the headlights on 20171109_182014.jpg
       
    10. Richard Means

      Richard Means New Member

      Joined:
      November 9, 2017
      Messages:
      8
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Mooresville
      Year, Model & Trim Level:
      2006 Explorer Limited
      ok so I have more problems lol. Pretty sure the GEM went out.....anyone know how to remove it? Is it on top of the fuses in the drivers foot well?
       
    11. skyhawk

      skyhawk New Member

      Joined:
      April 14, 2015
      Messages:
      5
      Likes Received:
      1
      Trophy Points:
      3
      Year, Model & Trim Level:
      2006 Explorer Limited V8
      You need to remove the dashboard to get the SJB (GEM) out. I'll be doing this myself in a couple weeks. I suspect I have a bad SJB, my puddle lamps don't work and my dash lights are stuck on a set dimming level. I've replaced the dimmer already. Codes stored in the SJB all point to replacement so that's what I'm doing. If you do this yourself you'll either need the Forscan software, or take it to the dealer and have them push your vehicle asbuilt configuration to the replacement SJB.
       
    12. Richard Means

      Richard Means New Member

      Joined:
      November 9, 2017
      Messages:
      8
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Mooresville
      Year, Model & Trim Level:
      2006 Explorer Limited
      I've still got no lights behind my cluster, nor do the buttons on my radio light up. Turn signals dont show up inside the truck, but work on the outside as they should. I'm guessing it' the GEM module
       
    13. skyhawk

      skyhawk New Member

      Joined:
      April 14, 2015
      Messages:
      5
      Likes Received:
      1
      Trophy Points:
      3
      Year, Model & Trim Level:
      2006 Explorer Limited V8
      Yeah I agree with that.. I found a replacement SJB for $50 shipped from a yard that I found on car-part.com. (Searched for 2006-2007, Fuse Box Cabin). If you go this route you can use one from a 2006 or 2007 as long as it wasn't a SportTrac.

      I have this cable that I use with ForScan:
      https://www.amazon.com/gp/product/B01N18TOFB/

      If you get one of these at least you can check to see if the SJB has any codes stored.
       
    14. Richard Means

      Richard Means New Member

      Joined:
      November 9, 2017
      Messages:
      8
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Mooresville
      Year, Model & Trim Level:
      2006 Explorer Limited
      so any GEM from 06-07 will work regardless of options, so long as it' not a Sport Trac?

      Sorry for sounding dumb lol, but what is FORScan?
       

      Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.
    15. skyhawk

      skyhawk New Member

      Joined:
      April 14, 2015
      Messages:
      5
      Likes Received:
      1
      Trophy Points:
      3
      Year, Model & Trim Level:
      2006 Explorer Limited V8
      Yes, but when you replace the GEM, you need to back up the configuration from the old one, and program it to the new one. (With Forscan or the Ford VCM diagnostic tool) So yes options do matter, but you can use a GEM (SJB) from 06-07. Not sure how SportTrac is different, but that's what the parts department said. You may luck out and find an SJB from a vehicle similarly optioned as yours.. If you still have weird things happening after swapping it out you could probably take it to the dealer to have the SJB re programmed.
       
    16. Richard Means

      Richard Means New Member

      Joined:
      November 9, 2017
      Messages:
      8
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Mooresville
      Year, Model & Trim Level:
      2006 Explorer Limited
      Does it cost any thing to get FORScan?
       

    Share This Page







    We Support Our Troops!