Dismiss Notice



Register Today It's free! This box will disappear once registered!

No brake, turn or hazard lights

Discussion in 'Tips and Technical Info posted by Technician's' started by mclark6649, May 15, 2018.

  • Searches ExplorerForum.com
    1. mclark6649

      mclark6649 New Member

      Joined:
      May 15, 2018
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Bellaire, OH
      Year, Model & Trim Level:
      2004 explorer
      Hello everyone,
      I have an 04 Explorer. The brake lights aren't working (third brake light does). No turn signals (front, rear, or dash indicators), no hazard lights (front, rear or dash indicators). I checked all the fuses (under hood and dash) checked the plug for the multifunction switch, plug is tight. Moved steering wheel up and down, no change. Checked all bulbs. Any suggestions? Thank You
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.

    Share This Page







    We Support Our Troops!