1. for access to reviews and discussion of the 2016 and 2017 Ford Explorer, Tech Tips, How to Articles, Off-Road Modification, Events, and more!

    Register Today It's free! This box will disappear once registered!

*OFFICIAL* MFT - MyFord Touch v2 Software Bugs and Fixes Thread

Discussion in '2011-2016 My Ford Touch / In Vehicle Technology' started by baxterdown, March 7, 2012.

  • Searches ExplorerForum.com
    1. baxterdown

      baxterdown Active Member

      Joined:
      January 26, 2011
      Messages:
      347
      Likes Received:
      0
      Trophy Points:
      16
      City, State:
      Fort Lauderdale, FL
      Year and Model:
      2011 Limited
      Come on, like you didn't know it's coming!?! LOL! :D
       
    2. Support EF


      Join the Elite Explorers for $20 a year

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, add your own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



      to hide adverts.
    3. suzook

      suzook Active Member

      Joined:
      December 31, 2006
      Messages:
      170
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      2006 Mountaineer
      1st bug! My nav isn't working! Ohhhh.....I need a new nav card???? Lol.
       
    4. cnsheets

      cnsheets Active Member

      Joined:
      September 7, 2011
      Messages:
      949
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      2011 Explemoner
      Dislike: MFT 4 quadrants home screen does not show RDS info, however, if you are on the radio screen, it shows song information, if you are on Climate screen, it shows song information in lower left entertainment tab, same with in Nav.... I know I can see song info on right hand cluster, but I would like to see it on the 4 quadrant home screen.
       
    5. smithj33

      smithj33 New Member

      Joined:
      March 11, 2012
      Messages:
      35
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Austin, Texas
      Year and Model:
      2012 Explorer XLT
      1. The name of the phone connected overlaps the phone signal meter in the upper left.
      2. When streaming over Bluetooth, track info shows on the main display but the instrument cluster shows Bluetooth Stream Detected instead of track info. Previous MFT showed track info on both.

      I have a thread outlining some USB issues with MFT and the iPhone.
       
    6. chimoman

      chimoman B

      Joined:
      February 8, 2011
      Messages:
      617
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      New Brunswick
      Year and Model:
      Explorer 2011 Ltd
      Song info is on the 4 quadrant home screen. In the square.
       
    7. cnsheets

      cnsheets Active Member

      Joined:
      September 7, 2011
      Messages:
      949
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      2011 Explemoner
      It shows it when I am using USB, but does not show when on FM. FM shows only when I am on all other screens except the main 4 quadrant home page. The 4 quadrant home screen only shows me the FM station number, such as 98.7, but nothing else.
       
    8. Joe Dirt

      Joe Dirt Explorer Addict

      Joined:
      October 4, 2007
      Messages:
      13,413
      Likes Received:
      2
      Trophy Points:
      0
      Year and Model:
      07 Camry
      Did it show all the time before? I know some stations don't list info all the time for all shows, and some stations don't have info at all.
       
    9. cnsheets

      cnsheets Active Member

      Joined:
      September 7, 2011
      Messages:
      949
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      2011 Explemoner
      Yes it showed all the time before for that particular station as well as other stations. If I switch to the entertainment tab, it shows it.... if I immediately switch to the 4 quadrant home view, it shows nothing
       
    10. chimoman

      chimoman B

      Joined:
      February 8, 2011
      Messages:
      617
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      New Brunswick
      Year and Model:
      Explorer 2011 Ltd
      Yep. You're right. That sucks. I guess we'll have to get use to using the right cluster.
       
    11. chimoman

      chimoman B

      Joined:
      February 8, 2011
      Messages:
      617
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      New Brunswick
      Year and Model:
      Explorer 2011 Ltd
      I have to bite my lip everytime that I use the word. CLUSTER. There is a word that starts with F and ends in K that follows that word. Nope, it's not Firetruck. This upgrade release has turned into a big giant cluster....... ck
       
    12. 2k11Explorer

      2k11Explorer New Member

      Joined:
      October 16, 2011
      Messages:
      37
      Likes Received:
      0
      Trophy Points:
      0
      1. Phone answer button occasional wont show up in the screen forcing me to find the phone to answer it.

      2. Black screen o death showed it's ugly head today.

      3. Audio source keeps dropping from Sirius to radio between drives. It also will drop from BT to Radio.

      4. Bluetooth seems to have wind noise occasionally. This is audible to the person you call and only for the first minute or so then it goes away.

      5. Caller ID fails quite often. Unknown caller displayed.
       
    13. chimoman

      chimoman B

      Joined:
      February 8, 2011
      Messages:
      617
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      New Brunswick
      Year and Model:
      Explorer 2011 Ltd
      Did you go back to your dealer and ask them to do the install? As I understand it they didn't go to the PTS site to check your vehicle. You may be missing something in the hardware dept that was put on later models. ?????


      Edit: I made the above comments as I was told by a Ford Employee that this was true. WRONG.
       
      Last edited: March 16, 2012
    14. Rial

      Rial New Member

      Joined:
      May 30, 2011
      Messages:
      21
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      Explorer XLT 4WD 2011
      I installed V 2.0 on Friday. Worked well until Sunday. Then

      1) The "eternal indexing cycle" for the USB started again. Voice command were not available. Had to re-index manually and then it worked ok.

      2) Today, and for one complete drive, entertainment was unavailable. Could not turn on radio or USB. After I dropped my daughter at school (engine off and doors closed/alarm on) and restarted, it worked OK.

      3) Does not show pictures in the phone agenda.

      Do not think it should be the expected behavior for an allegedly fully tested new version...
       
    15. harlenm

      harlenm Active Member

      Joined:
      July 24, 2011
      Messages:
      771
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Shelton, CT
      Year and Model:
      2013 Limited(lemon swap)
      location arrow disappears under street name. I actually find this really annoying.

      [​IMG]
       
    16. jrmexplorer

      jrmexplorer Well-Known Member

      Joined:
      April 19, 2011
      Messages:
      1,109
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      2011 Limited
      Other members have reported some weird behavior after installing until a fuse pull.
       
    17. jrmexplorer

      jrmexplorer Well-Known Member

      Joined:
      April 19, 2011
      Messages:
      1,109
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      2011 Limited
      Actually. . .

      According to the official ford bulletin, if syncmyride says to take it to the dealer. TAKE IT TO THE DEALER. Apparently they need to completely reflash the system.
       
    18. StunnedMonkey

      StunnedMonkey Active Member

      Joined:
      April 8, 2011
      Messages:
      237
      Likes Received:
      0
      Trophy Points:
      16
      City, State:
      Fort Wayne, IN
      Year and Model:
      2011 XLT
      This happens to me all the time, and it never happened previous to this upgrade. I'll select BT Audio and it will show it as selected, but FM (or whatever was previously playing) will remain displayed and playing. Clicking BT Audio over and over does nothing (as it's already "selected") and I need to switch over to some third screen (like USB or something) and then back over to BT. You can see below that BT Audio is selected and highlighted, but FM is still active in the window.

      [​IMG]
       
    19. Joe Dirt

      Joe Dirt Explorer Addict

      Joined:
      October 4, 2007
      Messages:
      13,413
      Likes Received:
      2
      Trophy Points:
      0
      Year and Model:
      07 Camry

      Exactly. I even posted the page on the dealer paperwork that says that, with the 3 event codes. But, it was deleted with a lot of other posts in that thread.
       
    20. Rial

      Rial New Member

      Joined:
      May 30, 2011
      Messages:
      21
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      Explorer XLT 4WD 2011
      Another smaller issue. The battery and signal drawings are not polished at all, the bars have not the same width.

      [​IMG]
       
    21. jrmexplorer

      jrmexplorer Well-Known Member

      Joined:
      April 19, 2011
      Messages:
      1,109
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      2011 Limited
      I had that happen to the point where I had to pull fuse 29. Hasn't happened since.
       
    22. cnsheets

      cnsheets Active Member

      Joined:
      September 7, 2011
      Messages:
      949
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      2011 Explemoner
      While on a route, I really like how the Nav shows the exit on the right side of the screen. From what I have seen so far, its very accurate to what the actual signs look like and read.....and it highlights the one brighter for which one you need to take........


      [​IMG]
       
    23. JDraper

      JDraper Somewhat Functional Moderator Emeritus

      Joined:
      January 11, 2001
      Messages:
      15,330
      Likes Received:
      1
      Trophy Points:
      58
      City, State:
      McVeytown, PA
      Year and Model:
      '11 XLT
      Mine hasn't shown any bugs yet, but I do see some things I'd like to have changed. I miss being able to have my background as the ONLY thing on the screen besides the four tabs in the corner and the fact it still doesn't recognize CD names and CD song names.
       
    24. ISMExplorer

      ISMExplorer New Member

      Joined:
      October 10, 2011
      Messages:
      25
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Anaheim, CA
      Year and Model:
      2012 Explorer XLT 4WD
      which fuse do you pull and from where? might come in handy after I have this update done.
       
    25. cnsheets

      cnsheets Active Member

      Joined:
      September 7, 2011
      Messages:
      949
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      2011 Explemoner
      Fuse #29, located in the fuse block under the dash to the upper left of the brake pedal, on the side. Have fun, its challenging to get to.
       
    26. jrmexplorer

      jrmexplorer Well-Known Member

      Joined:
      April 19, 2011
      Messages:
      1,109
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      2011 Limited
      Apparently on the 2012's there is a panel you have to remove to get at it. They made it more difficult to get to.

      Alternatively, you can unplug the battery terminal for a few minutes.
       

    Share This Page








    We Support Our Troops!