Dismiss Notice



Register Today It's free! This box will disappear once registered!

Please help!!! My explorer won't start

Discussion in 'Modified 2006 - 2010 Explorers' started by Billy t, January 12, 2018.

  • Searches ExplorerForum.com
    Tags:
    1. Billy t

      Billy t New Member

      Joined:
      November 20, 2017
      Messages:
      10
      Likes Received:
      0
      Trophy Points:
      11
      Year, Model & Trim Level:
      2006 ford explorer xlt
      Hello so I have a huge problem.
      3 months ago I tried to start my explorer but it won't start. No dash lights, no chimes noting at all. Radio works, headlights work. I towed it to my mechanic and it was there for a week. He said the instrument cluster is fried. He put a another used cluster and program the keys and everything. I paid $500 for everything. 3 weeks later I had a same problem again but after trying if for 10 mins it started right up but no dash lights at all. I drove it for couple of days and lights came back and everything seemed to be working. Yesterday I went to work in the morning and after I got off I tried to start nada nothing at all. I had the battery check and the battery is perfectly fine. I towed it again to the same mechanic again and Now He is saying Cluster is fired again and He needs to order another one. I have no car and I am so depressed now. Does anyone have any ideas or suggestions please help me. I think it is Anit theft system but the theft light is on (like it is armed and I put the key in the ignition light still on ) Please help
      Thanks
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. MotorCityFats13

      MotorCityFats13 Active Member

      Joined:
      January 25, 2015
      Messages:
      755
      Likes Received:
      23
      Trophy Points:
      18
      City, State:
      Flatrock MI
      Year, Model & Trim Level:
      2007 Explorer XLT 4.0L
      the anti-theft is in the cluster and if the new replacement fixed it then then something is not getting along somewhere..... a DTC should pop up on a scanner that reports a "theft detected" code
       
    4. Billy t

      Billy t New Member

      Joined:
      November 20, 2017
      Messages:
      10
      Likes Received:
      0
      Trophy Points:
      11
      Year, Model & Trim Level:
      2006 ford explorer xlt
      Yes exactly. My Mechanic is going crazy. Right now He is waiting on another cluster. When that one comes in He will put it in and then He will try to see what is the cause of all this.
       
    5. MotorCityFats13

      MotorCityFats13 Active Member

      Joined:
      January 25, 2015
      Messages:
      755
      Likes Received:
      23
      Trophy Points:
      18
      City, State:
      Flatrock MI
      Year, Model & Trim Level:
      2007 Explorer XLT 4.0L
      I shorted out my cluster and fried the illumination... now its picky when ever it wants to show me the display and when it does, turning on the lights kills it.... so does setting the speed control..... but it never gives me starting issues.... does all of your cluster lights work when you pop the key over..... I would ask about the lock mechanism where the transponder loop is, maybe its not reading the keys but at this point the mechanic would know about it and be ringing up cluster bills and swapping ignition switches
       
    6. Billy t

      Billy t New Member

      Joined:
      November 20, 2017
      Messages:
      10
      Likes Received:
      0
      Trophy Points:
      11
      Year, Model & Trim Level:
      2006 ford explorer xlt
      Yes when I fire it up all the dash lights everything works. But couple of times all the dash lights went off completely and the next day they came back and everything worked fine. Everything is just so strange.
      And yes the Mechanic should have checked everything. I will ask him about the lock mechanism.
       
    7. Billy t

      Billy t New Member

      Joined:
      November 20, 2017
      Messages:
      10
      Likes Received:
      0
      Trophy Points:
      11
      Year, Model & Trim Level:
      2006 ford explorer xlt
      Does any of you think that a bad ground can cause all this? My friend looked it and He told me my ground cable is not good. I told the to the Mechanic already.
      I appreciate everyone's opinion and help. Thanks
       
    8. MotorCityFats13

      MotorCityFats13 Active Member

      Joined:
      January 25, 2015
      Messages:
      755
      Likes Received:
      23
      Trophy Points:
      18
      City, State:
      Flatrock MI
      Year, Model & Trim Level:
      2007 Explorer XLT 4.0L
      well open loop electrical problems cause alot..... if you think a ground is bad fix it.... a ground cant ever be too good
       

    Share This Page







    We Support Our Troops!