1. for access to Ford Explorer and Ranger owner generated reviews and discussion, tech tips, how to articles, off-road modifications, events, and more! Since 1996 we have been the #1 Ford Explorer resource on the Internet. We also cover the Explorer Sport Trac, Mercury Mountaineer, Lincoln Navigator, Mazda Navajo, Mazda Pickups, and the Aerostar.

    Register Today It's free! This box will disappear once registered!

PRNDM light staying on

Discussion in 'Stock 2011 - 2017 Ford Explorer Discussion' started by Brownie11, December 27, 2012.

  • Searches ExplorerForum.com
    1. Brownie11

      Brownie11 New Member

      Joined:
      December 27, 2012
      Messages:
      10
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      2011 XLT AWD
      '11 XLT -- After exiting the vehicle, letting all the various lights and screens "time out" and shut off, the PRNDM shift-position indicator light in the speedometer is staying on (indefinitely). Also noticed that the red highlighted gear position isn't lighting. If you fiddle with the shifter lock button, and can get the red highlight light to come on, then the PRNDM light will properly go out along with the domelights, etc. The Dealer admits it's odd and is going to do some research to figure out what part to order and how to fix this. Will keep you updated, but thought in meantime someone might have similar experience?
       
    2. Support EF


      Join the Elite Explorers for $20 a year

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, add your own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



      to hide adverts.
    3. OneofMany

      OneofMany Active Member

      Joined:
      December 21, 2012
      Messages:
      191
      Likes Received:
      0
      Trophy Points:
      16
      City, State:
      Georgia Mountains- Talullah Falls
      Year and Model:
      94 expl 4x4
      Not that im an expert on that particular vehicle but from previous experience it sounds like there is an ignition switch issue. the gear selector and ignition switch are linked and are often problematic. try wiggling the ign. switch and gear selector.
       
    4. peterk9

      peterk9 Staff Member Moderator Elite Explorer

      Joined:
      December 28, 2010
      Messages:
      14,129
      Likes Received:
      53
      Trophy Points:
      68
      City, State:
      Ottawa, Ontario area
      Year and Model:
      2014 Lincoln MKT AWD
      Welcome to the Forum Brownie11.:wavey:
      The way you are describing the problem it almost seems like it is a issue with a poor electrical contact since wiggling the shifter. I don't recall a similar post with this problem although other members ahve reported getting a 'Shift to Park' message after parking their vehicle. It seems that was cured by replacing the shifter.
      By the way, if you add 'XLT' after 2011 in the left column profile you won't have to identify your Ex model everytime you post.
      Good luck and Season's Greetings.

      Peter
       
    5. FordService

      FordService Official Ford Rep

      Joined:
      October 25, 2010
      Messages:
      5,329
      Likes Received:
      1
      Trophy Points:
      48
      City, State:
      Dearborn, MI
      Year and Model:
      2014
      Hi Brownie11!

      You've already done what I would advise off the bat - you went to your dealership! Additionally, I am happy to get your case escalated to your regional customer service manager. Just send me a PM with your VIN, dealer, mileage, daytime phone number, and full name; I'll get things rolling.

      Great suggestions, OneofMany and Peter!

      Have a great weekend,

      Crystal
       
    6. keithd

      keithd New Member

      Joined:
      February 14, 2013
      Messages:
      2
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      Ford Explorer 2011
      2011 xlt gear lights stay on

      Same problem, but of course it doesnt do it at the dealer, its like taking a kid to the doctor, he gets well immediately. If they can't duplicate problem after today ill pick the vehicle back up and wait til it happens again. Glad i got the extended warranty. This will be the last Ford I EVER buy.
       
    7. peterk9

      peterk9 Staff Member Moderator Elite Explorer

      Joined:
      December 28, 2010
      Messages:
      14,129
      Likes Received:
      53
      Trophy Points:
      68
      City, State:
      Ottawa, Ontario area
      Year and Model:
      2014 Lincoln MKT AWD
      I assume that your last statement is based on more than just this post!
      My 2011 has been virually flawless over the almost 2 years I've had it. Of course if I had a extended list of problems that I've had with it, I would likely also share your feeling. FYI, I have seen a few similar posts by members on the Toyota Highlander Forum about their vehicles when I was active on there.

      Peter
       
    8. Brownie11

      Brownie11 New Member

      Joined:
      December 27, 2012
      Messages:
      10
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      2011 XLT AWD
      The dealer replaced the gear shift lever...and now all is well. Note to Keithd: the problem was intermittent, but I found that if I left the selector in PARK and toggled the release button on the backside of the shift lever, I could often duplicate the problem.
       
    9. vig1116

      vig1116 Active Member

      Joined:
      May 26, 2011
      Messages:
      314
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      monmouth, NJ
      Year and Model:
      2015 sport
      this is happening a lot more often than i realized.... This has been the biggest headache for me the last 3-4 months or so trying to get it fixed....
       
    10. dousley

      dousley New Member

      Joined:
      May 29, 2014
      Messages:
      2
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      2011
      New Post old issue 2011 Explorer shift indicator lights

      As on previous post I have seen about the shift lever indicator on the dash my lights are now own all time and the low pitch hummm.
      I have followed numerous in cab fixes to no evail.
      Ford Dealership first told me the battery was bad and computer didnt like that hence lights on on indicator.
      Now the is on 80 percent of time I stop my vehicle which is a nusiance and im not sure if that drains the battery or not.

      Sorry for mispelled words

      Thanks
      DO
       
    11. BlueSilver

      BlueSilver New Member

      Joined:
      July 12, 2014
      Messages:
      25
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      2013 Ford Explorer XLT
      Gear selector lights stay on dash

      Exterior courtesy and interior lights go off once door is shut but the PND lights in instrument panel stay illuminated. Everything else is off. Any ideas?
       
    12. peterk9

      peterk9 Staff Member Moderator Elite Explorer

      Joined:
      December 28, 2010
      Messages:
      14,129
      Likes Received:
      53
      Trophy Points:
      68
      City, State:
      Ottawa, Ontario area
      Year and Model:
      2014 Lincoln MKT AWD
      I know that the button on the shifter has caused problems with the "shit to Park" warning coming on. Not sure if this may be caused by the button as well. Next time it happens, try clicking the button a few times to see if the lights go off. Replacing the gear shift cleared up that issue.

      NOTE: I have merged your thread with this existing one on the same issue.

      Peter
       
    13. dco43054

      dco43054 Elite Explorer

      Joined:
      April 24, 2003
      Messages:
      1,245
      Likes Received:
      0
      Trophy Points:
      46
      City, State:
      cmh
      Year and Model:
      16 XLT
      Disconnect the negative battery cable, wait 30 seconds, reconnect. See if the condition persists.

      If you are lucky, it's just a body computer issue and a reset will fix it.
       
    14. BlueSilver

      BlueSilver New Member

      Joined:
      July 12, 2014
      Messages:
      25
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      2013 Ford Explorer XLT
      Thanks to both
       

    Share This Page








    We Support Our Troops!