Dismiss Notice



Register Today It's free! This box will disappear once registered!

question about motor mount installation

Discussion in 'Under the Hood' started by LukeDog3D, August 22, 2004.

  • Searches ExplorerForum.com
    1. LukeDog3D

      LukeDog3D Active Member

      Joined:
      September 2, 1999
      Messages:
      535
      Likes Received:
      0
      Trophy Points:
      16
      City, State:
      Lafayette, Louisiana
      Year, Model & Trim Level:
      '92 Sport
      I was curious as to how difficult replacing the two motor mounts on a 1st gen is. I read the haynes manual, it seems simple enough. Any experiences, comments, wisdom, tips, etc? Any suggestions as to where to buy them? (autozone has them; lifetime warranty for about 25 bucks each)
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. LukeDog3D

      LukeDog3D Active Member

      Joined:
      September 2, 1999
      Messages:
      535
      Likes Received:
      0
      Trophy Points:
      16
      City, State:
      Lafayette, Louisiana
      Year, Model & Trim Level:
      '92 Sport
      Thanks for the suggestions.


      Kidding...just being facetious. Hadn't logged in here in a long time, figured why not revive a 14 year old thread?
       

    Share This Page







    We Support Our Troops!