1. for access to Ford Explorer and Ranger owner generated reviews and discussion, tech tips, how to articles, off-road modifications, events, and more! Since 1996 we have been the #1 Ford Explorer resource on the Internet. We also cover the Explorer Sport Trac, Mercury Mountaineer, Lincoln Navigator, Mazda Navajo, Mazda Pickups, and the Aerostar.

    Register Today It's free! This box will disappear once registered!

Rt Turn signal light buzzing istead of blink

Discussion in 'Modified 1995-2001 Explorers' started by go4par, January 6, 2009.

  • Searches ExplorerForum.com
    1. go4par

      go4par New Member

      Joined:
      December 26, 2008
      Messages:
      7
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Auburn,Washington
      Year and Model:
      '96 Explorer XLT
      Hi every one,
      my 96 Ford Explorer right turn signal light buzzing instead of blinking but left side works normal. I checked rt front and rear turn signal light bulbs and they all looked OK.
      I replaced turn signal relay(flasher) from auto part store but still have same problem.(of course it's not returnable)
      Can any one tell me what's the next step could be?
       
    2. Support EF


      Join the Elite Explorers for $20 a year

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, add your own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



      to hide adverts.
    3. Dan Whitaker

      Dan Whitaker One fast putty tat Elite Explorer

      Joined:
      December 24, 2001
      Messages:
      7,056
      Likes Received:
      0
      Trophy Points:
      46
      City, State:
      Raytown MO (Kansas City suburb)
      Year and Model:
      No Mounty no more.
      Your MFS (multi function switch) is bad. AKA your turn signal switch.
       
    4. AMMO_HOOAH

      AMMO_HOOAH Active Member

      Joined:
      December 16, 2005
      Messages:
      858
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Spokane, Wa
      Year and Model:
      1996 Ex V8, AWD XLT
      Sounds more like a relay to me, the click is the sound of the relay moving. A buzzing instead sounds like it isn't doing what is should. I'd start there anyway, just swap one side for the other if it doesn't change then it's some where else.
       
    5. parad1mg

      parad1mg Elite Explorer

      Joined:
      August 7, 2007
      Messages:
      866
      Likes Received:
      1
      Trophy Points:
      0
      City, State:
      La Mirada, CA
      Year and Model:
      '97 Mounty 5.0 AWD
      mine does the same thing too when its cold although it rarely does it.. along side of that my wipers do occasionally stop in the middle of the windshield..

      i've already swapped and replaced the wiper relays but havent touched the relay for the turn signal..

      go4par, post your result if ever you decide to replace your multifunction stalk..
       
    6. jad2411

      jad2411 Well-Known Member

      Joined:
      October 29, 2006
      Messages:
      2,135
      Likes Received:
      0
      Trophy Points:
      46
      City, State:
      El Paso, TX
      Year and Model:
      blue 02 xlt & white 02xls
      Yup, mine was doing the same thing, got a new one for like 25dlls and changed it myself in ~20 min
       
    7. dogfriend

      dogfriend Human-Animal Hybrid

      Joined:
      July 22, 2002
      Messages:
      7,565
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Carmichael, CA
      Year and Model:
      '97 Sport 4x4
      MFS. Mine used to do the same thing. Buzz on left turn, no buzz on right turn (or was it the other way?, I forget because I replaced it years ago).

      Some people report smoke coming out. That's a bad thing. Maybe you want to replace it before it gets that bad, or maybe you like living on the edge. Your call.
       
    8. go4par

      go4par New Member

      Joined:
      December 26, 2008
      Messages:
      7
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Auburn,Washington
      Year and Model:
      '96 Explorer XLT
      Dan,Dog friend,jad2411 and others,
      Thanks you very much guys.
      i replaced MFS(multi function swith) this morning and working fine.
      It took me about 40 min to remove and replace first time and cost me less than $60 include tax on local parts store.
       
    9. CrazyAlaskan

      CrazyAlaskan Active Member

      Joined:
      December 15, 2008
      Messages:
      288
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Wasilla, Alaska
      Year and Model:
      1994 Explorer Limited 4wd
      I had the same problum but it turned out to be a short in the steering column for me, the wire would touch when i dropped the steering wheel down.looks like you got your fixed already though :D
       
    10. Tom T.

      Tom T. New Member

      Joined:
      July 22, 2010
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Tempe, AZ
      Year and Model:
      '96 Explorer XLT
      1996 Explorer flasher relay buzzing noise, inoperable windows.

      Hi Everyone,

      Just replaced my flasher relay switch due to signals not operating. Now, the signals work but I'm getting an intermittent yet steady buzzing noise from the new flasher relay and to boot, my power windows are not working now either. Would this also be an MFS problem? Thanks in advance for your help!
       
    11. luvtoretire

      luvtoretire New Member

      Joined:
      May 15, 2011
      Messages:
      2
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Victor, NY
      Year and Model:
      '05 Explorer XLT
      Turn Signal "growling at me"....

      I have a 2005 Explorer which has served me well so far. Recently, while using my turn signal indicator, I notice if I accidently move it forward ever so slightly while using it to indicate a right turn, it "growls" at me. It is VERY sensitive. About 50% of the time, while indicating a right turn, it works fine but, as I said, if it moves ever so slightly forward while I lift the handle, it will make a buzzing or growling sound and the signal will not work. I think it is the multifunction switch, which everyone seems to reference. Can anyone confirm my suspicions? THANKS.
       
    12. jad2411

      jad2411 Well-Known Member

      Joined:
      October 29, 2006
      Messages:
      2,135
      Likes Received:
      0
      Trophy Points:
      46
      City, State:
      El Paso, TX
      Year and Model:
      blue 02 xlt & white 02xls
      when I removed mine I was able to visually tell that it was damaged so you might start by removing it and inspecting it. Mine looked burnt and some plastic parts a bit melted. To this day the new one still works :)
       
    13. luvtoretire

      luvtoretire New Member

      Joined:
      May 15, 2011
      Messages:
      2
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Victor, NY
      Year and Model:
      '05 Explorer XLT
      turn signal noise.....

      Thanks for the info. I assume you mean the multifunction module, not the flasher module. I tried to access the flasher module but Ford, in their emminent wisdom, opted to make this darn near inaccessible for a novice like me. I also moved the steering wheel down and it seems to work better now. I am wondering if I have a slightly pinched wire in the column which may be the root cause of all of this. Again, thanks for your response and suggestions.
       
    14. majerusmusic

      majerusmusic New Member

      Joined:
      April 9, 2009
      Messages:
      2
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Lynnwood,Wa.
      Year and Model:
      95 Explorer Eddie Bauer
      :exp::exp:
      Thanks Crazy, I was looking to see what the problem could be and saw your post. I remembered adjusting my steering wheel on an extended trip the other day and bingo, that's it. Even if I turn the signal on and then adjust the steering wheel it stops working and starts buzzing.
       

    Share This Page








    We Support Our Troops!