and gain access to Reviews and Discussion of the 2016 and 2017 Ford Explorer Tech Tips, How to Articles, Off-Road Modifications and Events, Street Truck Mods and Events, and much more! Since 1996 our community has covered every aspect of the Ford Explorer, Ford Ranger and all vehicles based on this platform.

Register Today It's free! This box will disappear once registered!

Subwoofer Popping when hitting bumps, hitting brakes or taking turns...

Discussion in 'Explorer Audio & Navigation' started by markedman450, July 11, 2011.

  • Searches ExplorerForum.com
    1. markedman450

      markedman450 Active Member

      Joined:
      July 16, 2006
      Messages:
      114
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Enola, PA
      Year and Model:
      01 Sport
      So i have a 02 sport trac and got the mtx thunderform under the seat. Have a 4500 mtx sub in it with a mtx amp. Gains barely over half way up. Just recently it started making popping noises like its getting static in the lines, sometimes small and sometimes enough to make the sub hit pretty hard. Doesnt always do it, it does it randomly.. I checked connections and all are tight. I have it grounded to one of the bolts holding the seat down and also sanded off all the paint around the bolt. Possibly the amp going bad? Or possible RCA wire going bad? I have power wires and rcas on opposite side of the vehicle and do not cross at all. It has me stumped..Any ideas???
       
    2. Support EF


      Join the Elite Explorers for $20 a year

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, add your own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



      to hide adverts.
    3. Ji553r

      Ji553r New Member

      Joined:
      April 5, 2011
      Messages:
      21
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Jacksonville, NC
      Year and Model:
      05 XLS
      change the ground do it to bare paint and a self tapping screw. sounds to me your ground is inbetween the seat mount and the bolt head which doesnt sound ideal. change your ground and see if it continues. Static could be from power wire to close to RCA's causing interference
       

    Share This Page









    We Support Our Troops!