and gain access to Reviews and Discussion of the 2016 and 2017 Ford Explorer Tech Tips, How to Articles, Off-Road Modifications and Events, Street Truck Mods and Events, and much more! Since 1996 our community has covered every aspect of the Ford Explorer, Ford Ranger and all vehicles based on this platform.

Register Today It's free! This box will disappear once registered!

Turn Signal Lights Stop Flashing

Discussion in 'Stock 2002 - 2005 Explorers' started by Exproblems, May 29, 2011.

  • Searches ExplorerForum.com
    1. Exproblems

      Exproblems Well-Known Member

      Joined:
      April 17, 2011
      Messages:
      1,687
      Likes Received:
      3
      Trophy Points:
      48
      City, State:
      Orchard Park, N.Y.
      Year and Model:
      '05 Explorer XLT 4.0L
      Yesterday while driving, I noticed my turn signal lights stopped flashing, blinking on and off. The lights lit up, but didn't blink and froze like that on the dash and on the outside turn signal lights. This happened once before but they started working again after I jiggled the turn signal handle around. Today they worked okay. I've done some research in here on this problem and read where some people had issues with a "multifunction switch" inside the steering column. Does anyone have an idea what might be causing this since the turn signal lights do work and have power going to them, so it's not a bulb or turn signal flasher problem as far as I know. Could this just be a loose wire problem in the steering column and what could cause them to stop blinking yet they light up and have power going to them? Also, if anyone knows how to remove the steering column cover to get at the turn signal handle guts, please let me know. Thanks for any advice.
       
    2. Support EF


      Join the Elite Explorers for $20 a year

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, add your own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



      to hide adverts.
    3. xlt03

      xlt03 Active Member

      Joined:
      April 22, 2009
      Messages:
      346
      Likes Received:
      0
      Trophy Points:
      16
      City, State:
      Bay Point, CA
      Year and Model:
      2016 Sport
    4. Exproblems

      Exproblems Well-Known Member

      Joined:
      April 17, 2011
      Messages:
      1,687
      Likes Received:
      3
      Trophy Points:
      48
      City, State:
      Orchard Park, N.Y.
      Year and Model:
      '05 Explorer XLT 4.0L
      >>>>>>>>>>>>
      >>>>>>>>>>>>>>>>>>>>>>

      Thanks XLT03 for the reply and info and to Big Rondo for another great post and pics of the repair. When I searched for this type of article, Big R's post didn't come up. I saw some other posts from other people on this topic. Do you happen to know the cost of a Multifunction Switch? From the pics I have seen of it, it appears fairly large and since it is a Ford product, expensive? Also, could the fact that I keep the tilt steering column in the highest or upper most position when I drive, cause any problems with the function of this Multifunction Switch? All the other functions (wipers and washer fluid) appear to work okay, just the turn signal lights quit blinking every now and then. Thanks again!
       
    5. swetrid

      swetrid Well-Known Member

      Joined:
      September 30, 2010
      Messages:
      1,896
      Likes Received:
      1
      Trophy Points:
      0
      City, State:
      Reading Pa
      Year and Model:
      1999 Eddie Bauer
      It is the turn signal flasher in the central junction box.
       
    6. Exproblems

      Exproblems Well-Known Member

      Joined:
      April 17, 2011
      Messages:
      1,687
      Likes Received:
      3
      Trophy Points:
      48
      City, State:
      Orchard Park, N.Y.
      Year and Model:
      '05 Explorer XLT 4.0L
      >>>>>>>>>>
      >>>>>>>>>>

      Is the turn signal flasher unit and round like, plug in device that is plugged into the fuse box located under the driver side foot well area? I've never changed one or ever had problems with any turn signal Multifunction switches etc, other than have a few turn signal bulbs burn out over time in 34 years of driving. Thanks for the suggestion Swetrid!
       
    7. Mindy

      Mindy New Member

      Joined:
      July 24, 2011
      Messages:
      8
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Montreal
      Year and Model:
      2000 XLT
      Hey, did you ever figure out the problem?? I am having the same problem with my Explorer right now.
       
    8. leov5

      leov5 New Member

      Joined:
      January 21, 2010
      Messages:
      15
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      So. Cal.
      Year and Model:
      2002 Mtnr V8 AWD
      There is a flasher relay on the back side of the main fuse panel under the drivers side dash. If you look in the owners manual it will show were to look. It states that you have to remove the fuse panel to change it, not so. If you feel above the fuse panel you will feel the relay, I used a very small flat screwdriver to lift up the relay. Note make a mark on the relay before you remove it, with a pen, marker, etc... This will show how to put back the new one. I went to Pep Boys and got the relay, sorry forgot the part number. Cost was $12.99+tax. Reinstalling the relay, just line the pins before you install with the old one with marks will show which direction to to place it back in. Worth a try before you go installing a new multi function switch.
       
    9. bakerm5

      bakerm5 New Member

      Joined:
      April 21, 2012
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Apex, NC
      Year and Model:
      2003 Explorer
      Thanks for the suggestion to try this out. My scenario was the turn signal would activate, then anywhere from 5 seconds to 45 seconds it would just stop blinking (with the light off). This would happen turning both left and right.

      I decided rather than taking apart the steering wheel to try the flasher, and viola: 10 minutes later it was working.
       
    10. Hoz

      Hoz New Member

      Joined:
      June 8, 2016
      Messages:
      7
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Orlando, Florida
      Year and Model:
      2005 Sport trac
      OK it might be the year but my fuse box is on the side and I did not find a relay on the side under or anywhere. Has anyone a 2005 sport trac that had this issue and fixed it? In my case it looks like it started when someone sprayed a cleaner behind the fuse box but it could be as everyone else is saying that its the MFS. Can anyone answer, please.
       
    11. swshawaii

      swshawaii Explorer Addict

      Joined:
      April 3, 2009
      Messages:
      7,449
      Likes Received:
      33
      Trophy Points:
      58
      City, State:
      Kailua-Oahu, Hawaii
      Year and Model:
      '05 Sport Trac XLS (RWD)
      ^ What problems are you having? Intermittent turn signals? IF you have a tilt column, try cycling it up and down several times leaving it all the way UP. If that helps you have the common MFS connector binding issue.
      http://www.mysporttrac.com/MySportTrac/projects/Steering_Column_Wiring_Repair_Gen1.pdf

      Also be aware your ST has "another" power distribution fuse/relay box under the hood just aft of the battery. (Pages 192-194)
      http://www.fordservicecontent.com/Ford_Content/catalog/owner_guides/05p27og3e.pdf
       
    12. Hoz

      Hoz New Member

      Joined:
      June 8, 2016
      Messages:
      7
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Orlando, Florida
      Year and Model:
      2005 Sport trac
      Yes intermittent sometimes it will run fine all day then just stay on no blinking. My steering wheel has never been moved since I bought it and I d
      ok so try the tilt thing didn't work. So I am guessing it's the relay under the hood just doesn't make sense the relay covers more than just the blinker. How come everything else is working fine!?!?
       

    Share This Page






    We Support Our Troops!