1. for access to Ford Explorer and Ranger owner generated reviews and discussion, tech tips, how to articles, off-road modifications, events, and more! Since 1996 we have been the #1 Ford Explorer resource on the Internet. We also cover the Explorer Sport Trac, Mercury Mountaineer, Lincoln Navigator, Mazda Navajo, Mazda Pickups, and the Aerostar.

    Register Today It's free! This box will disappear once registered!

vacuum leak ???

Discussion in 'Stock 2006 -2010 Explorers' started by Gitzit2, August 5, 2010.

  • Searches ExplorerForum.com
    1. Gitzit2

      Gitzit2 New Member

      Joined:
      August 5, 2010
      Messages:
      10
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Catonsville, Maryland
      Year and Model:
      '07 XLT
      i have read Turdle's VERY informative post about locating the vacuum canister on the gen 2 vehicles.
      i have not been able to locate it in my 2007 XLT.
      checked under the fenderwells and all around under the hood but can not locate it.

      i believe that i am havng a similar problem with the canister since all works fine except when accelerating under a load i loose my vent air and it goes to defrost.
      i am getting no hissing sounds and the a/c control work fine under all other conditions.

      thanks in advance for your help!


      Mark
       
    2. Support EF


      Join the Elite Explorers for $20 a year

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, add your own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



      to hide adverts.
    3. mace_b

      mace_b New Member

      Joined:
      August 11, 2010
      Messages:
      5
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      utah
      Year and Model:
      2008 XLT
      Same problem

      I have the same problem you described. Is the canister the problem. Or should I look at a valve sticking because i hear hissing under the dash, there was mention of this in another post. Any one have any ideas?
       
    4. Gitzit2

      Gitzit2 New Member

      Joined:
      August 5, 2010
      Messages:
      10
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Catonsville, Maryland
      Year and Model:
      '07 XLT
      i do not get the hissing sound that i believe would indicte a straight vacuum leak...probably in the passenger compartment.

      my issue is that i appear to loose vacuum when engine operating conditions are such that it does not produce as much vacuum....ie under load up a long hill when towing, etc.
      i believe that my problem is with my vacuum resivour (sp) but i can not find it under the hood.
       
    5. mace_b

      mace_b New Member

      Joined:
      August 11, 2010
      Messages:
      5
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      utah
      Year and Model:
      2008 XLT
      The hissing wasn't all the time. so i went to the check valve took it off and blew throught it a few times put it back on havn't the vent problem for a couple of days. hopefully that fixed it.
       
    6. Gitzit2

      Gitzit2 New Member

      Joined:
      August 5, 2010
      Messages:
      10
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Catonsville, Maryland
      Year and Model:
      '07 XLT
      mace....
      hope it solves your problem
       
    7. Gitzit2

      Gitzit2 New Member

      Joined:
      August 5, 2010
      Messages:
      10
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Catonsville, Maryland
      Year and Model:
      '07 XLT
      btt

      any help woould be much appreciate!
       
    8. mr2fix2it

      mr2fix2it Active Member

      Joined:
      October 23, 2003
      Messages:
      185
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      new york
      Year and Model:
      98 sport w/06 mustang 4.0
      you have to look for a leak in vacuum system it could be supply or it could be in the dash check all functions to make sure they work correctly max a/c, a/c,vent ,floor/defrost,defrost a common thing is max a/c door gets knocked off under pass side of dash the storage bottle is there also look for hoses off
       
    9. mace_b

      mace_b New Member

      Joined:
      August 11, 2010
      Messages:
      5
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      utah
      Year and Model:
      2008 XLT
      It started up again My next step is to replace the check valve as soon as i can get to the dealer and pick one up. Gitzit2 my canister is under the dash right by the passengers feet. (2008 explorer XLT) Have you replaced that check valve yet?
       
    10. Gitzit2

      Gitzit2 New Member

      Joined:
      August 5, 2010
      Messages:
      10
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Catonsville, Maryland
      Year and Model:
      '07 XLT
      thanks for the replies!!!!

      i have not been able to find any obvious leaks so i was thinking that it was a vacuum capacity issue and targeted the vacuum reservior ball...but couldn't find it
      i was looking under the hood

      i'll look for and check the ball under the dash to see if it has water in it but the check valve would certainly seem like a possible cause, too.

      is the check valve near the canister under the dash, too?

      thanks again...you've been a big help
       
    11. mace_b

      mace_b New Member

      Joined:
      August 11, 2010
      Messages:
      5
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      utah
      Year and Model:
      2008 XLT
      The check valve on my vehicle is under the hood passanger side up high right up against the firewall about 1 1/2 inch long white and black. I pulled mine off again it was sticking open so i sprayed a little spray silicone in it working good now. ordered a new one at the dealer 13.00 dollars.
       
    12. Gitzit2

      Gitzit2 New Member

      Joined:
      August 5, 2010
      Messages:
      10
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Catonsville, Maryland
      Year and Model:
      '07 XLT
      i located and pulled the "ball" from under the dash and found it to be empty with all connections apparently tight

      thanks for the tip on finding the check valve :thumbsup:

      i pulled it, too, blew air in one end and it flowed freely.

      when i blew in the other end i expected it to seal completely but it did not.....some air still went through....not as much as the first direction but it certainly did not seal

      i sprayed silicone as you did and now it seals nicely.

      we'll test drive it this weekend and give a report

      many thanks, mace_b!!!!!
       
    13. Gitzit2

      Gitzit2 New Member

      Joined:
      August 5, 2010
      Messages:
      10
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Catonsville, Maryland
      Year and Model:
      '07 XLT
      found the leak to be on the temp knob on the hvac controls
      very small leak in cooling but when weather changed and needed heat the leak was very obvious
      ended up taking to dealer
      the fix was a new HVAC console

      thanks for all the replies
       
    14. HoustonTexan

      HoustonTexan New Member

      Joined:
      March 9, 2012
      Messages:
      3
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      2010 Explorer
      I have a 2010 with the air conditioning going off under load. I hear the hiss then a thump that sounds like it is from the passenger side. Where is this check valve? I dont see it under the dash. Any pics? I am sure it is a vacuum leak but dont know where!
       
    15. GB1977

      GB1977 New Member

      Joined:
      June 25, 2016
      Messages:
      3
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Georgia
      Year and Model:
      2010 Explorer XLT
      Houston,
      I'm having the same problem. Hoping someone chimes in with more information.
       

    Share This Page








    We Support Our Troops!