1. for access to reviews and discussion of the 2016 and 2017 Ford Explorer, Tech Tips, How to Articles, Off-Road Modification, Events, and more!

    Register Today It's free! This box will disappear once registered!

where is the Idle Air Control Valve on 2004 explorer

Discussion in 'Stock 2002 - 2005 Explorers' started by Zepplin454, September 3, 2009.

  • Searches ExplorerForum.com
    1. Zepplin454

      Zepplin454 New Member

      Joined:
      February 28, 2009
      Messages:
      35
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Pelham, NH
      Year and Model:
      2004 Explorer 4.0
      i have a 04 explorer 4.0 with the engine code K flex fuel engine with fly-by-wire throttle system and i was looking for the Idle Air Control Valve and cant find it. its not where they used to be on the older 4.0. i want to clean it cause im doing a bunch of maintence stuff before winter. it also has this little akip or studder when idleing. has new plugs and wires. coil maybe? accel make a coild for them that is suposed to have 10-15,000 more volts has anyone used one wanted to get one for a little more performance
       
    2. Support EF


      Join the Elite Explorers for $20 a year

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, add your own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



      to hide adverts.
    3. jrford

      jrford Well-Known Member

      Joined:
      March 1, 2005
      Messages:
      2,538
      Likes Received:
      0
      Trophy Points:
      46
      City, State:
      Birmingham, MI
      Year and Model:
      '10 Sport Trac
      with fly-by-wire, there is no iac, the computer can do the same thing since it actually controls the throattle plate via stepper motor.
      But there is a MAF sensor that can be cleaned carefully. Vacuum leak is another possibility.
       
    4. tonydp

      tonydp Active Member

      Joined:
      July 20, 2009
      Messages:
      129
      Likes Received:
      0
      Trophy Points:
      0
      Year and Model:
      2002 Eddie Bauer
      what about an '02 4.0?
       
      Last edited: September 24, 2009
    5. High_Order1

      High_Order1 Active Member

      Joined:
      January 31, 2007
      Messages:
      497
      Likes Received:
      0
      Trophy Points:
      16
      City, State:
      near Oak Ridge, TN
      Year and Model:
      2005 Jack Bauer Edition
      jims' right.

      I *think* the break point was 2004. On earlier ones, it would be mounted where you'd expect on the tb. There are pictures in here somewhere...


      Far as the coil, I couldn't find a specialty one in the same approx price range as stock. I even talked to accel about it. Well, I emailed them, and they promptly ignored me. (did you know accel and mallory appear to be the same people??)

      Where'd you find that accel pack? (interested)


      Shawn
       
    6. ReinIse

      ReinIse Member

      Joined:
      February 8, 2007
      Messages:
      66
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Huntsville, Alabama
      Year and Model:
      '04 4.0L SOHC V6 Explorer
      yeah i'm having the same problem, its gotta have an IAC, i just bought one for an 04 explorer from advanced auto parts.

      let me know if you find it
       
    7. jrford

      jrford Well-Known Member

      Joined:
      March 1, 2005
      Messages:
      2,538
      Likes Received:
      0
      Trophy Points:
      46
      City, State:
      Birmingham, MI
      Year and Model:
      '10 Sport Trac
      There should no IAC on an '04, do you have a cable going to the TB?
      My V8 Fly-By wire is in the pic below. Just above the '4' of the 4.6 there is a motor.
       

      Attached Files:

    8. BRG

      BRG New Member

      Joined:
      September 17, 2009
      Messages:
      6
      Likes Received:
      0
      Trophy Points:
      0
      No IAC on 04 4.0l

      I just went thru this... took explorer to dealer, shop foreman owes me a coffee as he bet me there was an IAC .... went out to truck and with the new drive by wire system the IAC has been eliminated... They updated my pcm, I had just installed new plugs, air filter, cleaned MAF and installed new fuel filter. Truck is running much better. The fuel filter is a must if you dont know when the last time it was changed. Just my 2 cents... good luck
       
    9. High_Order1

      High_Order1 Active Member

      Joined:
      January 31, 2007
      Messages:
      497
      Likes Received:
      0
      Trophy Points:
      16
      City, State:
      near Oak Ridge, TN
      Year and Model:
      2005 Jack Bauer Edition
      So....

      what do think you wound up actually getting?

      PS - I can't stand advanced. The last part I bought from them was wrong, they knew it was wrong, and a poorly painted reman at that. Bleah
       

    Share This Page








    We Support Our Troops!