and gain access to Reviews and Discussion of the 2016 and 2017 Ford Explorer Tech Tips, How to Articles, Off-Road Modifications and Events, Street Truck Mods and Events, and much more! Since 1996 our community has covered every aspect of the Ford Explorer, Ford Ranger and all vehicles based on this platform.

Register Today It's free! This box will disappear once registered!

Why would "THEFT" light stay on?

Discussion in 'Under the Hood' started by Phili602, April 10, 2012.

  • Searches ExplorerForum.com
    1. Phili602

      Phili602 New Member

      Joined:
      February 10, 2011
      Messages:
      47
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Phoenix
      Year and Model:
      96 Sport
      I have a 1998 XLT Explorer and whenever I press the lock button on either the remote or the door to lock the doors, the THEFT light stays on and flashes brighter and its causing my battery to drain. Any suggestions are greatly appreciated!
      Thanks
       
    2. Support EF


      Join the Elite Explorers for $20 a year

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, add your own profile photo, upload photo attachments directly to your posts and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



      to hide adverts.
    3. NHarris

      NHarris Well-Known Member

      Joined:
      May 31, 2010
      Messages:
      3,393
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Gillette, Wyoming
      Year and Model:
      04 Wrangler, 08 Ranger

      Based off of my assumption (on my 98), all second gens have the theft light that flashes.
      Let's specify here...
      Is it causing your battery to completely lose charge, or just drain it slightly?
       
    4. Phili602

      Phili602 New Member

      Joined:
      February 10, 2011
      Messages:
      47
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Phoenix
      Year and Model:
      96 Sport
      Well my battery was fine until i came out after leaving it sitting for a few days and it didnt want to start.... The theft light flashes on and off even when the doors are unlocked, but when i press the door lock button on either the door or remote, the theft light stays illuminated and just flashes brighter even though its already lit
       
    5. NHarris

      NHarris Well-Known Member

      Joined:
      May 31, 2010
      Messages:
      3,393
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Gillette, Wyoming
      Year and Model:
      04 Wrangler, 08 Ranger
      Did you get your battery tested?
      The ECU, radio, and whatever other electronics also are using power to stay on. I'll have to take a look at my X and see what its theft light is doin.
       
    6. Phili602

      Phili602 New Member

      Joined:
      February 10, 2011
      Messages:
      47
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Phoenix
      Year and Model:
      96 Sport
      Yes i got my battery tested. 1st time was at a oreilly and they said it was no good. But I think the oreilly i went to is shady because I took the same battery to autozone and they said its good and fully charged it for me. 1 of the cells on the battery were low so I just added some distilled water and it seems to be keeping its charge but havent put it back in the x because I dont want it to drain it again. My previous x had the theft light and it would flash all the time weather the doors were locked or not. and it wouldnt stay lit and flash like this 1 is doing.
       
    7. Phili602

      Phili602 New Member

      Joined:
      February 10, 2011
      Messages:
      47
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Phoenix
      Year and Model:
      96 Sport
      Any suggestions on what could be causing the theft light to stay on at all times? How could i disconnect that light so it doesnt drain my battery?
       
    8. Trolling

      Trolling Active Member

      Joined:
      June 11, 2010
      Messages:
      226
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      kah-lee-fur-nyah
      Year and Model:
      1997
      for the past few occasions that had my instrument cluster all apart, my theft light bulb has been a tiny red LED. Even with that left on for a week, it can't drain a car battery dry.

      Maybe there is something else draining your battery?
       
    9. IZwack

      IZwack Moderator Emeritus

      Joined:
      February 5, 2003
      Messages:
      21,788
      Likes Received:
      1
      Trophy Points:
      0
      City, State:
      Germantown, MD
      Year and Model:
      1998 Ford Explorer
      If it's blinking super fast and you hear a relay clicking at the same rate, then this usually means that the battery voltage is too low. If the battery is ~3-ish years old, then it's probably time to replace it. Another culprit could be of course the alternator not charging the batt.
       
    10. Phili602

      Phili602 New Member

      Joined:
      February 10, 2011
      Messages:
      47
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Phoenix
      Year and Model:
      96 Sport
      It may be another issue then besides the light
       
    11. jturkey69

      jturkey69 New Member

      Joined:
      August 5, 2011
      Messages:
      49
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Sheboygan,WI
      Year and Model:
      98 Explorer 5.0 AWD
      Did you ever figure this out? I replaced my starter yesterday, and after reconnecting battery, I started the truck to verify it was fixed, and immediately shut it off...three seconds later I tried again, and lo and behold the theft light and dash lights went dim, and clicking under dash (pats). I got on Ed here and found I had to insert keys in one by one to reprogram so to speak. All works fine now except theft light stays on when locked, and flashes a little brighter while its already on. What could this be? Did I miss a step?
       
    12. jturkey69

      jturkey69 New Member

      Joined:
      August 5, 2011
      Messages:
      49
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Sheboygan,WI
      Year and Model:
      98 Explorer 5.0 AWD
      Anyone? I have to disconnect and reconnect my battery, and cycle my keys to get it to start every time.! Dealer says that has never happened before...go figure..and wants 100$ plus to look at it. After a day the theft light flashes normally. Is there a sequence of things I need to do?
      Any help is appreciated.
       

    Share This Page




    Click Here

    We Support Our Troops!