Serious Explorations Ford Explorer and Ranger Message Board
#1 Resource for Ford Explorer and Ranger Owners - By Enthusiasts, for Enthusiasts.


Ford Explorer Generation Guide

EF Swag Store 2015 Ford Explorer Forums Elite Membership Chat Room My Posts Reviews Explorer Photo Gallery
Go Back   Ford Explorer and Ranger Forums "Serious Explorations" > Ford Explorer Ranger Repair - Troubleshooting - Modifications & Detailing Forums > 2002 - 2005 Explorer Mountaineer 3rd Generation > Stock 2002 - 2005 Explorers

Notices

Stock 2002 - 2005 Explorers Questions related to non-modified 2002 - 2005 Explorers and Mountaineers. Problem solving, maintenance, TSB, service bulletins, owner reviews, specifications. Sport Trac and Sport use the 1995-2001 forum.

Turn signal flashing quick. All bulbs working.

Reply
 
Thread Tools
Old 05-16-2007, 08:21 AM   #1
nurseryboy
Central PA
05 Mountaineer
 
Join Date: Apr 2007
Posts: 3

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Original Poster)
Turn signal flashing quick. All bulbs working.

Hey guys,

I have an 05 Mountaineer that just this morning started having an issue. Whenever I turn on the right-hand turn signal, it flashes really fast. The left-hand signal works fine. The first thing I checked were the light bulbs, and everything seems to be on. The front-right bulb flashes, but the rear-right does not, although the bulb is on.

I can hear the flasher relay or whatever clicking under the dash, and it clicks really fast, at the same speed as the signal indicator and front-right signal. Are there any bulbs that I could have missed that would cause this, or could a bulb be working but somehow faulty, or would it more likely be that the flasher relay is going out?

Thanks!
nurseryboy is offline   Reply With Quote
( Join the Elite Explorers )

For only $20 per year you can become an Elite Explorer. Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn what modifications really work without having to experiment on your own. Elite Explorer members can change the forum "styles" to see less ads, no green underlined links, and many other benefits such as being able to store 1000 Private Messages, upload photo attachments directly to your posts and more. Join the Elite Explorers today.


Old 05-16-2007, 09:26 AM   #2
BrooklynBay
Brooklyn, NY
 
BrooklynBay's Avatar
88 89 93 95 96 Aerostars
 
Join Date: Nov 2005
Posts: 47,046

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 121 Post(s)
It's one of the bulbs. Turn on the hazard lights, and headlights to check all of the bulbs. Have someone else step on the brake pedal while you check the rear lights.
BrooklynBay is online now   Reply With Quote
Old 05-16-2007, 09:48 AM   #3
ExploringNC
Hickory, NC
'98 XLT, '91 EB
 
Join Date: Oct 2006
Posts: 1,060

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Not sure on the 3rd gen. but on the 2nd it would be the multifunction switch assembly on the steering column. This is a common problem on the 2nd gen.




__________________
'91 EB 4.0 OHV 4x4
31x10.5 Maxxis Bighorn's

Uwharrie 2010

BrooklynBay's List of Useful Threads
ExploringNC is offline   Reply With Quote
Old 05-16-2007, 09:56 AM   #4
aeaglenfitch
Maple Valley, WA
'98 Mounty 4.0 SOHC 4x4
 
Join Date: Mar 2007
Posts: 488

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
you said one of the bulbs just stays on? try replacing it, bulbs r pretty cheep




__________________
98' Mounty. Hella brand lights behind the grille. 31x12.5x15 Thornbird TSL's. Custom quick disconnects on rear sway bar. Torsion Twist + Shackles + AAL. Volant Intake, Flowmaster 50 SUV, Moog Ball joints, new front hubs, Brown Wire Mod, Henson Performance Custom Tuning via xCalibrator1
Car Domain
aeaglenfitch is offline   Reply With Quote
Old 05-16-2007, 10:17 AM   #5
dman726749
Mall Crawler
Greenwood Indiana
 
dman726749's Avatar
96 xlt
 
Join Date: Jul 2003
Posts: 3,735

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
definetly replace that bulb that is not flashing...circuit is not completing like nornal...hense the quick flashing.




__________________
Dustin
96 XLT 2" tt and war shackles, 3" b/l 33" X-Terrains, Custom Snorkel Sold
Dman726749's 96 X!!!
2006 F150 FX4 Super Crew
Indianapolis Indiana Senior Portrait and Wedding Photography
dman726749 is offline   Reply With Quote
Old 05-16-2007, 11:31 AM   #6
nurseryboy
Central PA
05 Mountaineer
 
Join Date: Apr 2007
Posts: 3

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Original Poster)
Ok.. I just had someone watch the lights while I tried the ones I couldn't see myself (brakes & reverse), and the right-brake bulb doesn't brighten. The bulb is lit when the driving lights are on, but it doesn't brighten up when you press the brakes. Could this still be a bulb problem, or would it be something else? I didn't know since it still lights up, just doesn't get brighter.

Thanks.
nurseryboy is offline   Reply With Quote
Old 05-16-2007, 11:38 AM   #7
dman726749
Mall Crawler
Greenwood Indiana
 
dman726749's Avatar
96 xlt
 
Join Date: Jul 2003
Posts: 3,735

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
still a bulb..they are dual element bulbs...one element is break lights (not working) and the other is the running lights...replace that bulb too...




__________________
Dustin
96 XLT 2" tt and war shackles, 3" b/l 33" X-Terrains, Custom Snorkel Sold
Dman726749's 96 X!!!
2006 F150 FX4 Super Crew
Indianapolis Indiana Senior Portrait and Wedding Photography
dman726749 is offline   Reply With Quote
Old 05-16-2007, 11:47 AM   #8
nurseryboy
Central PA
05 Mountaineer
 
Join Date: Apr 2007
Posts: 3

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Original Poster)
Ok, great. I'll pick up a bulb this evening. Thanks for the help!
nurseryboy is offline   Reply With Quote
Old 02-24-2010, 07:35 AM   #9
apexfireman08
Apex,NC
97 eddie bauer
 
Join Date: Dec 2009
Posts: 4

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
hey yall my name is ryan and i have a 97 explorer eddie bauer and all my bulbs work but my driver side is flashing fast. when my hazards on the bulb is lit up but not blinking but when driver side blinker on its going very fast idk whats wrong with it i reploaced it and still fast
apexfireman08 is offline   Reply With Quote
Reply

Suggest this thread to friends:



Join the "Elite Explorers" Today!



Search Explorer Forum


Top of Page

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:44 PM.



US Flag
We Support Our Troops!

Explore the site!


Copyright 2014 - 1996 Rick Horwitz Photography



Ford Motor Company is not involved in the management of this site in any way.



All tips on this site are for use at your own risk and discretion.

Modifying the suspension on any vehicle will cause changes to its handling characteristics.



Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.