Serious Explorations Ford Explorer and Ranger Message Board
#1 Resource for Ford Explorer and Ranger Owners - By Enthusiasts, for Enthusiasts.


Ford Explorer Generation Guide

EF Swag Store 2016 Ford Explorer Forums Elite Membership Chat Room My Posts Reviews Explorer Photo Gallery
Go Back   Ford Explorer and Ranger Forums "Serious Explorations" > Ford Explorer Ranger Repair - Troubleshooting - Modifications & Detailing Forums > 2002 - 2005 Explorer Mountaineer 3rd Generation > Stock 2002 - 2005 Explorers

Notices

Stock 2002 - 2005 Explorers Questions related to non-modified 2002 - 2005 Explorers and Mountaineers. Problem solving, maintenance, TSB, service bulletins, owner reviews, specifications. Sport Trac and Sport use the 1995-2001 forum.

2004 V8 Explorer check charging system problem.

Reply
 
Thread Tools
Old 11-28-2008, 10:04 PM   #1
kent tango
2004 Explorer Eddie Bauer
 
Join Date: Nov 2008
Posts: 1

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Original Poster)
Dk Exp 2004 V8 Explorer check charging system problem.

I am a new forum member and found a similar problem to the one I have where a 05 explorer V6 owner had a "check charging system" problem but never posted a solution?? I have had a similar problem with my 04 Explorer V8 (w/ tow package), but many trips to Ford dealers and private mechanics have not solved the problem. I have added a new battery and alternator, and during the latest dealer siege of three weeks, they tried (2) new PCM's, did a grid (wiring harhas) overlay test and they still have not solved the problem?? The "check charging system and battery light" still come on regularly. The system is charging OK but misses occasionally under light load?? Dealer now says I need a new $1,400 (primary) wiring harnas. The dealer says he "believes" that is the solution (even though he could not find it), but also says it might need one or two other harnaces if that doesn't work. The Explorer only has 37K and is well maintained (Mobile 1 etc.) This is getting out of hand and driving me nuts!! I need a reliable tow vehicle soon!! to make a trec south with my trailer in January and February. Any help would be appreciated!!! -Kent-
kent tango is offline   Reply With Quote
( Join the Elite Explorers )

Join the Elite Explorers for only $20 a year. Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications really work without having to experiment on your own. Elite Explorer members can change the forum "styles" to eliminate most ads, including blue underlined links, and no ads on photos. Other benefits include the ability to store 1000 Private Messages, upload photo attachments directly to your posts and to our Photo Gallery and more. Join the Elite Explorers today.


Old 11-28-2008, 11:48 PM   #2
Sams01XplrSprt
Southern Cali Explorer
Newport Beach California & Bay Area California
 
Sams01XplrSprt's Avatar
2001 Sport (sold)
 
Join Date: Nov 2004
Posts: 15,660

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
welcome kent




__________________
2001 Ford Explorer Sport 4.0 sohc engine. Mods include: dual 40 series flowmasters & high flow k&n air filter & removed silencer & yellow fog lights (sold for $1,800) as of 2-26-12
Sams01XplrSprt is offline   Reply With Quote
Old 11-29-2008, 10:22 PM   #3
BrooklynBay
Brooklyn, NY
 
BrooklynBay's Avatar
88 89 93 95 96 Aerostars
 
Join Date: Nov 2005
Posts: 48,103

Vehicle Specs

Mentioned: 4 Post(s)
Tagged: 1 Thread(s)
Quoted: 217 Post(s)
Welcome to this forum! Your charging system doesn't have that many separate harnesses that it should cost that much. Check Autozone's website for a schematic diagram. You could check each wire from point to point with a continuity tester.
BrooklynBay is online now   Reply With Quote
Old 02-10-2014, 06:53 AM   #4
fkatende
2004 ford explorer
 
Join Date: Feb 2014
Posts: 1

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
i just acquired a 2004 ford explorer XLT and has the similar problem 'check charging system'. i have looked at various problem and seems like its a common problem and there is no lasting solution to it.......has some one out there managed to have it fixed for good..help..!
fkatende is offline   Reply With Quote
Old 02-15-2014, 09:54 PM   #5
mikebusc
2004 Mercury Mountaineer
 
Join Date: Feb 2014
Posts: 1

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Looks Like you responded to an old post (2009). I have the same problem. Going to try tomorrow changing battery and checking belt and alternator. Let me know if you find anything too.
mikebusc is offline   Reply With Quote
Old 05-28-2014, 09:49 AM   #6
westernMdlife
2004 Explorer XLT
 
Join Date: Oct 2013
Posts: 1

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I've been having this problem for the last week. It will start up but the alternator doesn't charge the battery back up. I started it and kinda "jump started"/excite the I term on the alternator and it began to charge properly, until I turn the engine off. Replaced the alternator (new), battery is 2yrs old but still good. Have the constant hot to the alternator, continuity on stator wire is good. Only thing I'm left with is something with the ignition switch? ..IDK..
westernMdlife is offline   Reply With Quote
Old 05-29-2014, 12:42 AM   #7
name420420
Fairmont,West Virginia
2002 ford explorer 4.6L
 
Join Date: May 2014
Posts: 30

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
mine had this issue. was a broken wire in the harness by the battery. I also am told their is a fuse by the alternator itself. but not sure about that
name420420 is offline   Reply With Quote
Old 05-29-2014, 03:58 PM   #8
phouse
Phila PA
1991 Explorer
 
Join Date: Mar 2001
Posts: 76

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Have you tried a alternator from the Ford Dealership?




__________________
1991 Explorer 4WD 4DR 4.0 V6 Pushrod 196K blown head gasket.. RIP
2005 Explorer XLT
1998 Mercedes Benz E 430 Sport
1987 Oldsmobile Cutlass Salon V8 Factory Bucket seats
phouse is offline   Reply With Quote
Reply


Suggest this thread to friends:



Join the "Elite Explorers" Today!



Search Explorer Forum


Top of Page

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:31 AM.



US Flag
We Support Our Troops!

Explore the site!


Copyright 2014 - 1996 Rick Horwitz Photography



Ford Motor Company is not involved in the management of this site in any way.



All tips on this site are for use at your own risk and discretion.

Modifying the suspension on any vehicle will cause changes to its handling characteristics.



Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.