Serious Explorations Ford Explorer and Ranger Message Board
#1 Resource for Ford Explorer and Ranger Owners - By Enthusiasts, for Enthusiasts.


Ford Explorer Generation Guide

EF Swag Store 2015 Ford Explorer Forums Elite Membership Chat Room My Posts Reviews Explorer Photo Gallery
Go Back   Ford Explorer and Ranger Forums "Serious Explorations" > Ford Explorer Ranger Repair - Troubleshooting - Modifications & Detailing Forums > 2006 - 2010 Explorer Mountaineer 4th Generation > Stock 2006 -2010 Explorers

Notices

Stock 2006 -2010 Explorers Stock 2006 -2010 Ford Explorer Forum. Problem solving, maintenance, TSB, service bulletins, owner reviews, specifications.

Light doesn't work on my gear shifter ('07), easy fix?

Reply
 
Thread Tools
Old 12-29-2009, 01:36 PM   #1
AllFiredUp
Lake Arrowhead (Waleska), GA
2007 Eddie Bauer 4.0L 2WD
 
Join Date: May 2008
Posts: 18

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Original Poster)
Light doesn't work on my gear shifter ('07), easy fix?

I've got an '07 Explorer Eddie Bauer and the gear shift position indicator (PRNDL) light has stopped working. I'm hoping it's just a bulb that needs replacing. The Owner's Manual lists the specs of a few hundred bulbs and fuses scattered around the vehicle, just not the one I need!

Before I continue, I should mention that the warranty expired long ago. It's barely three years old but has 118,000 miles on it!

Have any of you guys had the same problem? I'm wondering how easy it is to access the location of the light? Do you get to it from the top side (by removing the base/trim of the shifter somehow...or does that section of the console have to be removed? Any advice or input will be greatly appreciated!

I love the new interior design (compared to the '04 XLT I had before) but there are a few minior things they overlooked. A redundant gear shift indicator in the instrument panel is one of them! Every other vehicle I've ever driven with a floor mounted shifter showed the gear selected next to the shifter itself (like mine) AND in the instrument panel also.

I probably seem really petty letting this irritate me so much, but it's only because I can't find anything else wrong with it!
AllFiredUp is offline   Reply With Quote
( Join the Elite Explorers )

For only $20 per year you can become an Elite Explorer member. Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications really work without having to experiment on your own. Elite Explorer members can change the forum "styles" to eliminate most ads, including blue underlined links, and no ads on photos. Other benefits include the ability to store 1000 Private Messages, upload photo attachments directly to your posts and to our Photo Gallery and more. Join the Elite Explorers today.


Old 12-29-2009, 01:55 PM   #2
bill32399
Oregon
07 ST XLT 4x4 V8
 
Join Date: Aug 2009
Posts: 271

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
You may want to lookup an LED bulb to put in there if it is hard to get to. I use www.ledtronics.com
bill32399 is offline   Reply With Quote
Old 12-29-2009, 02:11 PM   #3
Curtis
Orlando, FL
04' and 96' XLT's
 
Join Date: Nov 2001
Posts: 1,673

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
I cant add much value for replacing the bulb... but lets see if I understand correctly.

In the 4th gens with the console shifter, the PRND12 is displayed by the shifter AND in below the Speedo? And the one below the speedo does not do anything?

Seems cheesy to me!




__________________
Curtis
````````````````````````
2008 Expedition EL Limited
2004 Explorer XLT 4x4 4.6
1970 Buick GS 455 Silver Mist
Curtis is offline   Reply With Quote
Old 01-18-2010, 07:25 PM   #4
gt_2001
Ontario
2006 Explorer XLT V8 Tow
 
Join Date: Aug 2003
Posts: 27

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by AllFiredUp View Post
I've got an '07 Explorer Eddie Bauer and the gear shift position indicator (PRNDL) light has stopped working. I'm hoping it's just a bulb that needs replacing. The Owner's Manual lists the specs of a few hundred bulbs and fuses scattered around the vehicle, just not the one I need!

Before I continue, I should mention that the warranty expired long ago. It's barely three years old but has 118,000 miles on it!

Have any of you guys had the same problem? I'm wondering how easy it is to access the location of the light? Do you get to it from the top side (by removing the base/trim of the shifter somehow...or does that section of the console have to be removed? Any advice or input will be greatly appreciated!

I love the new interior design (compared to the '04 XLT I had before) but there are a few minior things they overlooked. A redundant gear shift indicator in the instrument panel is one of them! Every other vehicle I've ever driven with a floor mounted shifter showed the gear selected next to the shifter itself (like mine) AND in the instrument panel also.

I probably seem really petty letting this irritate me so much, but it's only because I can't find anything else wrong with it!

Did you find out what bulb it takes? Mine is out also and I want to get the bulb before I take the console apart!
Thanks
gt_2001 is offline   Reply With Quote
Old 01-18-2010, 07:54 PM   #5
Hitchhikingmike
Dallas, Texas
'02 XLS
 
Join Date: Jan 2008
Posts: 1,529

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
You really rack up the miles quickly. On a side question, have you had any drivetrain problem at all?




__________________
-Mike
Hitchhikingmike is offline   Reply With Quote
Old 01-19-2010, 01:05 PM   #6
AllFiredUp
Lake Arrowhead (Waleska), GA
2007 Eddie Bauer 4.0L 2WD
 
Join Date: May 2008
Posts: 18

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Original Poster)
Racking up miles...

Quote:
Originally Posted by Hitchhikingmike View Post
You really rack up the miles quickly. On a side question, have you had any drivetrain problem at all?
Actually, I can't take sole credit for all of those miles. It was originally my best friend's company vehicle. In 15 months, he put 72,000 miles on it! In the subsequent two years, I've racked up 46,000 more.

When he got it new, it had a sticker price of $35k and change. I bought it 15 months later with 72k miles for $15,750! SWEET DEAL!

The '05 Explorer XLT 4x4 that I had it prior to my '07 Eddie Bauer was also his company vehicle. It was close to two years old and had just over 80k miles and only cost 11k! And the Fusion SEL V6 that he got after the '07 EB now belongs to my mom and dad...they paid barely $10k for it with 64k miles on it.

He even let me spec out my EB when he originally got to order it back in late '06. The only let-down was the exterior color- I picked Red Fire Metallic and ended up with Dark Cherry Metallic instead...but it's grown on me.

As for drivetrain problems, I've had ZERO mechanical issues! It's a 4x2, which simplifies things (although my '05 4x4 has over 160k with no probs). And the 4.0L V6/5-speed auto are pretty much bulletproof in my experience.
AllFiredUp is offline   Reply With Quote
Old 01-19-2010, 01:09 PM   #7
AllFiredUp
Lake Arrowhead (Waleska), GA
2007 Eddie Bauer 4.0L 2WD
 
Join Date: May 2008
Posts: 18

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Original Poster)
Haven't figured it out yet!

Quote:
Originally Posted by gt_2001 View Post
Did you find out what bulb it takes? Mine is out also and I want to get the bulb before I take the console apart!
Thanks
One service/parts guy at the Ford dealership claimed that the bulb couldn't be replaced??? The only fix was to replaced the entire shifter, what a joke!

I plan to pull the console soon (maybe this weekend) and figure out what it needs. When I do, I'll let you know!
AllFiredUp is offline   Reply With Quote
Old 01-19-2010, 04:17 PM   #8
ZO6_Vette
Long Island
2006 EB
 
Join Date: Dec 2008
Posts: 68

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Even though Ferd may not sell it they do not make bulbs so someone else makes it and sells it. Take it apart and see what bulb it is.
I had to do this with a few bulbs in my 1998 Grand Marquis. Headlight switch, Digital dash and some other stuff.
ZO6_Vette is offline   Reply With Quote
Old 01-20-2010, 07:27 PM   #9
gt_2001
Ontario
2006 Explorer XLT V8 Tow
 
Join Date: Aug 2003
Posts: 27

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks guys.
gt_2001 is offline   Reply With Quote
Old 01-20-2010, 09:01 PM   #10
Joe Dirt
Elite Explorer
 
Joe Dirt's Avatar
07 Camry
 
Join Date: Oct 2007
Posts: 13,442

Vehicle Specs

Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
And be careful whigh you use- LED's or a brighter bulb will create a really bright distraction. I replaced the bulb in my SHO which fit, but was a brighter bulb, and it was way too bright, and I had to take it apart and replace it with the correct one.




__________________
If we confess our sins, He is faithful and just and will forgive us our sins and purify us from all unrighteousness. 1 John 1:9
Joe Dirt is offline   Reply With Quote
Reply



Suggest this thread to friends:



Join the "Elite Explorers" Today!



Search Explorer Forum


Top of Page

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:57 PM.



US Flag
We Support Our Troops!

Explore the site!


Copyright 2014 - 1996 Rick Horwitz Photography



Ford Motor Company is not involved in the management of this site in any way.



All tips on this site are for use at your own risk and discretion.

Modifying the suspension on any vehicle will cause changes to its handling characteristics.



Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.