Serious Explorations Ford Explorer and Ranger Message Board
#1 Resource for Ford Explorer and Ranger Owners - By Enthusiasts, for Enthusiasts.


Ford Explorer Generation Guide

EF Swag Store 2015 Ford Explorer Forums Elite Membership Chat Room My Posts Reviews Explorer Photo Gallery
Go Back   Ford Explorer and Ranger Forums "Serious Explorations" > Ford Explorer Ranger Repair - Troubleshooting - Modifications & Detailing Forums > Explorer Audio & Navigation

Notices

Explorer Audio & Navigation Audio and navigation systems. CD, DVD, MP3, GPS, Video, Mobile Computer, Speakers, Amplifiers.

Subwoofer Popping when hitting bumps, hitting brakes or taking turns...

Reply
 
Thread Tools
Old 07-11-2011, 07:08 PM   #1
markedman450
Enola, PA
01 Sport
 
Join Date: Jul 2006
Posts: 114

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Original Poster)
Subwoofer Popping when hitting bumps, hitting brakes or taking turns...

So i have a 02 sport trac and got the mtx thunderform under the seat. Have a 4500 mtx sub in it with a mtx amp. Gains barely over half way up. Just recently it started making popping noises like its getting static in the lines, sometimes small and sometimes enough to make the sub hit pretty hard. Doesnt always do it, it does it randomly.. I checked connections and all are tight. I have it grounded to one of the bolts holding the seat down and also sanded off all the paint around the bolt. Possibly the amp going bad? Or possible RCA wire going bad? I have power wires and rcas on opposite side of the vehicle and do not cross at all. It has me stumped..Any ideas???
markedman450 is offline   Reply With Quote
( Join the Elite Explorers )

For only $20 per year you can become an Elite Explorer member. Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications really work without having to experiment on your own. Elite Explorer members can change the forum "styles" to eliminate most ads, including blue underlined links, and no ads on photos. Other benefits include the ability to store 1000 Private Messages, upload photo attachments directly to your posts and to our Photo Gallery and more. Join the Elite Explorers today.


Old 07-20-2011, 01:11 PM   #2
Ji553r
Jacksonville, NC
05 XLS
 
Join Date: Apr 2011
Posts: 16

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
change the ground do it to bare paint and a self tapping screw. sounds to me your ground is inbetween the seat mount and the bolt head which doesnt sound ideal. change your ground and see if it continues. Static could be from power wire to close to RCA's causing interference
Ji553r is offline   Reply With Quote
Reply



Suggest this thread to friends:



Join the "Elite Explorers" Today!



Search Explorer Forum


Top of Page

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:40 PM.



US Flag
We Support Our Troops!

Explore the site!


Copyright 2014 - 1996 Rick Horwitz Photography



Ford Motor Company is not involved in the management of this site in any way.



All tips on this site are for use at your own risk and discretion.

Modifying the suspension on any vehicle will cause changes to its handling characteristics.



Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.