Serious Explorations Ford Explorer and Ranger Message Board
#1 Resource for Ford Explorer and Ranger Owners - By Enthusiasts, for Enthusiasts.


Ford Explorer Generation Guide

EF Swag Store 2016 Ford Explorer Forums Elite Membership Chat Room My Posts Reviews Explorer Photo Gallery
Go Back   Ford Explorer and Ranger Forums "Serious Explorations" > All Other Cars, Trucks, Motorcycles etc. > All Other Makes and Models

Notices

All Other Makes and Models For topics involving all other makes and models that do not fit into our new sub-forums.

2003 ford explorer xlt won't start with battery fully charged

Reply
 
Thread Tools
Old 01-07-2013, 09:43 AM   #1
ChuckFinley
2003 Ford Explorer
 
Join Date: Jan 2013
Posts: 3

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Original Poster)
Unhappy 2003 ford explorer xlt won't start with battery fully charged

I went to start my 2003 Ford Explorer sport xlt and it wouldn't start. No dash lights other than the theft light (flashing) lit up when i turned the key. No clicking from a froze starter or any noise at all. Now when i turned the key to the off position and took it out of the ignition i heard a lot of clicking noises coming from under the steering column from a black back. hard to see what it was since it is my daughter's car and the seat is way up toward the front and i can barely get in there. The Seat lumbar works, but i have yet to check other things out.
Has any heard of anything like this? we got the car off of someone and do not have the code for the keyless entry on the door. We do NOT have a remote for unlocking the doors. The power door locks do not work.
ChuckFinley is offline   Reply With Quote
( Join the Elite Explorers )

For only $20 per year you can become an Elite Explorer member. Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications really work without having to experiment on your own. Elite Explorer members can change the forum "styles" to eliminate most ads, including blue underlined links, and no ads on photos. Other benefits include the ability to store 1000 Private Messages, upload photo attachments directly to your posts and to our Photo Gallery and more. Join the Elite Explorers today.


Old 01-07-2013, 12:25 PM   #2
Blee1099
Evil Asian
Elkridge, MD
 
Blee1099's Avatar
91
 
Join Date: Mar 2002
Posts: 14,098

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
When you turn the key to the "ON" position without cranking, can you hear the fuel pump priming? With the key in the ignition is the theft light flashing rapidly, if so it probably indicates a issue with the PATS anti-theft system. A good locksmith or dealer may be the only options for repair if it is a issue with the PATS system. If you have a spare key, try using it.
Blee1099 is offline   Reply With Quote
Old 01-08-2013, 08:28 AM   #3
ChuckFinley
2003 Ford Explorer
 
Join Date: Jan 2013
Posts: 3

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Original Poster)
i do not hear anything when i turn the key to the ON position. I have to pull the battery and see if it has a full charge still and check that ticking noise again. that went off when i turned the key to the on position but i did not hear the fuel pump power up the last time i checked. The theft light turns out when the key is in this position. the theft blinks when the key is out of the ignition
ChuckFinley is offline   Reply With Quote
Old 01-08-2013, 12:46 PM   #4
ChuckFinley
2003 Ford Explorer
 
Join Date: Jan 2013
Posts: 3

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Original Poster)
turns out that battery had a short. I took it out and put a battery tester on it. BAD. took it back under warranty and got a new one. Vehicle is running again.

Although a battery could be showing fully charged, put it on a tester to see if there is a short in it people, words of wisdom
ChuckFinley is offline   Reply With Quote
Reply



Suggest this thread to friends:


Tags
ignition, starting problem, theft light
Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 + Explorer TSB's JDraper Stock 2011 - 2016 Ford Explorer Discussion 15 09-21-2014 05:35 PM
Ford Explorer & Ranger Solid Axle Swap - SAS - Registry Index Randall Explorer/Ranger Solid Axle Swap Registry 21 09-01-2014 07:50 PM
2003 Ford Explorer AWD XLT 4.6L STICKING THROTTLE Bar1 Stock 2002 - 2005 Explorers 1 02-19-2014 10:57 PM
2004 Ford Explorer 4.0 XLT wont start, engine turns over xchecko Stock 2002 - 2005 Explorers 3 12-23-2012 11:28 AM
Stock 1/4 mile and 0-60 times for almost all cars in production CHEESYPOOFS Need for Speed! 41 06-30-2009 08:10 PM



Join the "Elite Explorers" Today!



Search Explorer Forum


Top of Page

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:02 PM.



US Flag
We Support Our Troops!

Explore the site!


Copyright 2014 - 1996 Rick Horwitz Photography



Ford Motor Company is not involved in the management of this site in any way.



All tips on this site are for use at your own risk and discretion.

Modifying the suspension on any vehicle will cause changes to its handling characteristics.



Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.