Serious Explorations Ford Explorer and Ranger Message Board
#1 Resource for Ford Explorer and Ranger Owners - By Enthusiasts, for Enthusiasts.


Ford Explorer Generation Guide

EF Swag Store 2015 Ford Explorer Forums Elite Membership Chat Room My Posts Reviews Explorer Photo Gallery
Go Back   Ford Explorer and Ranger Forums "Serious Explorations" > Ford Explorer Ranger Repair - Troubleshooting - Modifications & Detailing Forums > Under the Hood

Notices

Under the Hood Ford Explorer and Ranger, Engine, troubleshooting, modifications, performance and accessories.

Engine stalls for no reason...HELP!!!

Reply
 
Thread Tools
Old 07-07-2002, 11:12 AM   #1
dbdb
Westminster, MD
93 Sport
 
Join Date: Jul 2002
Posts: 10

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Original Poster)
Angry Engine stalls for no reason...HELP!!!

Ok I have a 93 Sport Explorer.
The enigine stalls on me every so often for now reason. Yes the CEL light comes on, but goes away when I try to restart the engine. It wants to turn over, but nothing. 2 things I noticed:
1) There seems to be too much oil according to the dipstick, might have the wrong dip stick for that model don't know.
2) If I let the car sit for a while, and it varies how long, sometimes 2 hours, sometimes 24 hours, it will usually start right back up.
But eventually it will stall out again. I thought maybe the fuel filter, but no one can get a code to show them what the issue is. HELP please anyone! Thanx.
BTW, recent work done to my baby was having the Valve Modulator replaced because of a slipping tranny.
Thanks in advance.




__________________
Dan Bantner
dbdb Designs
Dream Big... Dream Bold!!!
http://dbdb.0catch.com
dbdb is offline   Reply With Quote
( Join the Elite Explorers )

For only $20 per year you can become an Elite Explorer member. Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose and fix problems yourself, and learn which modifications really work without having to experiment on your own. Elite Explorer members can change the forum "styles" to eliminate most ads, including blue underlined links, and no ads on photos. Other benefits include the ability to store 1000 Private Messages, upload photo attachments directly to your posts and to our Photo Gallery and more. Join the Elite Explorers today.


Old 07-07-2002, 12:57 PM   #2
mrboyle
I Drive By Brail
Fruita, CO
 
mrboyle's Avatar
'96 XLT '80 Toy
 
Join Date: Feb 1999
Posts: 4,156

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
It sounds like your fuel pump is going out. Next time this happens, check for fuel pressure at the injector rail. No pressure = replace pump.




__________________
Mike Boyle
ASE Certified Master Tech.
'92 XLT(RIP) 1980 Toyota PU
Quote:
Originally Posted by DiffWackDaddy
Some people go looking for God, others get broadsided by them
mrboyle is offline   Reply With Quote
Old 07-11-2002, 05:44 PM   #3
Ksharpe
Eureka, Missouri
2000 XLT
 
Join Date: Jul 2002
Posts: 2

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Check your idle selonoid.
Mine is stalling out, with a 4.0 SOHC, and a mechanic friend told me that this was also occurring on alot of the fords they work on. If you can find the selonoid, called the I.A.C. in Haynes, tap it lightly with a screwdriver to see if it loosens frees up the idle.
Ksharpe is offline   Reply With Quote
Old 07-11-2002, 05:48 PM   #4
jeremism30
Oxnard,ca
1995 Sport
 
Join Date: Jul 2002
Posts: 67

Vehicle Specs

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Idle speed controll motor.
The symtoms are:

1. The engine starts, but only with yyour foot on the gas. If you take your foot off it stops.

2. A bad idol speed control motor can also cause a waveyness in the engine.

3. The hotter the weather is the worse it is.

It's your Idal Speed Controll Motor. First call a dealership with your ven#, due to many models on all Fords have recalls. If there isn't a recall on it, first remove it and clean it inside and out. See if that works. If it doesn't then replace it. It's about 80-100 bucks i think for the part. I had the same problem, I first cleaned mine and it worked fine for a while, but now I think that I will end up replacing it. I think early 90's are the years that where recalled.
jeremism30 is offline   Reply With Quote
Reply



Suggest this thread to friends:



Join the "Elite Explorers" Today!



Search Explorer Forum


Top of Page

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:58 AM.



US Flag
We Support Our Troops!

Explore the site!


Copyright 2014 - 1996 Rick Horwitz Photography



Ford Motor Company is not involved in the management of this site in any way.



All tips on this site are for use at your own risk and discretion.

Modifying the suspension on any vehicle will cause changes to its handling characteristics.



Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.