Dismiss Notice



Register Today It's free! This box will disappear once registered!

02 xlt slip/bump on accel

Discussion in 'Stock 2002 - 2005 Explorers' started by tallfordguy, July 21, 2011.

^^Searches ExplorerForum.com^^
  1. tallfordguy

    tallfordguy New Member

    Joined:
    July 21, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Pittsburgh Pa.
    Year, Model & Trim Level:
    02 xlt
    New member here! Having an issue with my exploder and wondering if any of you have had this issue. 2002 Explorer w/124000 miles on acceleration from a stop or going up-hill, feel a slip or even bumping while accelerating. The tach does not jump nor do I have a MIL light. At first I thought trans problem but it "only" happens on accel or going up hills. Also, goes away if I push 4x4 high button when it does it. Did not notice this issue untill about 6,000 miles ago when I installed 4 new Firestone Destination AT's. Anyone have any input for this newbie?
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. fedyfedz

    fedyfedz Active Member

    Joined:
    April 26, 2010
    Messages:
    898
    Likes Received:
    2
    Trophy Points:
    16
    City, State:
    Suffolk County, NY
    Year, Model & Trim Level:
    2002 limited v8
    might be 4x4 control module, shows slight shuddering in 2nd or 3rd gear usually under load. Mine does this on occasion to.
     
  4. BigRondo

    BigRondo USMC 1371 Elite Explorer Moderator Emeritus

    Joined:
    February 15, 2010
    Messages:
    7,888
    Likes Received:
    7
    Trophy Points:
    48
    City, State:
    Worcester, MA
    Year, Model & Trim Level:
    2002 XLT V6 4x4
    Maybe a tranny filter & fluid change? Worked for me when I had this issue!
     






We Support Our Troops!