Dismiss Notice



Register Today It's free! This box will disappear once registered!

03' Ford Explorer NO heat or AC

Discussion in 'A/C & Heater systems - HVAC' started by reamer7, June 29, 2011.

  • Searches ExplorerForum.com
    1. reamer7

      reamer7 New Member

      Joined:
      June 29, 2011
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      KS
      Year, Model & Trim Level:
      03' Explorer
      I have an 03' Explorer I replaced the blend door actuator in January. It is now June I went and got in the truck after work and started it up and had no air what so ever. I checked heat, defrost, and A/C got nothing. Checked all fuses and relays and they are all good. I am just not sure if it is the blower that has went bad or if something else has failed? I need help cause it is hot here in Kansas and it will be another cold winter without heat too.
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.

    Share This Page







    We Support Our Troops!