Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

03 xlt headlight issues

Discussion in 'Stock 2002 - 2005 Explorers' started by Reaper666, January 8, 2011.

^^Searches ExplorerForum.com^^





  1. Reaper666

    Reaper666 New Member

    Joined:
    January 8, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Lainsburg, Michigan AKA The burg
    Year, Model & Trim Level:
    03 xlt
    I have a 03 explorer xlt. My high beams dont work. i've tried changing the bulbs and checked the fuses all is ok there. i think it might be the relay switch. i would be gratefully for any help.
     
  2. Support EF

    Elite Explorer 2 for 1 Sale! $20 for 2 years!

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. Tmac11

    Tmac11 New Member

    Joined:
    November 29, 2010
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Ypsilanti, Michigan
    Year, Model & Trim Level:
    2003 XLT
  4. BigRondo

    BigRondo USMC 1371 Elite Explorer Moderator Emeritus

    Joined:
    February 15, 2010
    Messages:
    7,886
    Likes Received:
    10
    Trophy Points:
    48
    City, State:
    Worcester, MA
    Year, Model & Trim Level:
    2002 XLT V6 4x4
    Welcome to the forum! :salute:

    Here is some info from my owner's manual. If you don't have an owner's manual, it can be downloaded here.

    I apologize for the size of the pics but I wanted you to be able to see them.

    There is 1 fuse & 1 relay related to the high beams located in the power distribution box located under the hood. #19 is a 20A Maxi Cartridge Fuse for the High Beam Relay, #49 is the High Beam Relay itself:

    [​IMG] [​IMG]
    [​IMG]

    This could also be related to the Multifunction Switch. Here is the How-To on replacing it.

    Hope this helps out. :biggthump
     

Share This Page







We Support Our Troops!