Dismiss Notice



Register Today It's free! This box will disappear once registered!

04 explorer 4.0 2wd trans questions

Discussion in 'Transmissions & Transfer Cases' started by jamesyarbrough, July 26, 2011.

^^Searches ExplorerForum.com^^





  1. jamesyarbrough

    jamesyarbrough New Member

    Joined:
    July 26, 2011
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    north texas
    Year, Model & Trim Level:
    2004
    hello just want to say i love the way the site is set up!! it only took me 15mins of reading to learn how to change my fluid and that i probably need to change the solenoid block. but i would like to run a few things over with you guys just make sure im right.

    the transmission(im not sure the model number) revs high in between shifts sometimes. after hard breaking or extended idling it will not engage instantly into drive or reverse. i hit the pedal it revs up and then slam's into gear, almost like neutral bombing it.

    it has 116k on it and i had the dealer change the fluid at 90k even tho the manual said wait until 150k.

    so does this seem right? should i change the solenoids or is it just varnish build up that is the problem?

    where can i buy solenoids at a good price? is it a dealer only item? whats the going rate?

    is it possible this transmission could benefit more from a top tier ATF like redline or royal purple or should i just stick to Merc V?

    thanks very much for any insite

    james
     
  2. Support EF

    Special! - 2 Year Elite membership now through July 24 $20!

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. jamesyarbrough

    jamesyarbrough New Member

    Joined:
    July 26, 2011
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    north texas
    Year, Model & Trim Level:
    2004
    just one more thing from what i read you guys have CEL come on when the trans acts up? mine never comes on. only once when i needed a new EGR.

    the more i read, the more questions i have lol
    it looks like it could be a servo problem and might need sleeves? so if i pull the Solenoid block and it ohms out good where do i go from there?
     
  4. jamesyarbrough

    jamesyarbrough New Member

    Joined:
    July 26, 2011
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    north texas
    Year, Model & Trim Level:
    2004
    never mind the local trans shop is going to rebuild it for 1700 installed with 1 year warranty and fixing the valvebody and servo problems.

    thanks for the help

    NOT
     

Share This Page







We Support Our Troops!