Dismiss Notice



Register Today It's free! This box will disappear once registered!

04 explorer stalls sometimes

Discussion in 'Stock 2002 - 2005 Explorers' started by Rfowlkes81, February 27, 2013.

^^Searches ExplorerForum.com^^
  1. Rfowlkes81

    Rfowlkes81 New Member

    Joined:
    February 23, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    New Orleans
    Year, Model & Trim Level:
    2004 ford explorer
    hey I just bought a 04 explorer and i'm new to this forum so any help on my issue would be greatly appreciated. so here's the deal, sometimes my truck dies while i'm stopped. i'll come to a red light and stop completly and my truck will stall. it doesn't sputter or give any sighns of problems. it just shuts off as if i turned it off. the service engine light has come on recently and i've not had a chance to see what codes are coming up. this happens about once every couple of weeks and sometimes when i start the truck it idles really rough like it is misfiring on a cylinder and the wrench light comes on. but when i turn the truck off and restart it the wrench light goes away and the truck runs fine. any help would be great. Has anyone had a similar problem and if so how did you fix it.
    I was thinking that maybe the problem is with throttle position sensor or my MAF sensor. i have also been trying to keep a eye on if it stalls when i have my A\C on. it's just wierd the way it kills when i'm only stopped and the fact that the only way i know the truck died is because all my instrument cluster lights come on.
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


  3. mikey4563

    mikey4563 Member

    Joined:
    October 28, 2012
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Camas, WA
    Year, Model & Trim Level:
    2004 Ford Explorer XLT
    welcome to the forums! the best way to go is to figure out what codes your truck is giving you and come back and post them here so we have a better idea of what it could possibly be. good luck!
     
  4. HiImBrian

    HiImBrian Well-Known Member

    Joined:
    September 4, 2009
    Messages:
    1,429
    Likes Received:
    3
    Trophy Points:
    48
    City, State:
    St. Petersburg, Florida
    Year, Model & Trim Level:
    2003 Explorer Eddie Bauer
    Search in here for the Idle Air Control (IAC) Valve thread. They provide the engine with the proper amount of air it requires to stay at idling RPM. Which, is why it stalls out when you let off the gas and come to a stop. They tend to stick closed and suffocate the engine. When mine starts acting up it is almost as if my explorer has the hiccups. They are about $80 and very simple to replace. Just be sure to buy a Motorcraft part, they are picky.
     
  5. unclemeat

    unclemeat Well-Known Member

    Joined:
    October 20, 2002
    Messages:
    3,082
    Likes Received:
    4
    Trophy Points:
    48
    City, State:
    Richmond, VA
    Year, Model & Trim Level:
    91 sport
    My 05 had a stalling proble. It would stall a low speeds when the cruse control was on. It was still under warrenty at the time. The dealer reflashed the computer with a newer engine operating program and it has not happend since.

    Your problem sounds like it needs either a new fuel filter or else new plugs and wires.
     






We Support Our Troops!