Dismiss Notice



Register Today It's free! This box will disappear once registered!

07 transmission problem

Discussion in 'Stock 2006 -2010 Explorers' started by Chris Schroeder, July 25, 2016.

  • Searches ExplorerForum.com
    1. Chris Schroeder

      Chris Schroeder New Member

      Joined:
      July 25, 2016
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      LaPlata
      Year, Model & Trim Level:
      2007 Ford Explorer
      The situation that I am having with my 07 explorer is in the transmission. The trans will run through all gears while in drive, if I put the trans in neutral or reverse it will not ingage in neither, the trans will stay in the drive gear although it will not move when you press the gas pedal.

      I have replaced the fluid and filter and that has not helped l, I am thinking it might be the solenoids??Any help with this would be appreciated.

      Thanks,
      Chris
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.

    Share This Page







    We Support Our Troops!