Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

1995 Explorer won't start

Discussion in 'Stock 1995 - 2001 Explorers' started by sfshon, April 1, 2009.

^^Searches ExplorerForum.com^^



Do Not Sell My Personal Information



  1. sfshon

    sfshon New Member

    Joined:
    April 1, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    1995 XLT
    My baby has been sitting up in storage for about three years now as I have been deployed. Father in-law went to check on her and she won't even blink.

    He charged the battery, tried to jump her, bought a new battery and she still won't turn over and no lights anywhere to be seen and no horn either.

    What gives? Anybody and everybody chime on in. What should I check and what's the worse case scenario?
     
  2. Support EF

    Join the Elite Explorers for $20.

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no advertisements, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. Dopler174

    Dopler174 Official Welcome Committe Moderator Emeritus

    Joined:
    February 21, 2005
    Messages:
    4,999
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Greensboro, NC
    Year, Model & Trim Level:
    1993 XLT 4X4
    Sounds like you are headed in the correct direction. Try the battery terminals and check all your fuses.
     
  4. 924dr4x4

    924dr4x4 Active Member

    Joined:
    October 29, 2007
    Messages:
    518
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    philly,pa
    Year, Model & Trim Level:
    92 xlt 4 door 4x4
    maybe a bad ground wire somewhere?since u replaced the battery..u should also replace the alternator also and go from there..if still nothing,then start checking the ground wires to the chassis and other locations
     
  5. marragtop

    marragtop Well-Known Member

    Joined:
    April 14, 2001
    Messages:
    2,075
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    balt, md
    Year, Model & Trim Level:
    91, 92, 95, and 2000 xlts
    If you are getting nothing (no dash lights, horn, etc) with a hot battery, then it has to be connection related. Battery cables can corrode from the inside. Check them carefully and the grounds. I would not consider an alternator until you have some sign of juice.
     

Share This Page







We Support Our Troops!