Dismiss Notice



Register Today It's free! This box will disappear once registered!

1998 Explorer. A/C blows hot all of the time.

Discussion in 'A/C & Heater systems - HVAC' started by vacdude, July 23, 2011.

  • Searches ExplorerForum.com
    1. vacdude

      vacdude New Member

      Joined:
      August 15, 2009
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Minnesota
      Year, Model & Trim Level:
      '98 xlt
      Hi - I just registered and have seen some posts regarding the Blend Door. Not sure if this is the problem with mine though. One day my ac was working just fine and next day it would only blow hot air even on Max AC. The posts regarding the blend door indicate that it will blow cool on Max AC if it is the problem but mine blows hot all the time.... Could it be a relay? Any thoughts? Thanks!!
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. BrooklynBay

      BrooklynBay Moderator & long time member. Staff Member Moderator Elite Explorer

      Joined:
      November 11, 2005
      Messages:
      52,495
      Likes Received:
      248
      Trophy Points:
      93
      City, State:
      Brooklyn, NY
      Year, Model & Trim Level:
      88 89 93 95 96 Aerostars
    4. blazin8556

      blazin8556 Active Member

      Joined:
      October 17, 2010
      Messages:
      215
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Stalkin' your mom....
      Year, Model & Trim Level:
      1997 XLT AWD 5.0
      mine is currently doing this. i pulled my blend door servo off and found the top of the door axle is broken. some unbolt (kinda a pain) and some unclip (i was lucky) then you can put your finger in there and feel it.
       

    Share This Page







    We Support Our Troops!