Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

2.0 EB issues at WOT

Discussion in 'Stock 2011 - 2019 Ford Explorer Discussion' started by dhonnoll, January 10, 2020.

^^Searches ExplorerForum.com^^



Do Not Sell My Personal Information



  1. dhonnoll

    dhonnoll New Member

    Joined:
    July 7, 2009
    Messages:
    45
    Likes Received:
    3
    Trophy Points:
    8
    City, State:
    Nesbit, MS
    Year, Model & Trim Level:
    2013 Limited
    I have a 2013 2.0 Ecoboost. About a year and a half ago not long after we bought it I replaced the turbo charger due to the lack of boost error and the wastegate was rattling and just basically worn out. Problem solved mostly. For the daily driver it is, it is fine. If I ease into the gas it is fine. If I Stomp on it WOT or mash hard to get on the interstate it will rev up, fall flat, dead miss. CEL flashes (which would be a dead miss) and it has no power no get up even when not dead missing. If I ease into it, smooth power. Is this just How it is? or do I maybe have condensation in the intercooler as I am seeing a lot of the F-150 EBs have?
    New plugs,
    New turbo charger.
    Clean K&N filter
    Cleaned the MAF
    Cleaned the heads with a spray in type head cleaner that is supposed to be turbo safe.

    No CELs just when you stomp on it especially when it is already in higher gears it just falls flat will downshift but misses. I know it isn't a race vehicle but I should be able to go full throttle if I wish with no dead misses.
     
  2. Support EF

    Join the Elite Explorers for $20.

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. whimsey

    whimsey Member

    Joined:
    April 6, 2017
    Messages:
    96
    Likes Received:
    9
    Trophy Points:
    8
    City, State:
    sparta, nj
    Year, Model & Trim Level:
    2017 XLT
    We have a 2017 2,3 EB Explorer. It's never "liked" a stomped full throttle, it usually just falls flat, no to very poor acceleration. Like you, if we accelerate smoothly it goes great. There are no CEL or stored codes. So that's what we do now. In the "old day" there was turbo lag with sudden wot throttle. I thought they that would have been "fixed" by now but maybe not. Since we know that smooth but rapid throttle produces rapid acceleration if needed that's what we do.

    Whimsey
     

Share This Page







We Support Our Troops!